X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Isithangami Sabeseki

MUST be able to connect in spite of "site uses HTTP Strict Transport Security (HSTS)"

Kuphostiwe

FF MUST FIND A WORKAROUND FOR THIS ERROR: "The owner of www.xxxxx.blogspot.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website. This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox may only connect to it securely. As a result, it is not possible to add an exception for this certificate."

Absolutely not acceptable that FF prevents a user from doing what he desires to do. I'm not using any 3rd party security stuff that would demand certificates.

Maybe the blog owner has created his page using some code that conflicts with the higher doman, but there is no way to TELL him since I can't see the page... It is up to FF to somehow workaround this so that I, the USER, can control my tool. An uncontrollable tool is at best useless & at worst dangerous

FF MUST FIND A WORKAROUND FOR THIS ERROR: "The owner of www.xxxxx.blogspot.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website. This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox may only connect to it securely. As a result, it is not possible to add an exception for this certificate." Absolutely not acceptable that FF prevents a user from doing what he desires to do. I'm not using any 3rd party security stuff that would demand certificates. Maybe the blog owner has created his page using some code that conflicts with the higher doman, but there is no way to TELL him since I can't see the page... It is up to FF to somehow workaround this so that I, the USER, can control my tool. An uncontrollable tool is at best useless & at worst dangerous

Isisombululo esikhethiwe

VerizonSucks said

I played with turning HTTPS Everywhere on & off... it noticed that the option to "turn it off for this site" has no effect either -- when I Reload the same FireFox blocking comes up.

Turning it off would let you use HTTP instead of HTTPS on the address. But you need to do the edit yourself.

Funda le mpendulo ngokuhambisana nalesi sihloko 0
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:60.0) Gecko/20100101 Firefox/60.0

Eminye Imininingwane

Tyler Downer
  • Top 25 Contributor
  • Moderator
1503 izisombululo 10451 izimpendulo
Kuphostiwe

Please update to Firefox 66.0.5 and let us know if you still have issues.

Please update to Firefox 66.0.5 and let us know if you still have issues.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
FredMcD
  • Top 10 Contributor
4074 izisombululo 56842 izimpendulo
Kuphostiwe

There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connection certificates and send their own.

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

Websites don't load - troubleshoot and fix error messages

http://kb.mozillazine.org/Error_loading_websites

What do the security warning codes mean


  • MOZILLA_PKIX_ERROR_MITM_DETECTED
  • uses an invalid security certificate SSL_ERROR_BAD_CERT_DOMAIN
  • configured their website improperly

How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER

There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connection certificates and send their own. https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message https://support.mozilla.org/en-US/kb/connection-untrusted-error-message [https://support.mozilla.org/en-US/kb/websites-dont-load-troubleshoot-and-fix-errors?redirectlocale=en-US&redirectslug=Error+loading+web+sites Websites don't load - troubleshoot and fix error messages] http://kb.mozillazine.org/Error_loading_websites [https://support.mozilla.org/en-US/kb/what-does-your-connection-is-not-secure-mean What do the security warning codes mean] *MOZILLA_PKIX_ERROR_MITM_DETECTED *uses an invalid security certificate SSL_ERROR_BAD_CERT_DOMAIN *configured their website improperly How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8314 izisombululo 68040 izimpendulo
Kuphostiwe

Hi VerizonSucks, do you use HTTPS Everywhere or a similar extension that upgrades HTTP to HTTPS?

I think there is an error in the link. Try it without the www. in the URL.

When you do not use HTTPS, the www subdomain is redirected to a URL without www.

However, when you use HTTPS, there is a certificate error because Google's global certificate covers:

*.blogspot.com  

but not

*.*.blogspot.com

(not sure that would be legal?).

So the redirect fails because a non-matching certificate is sent back.

But this problem should not arise if you use the official URL of this Blogspot site instead of one with an extra www on the front.

Hi VerizonSucks, do you use HTTPS Everywhere or a similar extension that upgrades HTTP to HTTPS? I think there is an error in the link. Try it without the <code>www.</code> in the URL. When you do ''not'' use HTTPS, the www subdomain is redirected to a URL without www. However, when you use HTTPS, there is a certificate error because Google's global certificate covers: *.blogspot.com but not *.*.blogspot.com (not sure that would be legal?). So the redirect fails because a non-matching certificate is sent back. But this problem should not arise if you use the official URL of this Blogspot site instead of one with an extra www on the front.

Okulungisiwe ngu jscher2000

Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

I do use HTTPS Everywhere, but I disabled it.

The address in the URL bar is https://www.xxxx.blogspot.com/ of course the xxxx is redacted for privacy.

I played with turning HTTPS Everywhere on & off... it noticed that the option to "turn it off for this site" has no effect either -- when I Reload the same FireFox blocking comes up.

I'm on the FF Ver 60.6.3 esr which is the latest esr. I'm running OSX 10.11.16 El Capitan.

I do use HTTPS Everywhere, but I disabled it. The address in the URL bar is https://www.xxxx.blogspot.com/ of course the xxxx is redacted for privacy. I played with turning HTTPS Everywhere on & off... it noticed that the option to "turn it off for this site" has no effect either -- when I Reload the same FireFox blocking comes up. I'm on the FF Ver 60.6.3 esr which is the latest esr. I'm running OSX 10.11.16 El Capitan.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Removing the www makes the site load. That's weird... since when do URLs function without being prefixed by www?

Removing the www makes the site load. That's weird... since when do URLs function without being prefixed by www?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8314 izisombululo 68040 izimpendulo
Kuphostiwe

VerizonSucks said

Removing the www makes the site load. That's weird... since when do URLs function without being prefixed by www?

It's not that weird; Twitter doesn't use www. Sites like mail.yahoo.com do not use www.

The problem here is there is a redirect on the www address that works on HTTP, but it can't work on HTTPS because the certificate on the redirector doesn't match the individual sites.

''VerizonSucks [[#answer-1222550|said]]'' <blockquote> Removing the www makes the site load. That's weird... since when do URLs function without being prefixed by www? </blockquote> It's not ''that'' weird; Twitter doesn't use www. Sites like mail.yahoo.com do not use www. The problem here is there is a redirect on the www address that works on HTTP, but it can't work on HTTPS because the certificate on the redirector doesn't match the individual sites.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8314 izisombululo 68040 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

VerizonSucks said

I played with turning HTTPS Everywhere on & off... it noticed that the option to "turn it off for this site" has no effect either -- when I Reload the same FireFox blocking comes up.

Turning it off would let you use HTTP instead of HTTPS on the address. But you need to do the edit yourself.

''VerizonSucks [[#answer-1222549|said]]'' <blockquote> I played with turning HTTPS Everywhere on & off... it noticed that the option to "turn it off for this site" has no effect either -- when I Reload the same FireFox blocking comes up. </blockquote> Turning it off would let you use HTTP instead of HTTPS on the address. But you need to do the edit yourself.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

So a general solution is to see if removing (or maybe adding) the www makes the site work.

The FF error msg ought to give hints like that.

So a general solution is to see if removing (or maybe adding) the www makes the site work. The FF error msg ought to give hints like that.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8314 izisombululo 68040 izimpendulo
Kuphostiwe

VerizonSucks said

So a general solution is to see if removing (or maybe adding) the www makes the site work. The FF error msg ought to give hints like that.

Firefox doesn't usually suggest that you have the wrong address unless there is no response from the server or the server says the page was not found. If you are using a link you found in search results or got from the site, usually it's a good address.

''VerizonSucks [[#answer-1222555|said]]'' <blockquote> So a general solution is to see if removing (or maybe adding) the www makes the site work. The FF error msg ought to give hints like that. </blockquote> Firefox doesn't usually suggest that you have the wrong address unless there is no response from the server or the server says the page was not found. If you are using a link you found in search results or got from the site, usually it's a good address.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

This address is embededded in a blog in the "other blogs I follow" section. Probably dates back to before HTTPS existed.

This address is embededded in a blog in the "other blogs I follow" section. Probably dates back to before HTTPS existed.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.