X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I want to get rid of the dropdown search bar permanently.

Kuphostiwe

I did some extensive googling to rid myself of this stupid "feature", but none of them has brought me any luck. How do I permanently delete this? I don't want it to give me any suggestions, nor do I want it to search. If I wanted to search I'd visit Google. All I want my adress bar to do is exactly nothing, except being there.

I've tried deleting the search engines in tools, or options or whatever it is you call it, one by one but it refuses to let me delete the last one; as though there MUST be an annoying search engine enabled. Please help me remove this, by force if needed.

Thank you.

I did some extensive googling to rid myself of this stupid "feature", but none of them has brought me any luck. How do I permanently delete this? I don't want it to give me any suggestions, nor do I want it to search. If I wanted to search I'd visit Google. All I want my adress bar to do is exactly nothing, except being there. I've tried deleting the search engines in tools, or options or whatever it is you call it, one by one but it refuses to let me delete the last one; as though there MUST be an annoying search engine enabled. Please help me remove this, by force if needed. Thank you.

Isisombululo esikhethiwe

You can use code in userChrome.css remove all suggestions from the address bar drop down list. Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* remove all items from the urlbar drop down */
#PopupAutoCompleteRichResult {display:none !important;}


It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close and restart Firefox when you create or modify the userChrome.css file.

Funda le mpendulo ngokuhambisana nalesi sihloko 1

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Eminye Imininingwane

WestEnd
  • Top 25 Contributor
60 izisombululo 5379 izimpendulo
Kuphostiwe

Impendulo Ewusizo

What does your screenshot of your search option look like?

What does your screenshot of your search option look like?

Umnikazi wombuzo

Like so:

Like so:

Umnikazi wombuzo

Surely there's a way to forcefully remove that last one? Surely Mozilla wouldn't force this ridiculous dropdown menu on their users?

Surely there's a way to forcefully remove that last one? Surely Mozilla wouldn't force this ridiculous dropdown menu on their users?
Claudy 0 izisombululo 3 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Hi, I'm a user too, but as I understand it, the dropdown from url adress bar shows hits from your Chronic and from your bookmarks. Under settings / Search you can customize search engines and also choose if a search shall be shown in adress url bar or not and if you will have a seperat search field or only use the adress bar for it..

Hi, I'm a user too, but as I understand it, the dropdown from url adress bar shows hits from your Chronic and from your bookmarks. Under settings / Search you can customize search engines and also choose if a search shall be shown in adress url bar or not and if you will have a seperat search field or only use the adress bar for it..

Umnikazi wombuzo

What's a chronic? And no bookmarks ever appeared in my URL bar before, so that's not the problem either.

As you can see by the attached picture, I already "customized" search engines by deleting them, except it won't let me delete that last one. I don't want any dropdown menu to appear at all when I start typing URL's, there must be a way to fix this.

EDIT: And, of course, I unticked the "show search results" as well, but it still shoves it in my face. It really needs to go.

What's a chronic? And no bookmarks ever appeared in my URL bar before, so that's not the problem either. As you can see by the attached picture, I already "customized" search engines by '''deleting''' them, except it won't let me delete that last one. I don't want any dropdown menu to appear at all when I start typing URL's, there must be a way to fix this. EDIT: And, of course, I unticked the "show search results" as well, but it still shoves it in my face. It really needs to go.

Okulungisiwe ngu Irrelevant

Claudy 0 izisombululo 3 izimpendulo
Kuphostiwe

With Chronic I meant the browsing history ;-) Okay, there is a second option too Options > Privacy & Security - Address bar, and deselect one or more options in addition.

More possibilities I don't know, sorry.

With Chronic I meant the browsing history ;-) Okay, there is a second option too Options > Privacy & Security - Address bar, and deselect one or more options in addition. More possibilities I don't know, sorry.
McCoy
  • Top 10 Contributor
534 izisombululo 5035 izimpendulo
Kuphostiwe

Hello Irrelevant,

Would you please do this :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar :

browser.urlbar.oneOffSearches and set its value to false

Then type in the search bar keyword.enabled and set its value to false

Then close and restart Firefox.

I hope that does what you are looking for .....

Hello Irrelevant, Would you please do this : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar : '''browser.urlbar.oneOffSearches''' and set its value to '''false''' Then type in the search bar '''keyword.enabled''' and set its value to '''false''' Then close and restart Firefox. I hope that does what you are looking for .....

Okulungisiwe ngu McCoy

Umnikazi wombuzo

Thanks guys.

Claudy: Adress bar thing was already disabled in Privacy & Security.

McCoy: First one was already set to false. The second was set to true, but I set it to false and restarted the browser. I still get a dropdown menu when I begin typing an URL. Is there another way?

Thanks guys. Claudy: Adress bar thing was already disabled in Privacy & Security. McCoy: First one was already set to false. The second was set to true, but I set it to false and restarted the browser. I still get a dropdown menu when I begin typing an URL. Is there another way?
McCoy
  • Top 10 Contributor
534 izisombululo 5035 izimpendulo
Kuphostiwe

Irrelevant said

McCoy: First one was already set to false. The second was set to true, but I set it to false and restarted the browser. I still get a dropdown menu when I begin typing an URL. Is there another way?

You may already have done this, but just in case - would you please take a look at this article and scroll down to the section :

Enabling or disabling search suggestions

Does that work  ?

''Irrelevant [[#answer-1195460|said]]'' <blockquote> McCoy: First one was already set to false. The second was set to true, but I set it to false and restarted the browser. I still get a dropdown menu when I begin typing an URL. Is there another way? </blockquote> You may already have done this, but just in case - would you please take a look at this article and scroll down to the section : [https://support.mozilla.org/en-US/kb/search-suggestions-firefox Enabling or disabling search suggestions] Does that work ?

Umnikazi wombuzo

Yes, it is already disabled. :(

Yes, it is already disabled. :(
McCoy
  • Top 10 Contributor
534 izisombululo 5035 izimpendulo
Kuphostiwe

Irrelevant said

Yes, it is already disabled. :(

All your settings in Options (both Search and Privacy & Security, under 'Address Bar') are correct; on the "about:config" page you have "keyword.enabled" = false, and you still get search suggestions  ?

''Irrelevant [[#answer-1195478|said]]'' <blockquote> Yes, it is already disabled. :( </blockquote> All your settings in Options (both Search and Privacy & Security, under 'Address Bar') are correct; on the "about:config" page you have "keyword.enabled" = false, and you still get search suggestions ?

Umnikazi wombuzo

Yes, McCoy ... ever since the last update. It is very annoying.

Yes, McCoy ... ever since the last update. It is very annoying.
cor-el
  • Top 10 Contributor
  • Moderator
17473 izisombululo 157934 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

You can use code in userChrome.css remove all suggestions from the address bar drop down list. Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* remove all items from the urlbar drop down */
#PopupAutoCompleteRichResult {display:none !important;}


It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close and restart Firefox when you create or modify the userChrome.css file.

You can use code in userChrome.css remove all suggestions from the address bar drop down list. Add code to the <b>userChrome.css</b> file below the default @namespace line. *http://kb.mozillazine.org/userChrome.css *https://www.userchrome.org/how-create-userchrome-css.html *https://www.userchrome.org/what-is-userchrome-css.html <hr> <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ /* remove all items from the urlbar drop down */ #PopupAutoCompleteRichResult {display:none !important;} </nowiki></pre> ---- It is not that difficult to create userChrome.css if you have never used it. The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder. *https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name <u>chrome</u> in this folder (name is all lowercase). In the <b>chrome</b> folder you need to create a text file with the name <u>userChrome.css</u> (name is case sensitive). In this userChrome.css text file you paste the text posted. In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named <i>userChrome.css.txt</i>. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as". You need to close and restart Firefox when you create or modify the userChrome.css file.

Umnikazi wombuzo

Thank you! That worked. It is now gone. Oh joy. :D

Thank you! That worked. It is now gone. Oh joy. :D

Umnikazi wombuzo

Well, here we go again. Another Firefox update, and the stupid dropdown menu has returned when typing something in the search bar. The userChrome.css file does nothing.

How do I get rid of it this time? Please, and thank you.

Well, here we go again. Another Firefox update, and the stupid dropdown menu has returned when typing something in the search bar. The userChrome.css file does nothing. How do I get rid of it this time? Please, and thank you.

Okulungisiwe ngu Irrelevant

cor-el
  • Top 10 Contributor
  • Moderator
17473 izisombululo 157934 izimpendulo
Kuphostiwe

Use this code in Firefox 68+:

#urlbar-results { display:none!important; }
Use this code in Firefox 68+: #urlbar-results { display:none!important; }

Umnikazi wombuzo

cor-el said

Use this code in Firefox 68+: #urlbar-results { display:none!important; }

Thank you, but sorry - where do I put this code? In about:config? EDIT: Nevermind, it's for the userChrome.css file, still. My bad.

Thank you very much!

''cor-el [[#answer-1236739|said]]'' <blockquote> Use this code in Firefox 68+: #urlbar-results { display:none!important; } </blockquote> Thank you, but sorry - where do I put this code? In about:config? EDIT: Nevermind, it's for the userChrome.css file, still. My bad. Thank you very much!

Okulungisiwe ngu Irrelevant