Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox does not show a chat window for a website but it does show in Chrome; how can I get chats to show?

  • 2 uphendule
  • 1 inale nkinga
  • 2078 views
  • Igcine ukuphendulwa ngu Caitlin

more options

A website uses a chat for user support. When I'm using Chrome, the chat window shows and can be used. When I'm in Firefox, the chat window does not exist. (Mac 10.13.4, FF 59.0.2, 64-bit)

This page should show the chat button in the lower right-hand corner: https://app.smartbnb.io/login

Thanks, Caaitlin

Isisombululo esikhethiwe

Hi Caaitlin, one possible reason the chat bubble might be blocked is if Firefox is applying Tracking Protection to the page. Do you see a shield icon toward the left end of the address bar? I'm attaching a screenshot of what happens when I have the feature enabled/disabled. More info on managing the feature in this article: What happened to Tracking Protection?.

If that's not it, how about extensions that block content in pages? For example, Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix.

These extensions usually provide toolbar buttons to manage blocked content in a page, so that's the first thing to try.

If necessary, you can view, disable, and often configure or remove extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions that Firefox installs on its own are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that could be blocking content? If in doubt, disable.

Any improvement?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (2)

more options

Isisombululo Esikhethiwe

Hi Caaitlin, one possible reason the chat bubble might be blocked is if Firefox is applying Tracking Protection to the page. Do you see a shield icon toward the left end of the address bar? I'm attaching a screenshot of what happens when I have the feature enabled/disabled. More info on managing the feature in this article: What happened to Tracking Protection?.

If that's not it, how about extensions that block content in pages? For example, Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix.

These extensions usually provide toolbar buttons to manage blocked content in a page, so that's the first thing to try.

If necessary, you can view, disable, and often configure or remove extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions that Firefox installs on its own are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that could be blocking content? If in doubt, disable.

Any improvement?

more options

It was the tracking protection. As soon as I turned it off, the chat window appeared.

Thank you! Caaitlin