Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

The scrolling is choppy & staggered

  • 5 uphendule
  • 1 inale nkinga
  • 3 views
  • Igcine ukuphendulwa ngu TyDraniu

more options

Hi,

I've noticed the positioning of elements when tied to scroll is very choppy in the new Quantum Firefox. I didn't notice this in the old Firefox.

https://aspirestar.com/music/index.html The above website uses scroll based positioning to create a parallax effect. Up until the old Firefox, the scroll was smooth. After the upgrade to Quantum the elements which gets positioned on scroll is very choppy. This was not the case in the old Firefox as well as current chrome and every other browser.

Also when you scroll using a trackpad or using the scroll bar there is no choppiness. Only when using the scroll wheel on the mouse this issue occurs.

Now here is the weird thing which further hints this is a firefox issue. When you open the "Developer Tools" and scroll, the choppiness disappears. When you close the developer tools and scroll, the choppiness returns.

Could Firefox look into this issue soon.


Thanks, Codey

All Replies (5)

more options

Hello, try turning off Smooth Scrolling.

To do this:

1. Navigate to about:preferences by typing it in your URL bar. 2. Scroll down until you see Browsing 3. Uncheck 'Use Smooth Scrolling'

Did this solve your problem? If it did, please mark as solution.

more options

Hi MkII,

I turned off the Smooth Scrolling, and now both the parallaxed and the other(non parallaxed) elements of the page move in steps. Which is why I think the smooth scroll is enabled by default.

When the developers were coding quantum I think the code responsible for smooth CSS positioning of elements on scroll events(with smooth scrolling enabled) was taken out or messed up.

I forgot to mention this before.. I'm on firefox 57.01 on Ubuntu 14.04LTS


Codey

more options

Hello Codey,

I think that you should report the issue on https://bugzilla.mozilla.org/enter_bug.cgi

more options

Thanks, I've just opened a bug in bugzilla.

more options