X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Removed certificate from website. And firefox keeps adding the s back in the address? How do I stop firefox from doing that?

Kuphostiwe

Removed certificate from website. So it went from "https://" to "http://". And firefox keeps adding the s back in when I type the address in the address bar and using links. How do I stop firefox from adding the "s" back in? I tried deleting cookies, clearing the cache, and deleted firefox. Then I reinstalled firefox and it didn't fix it.

Removed certificate from website. So it went from "https://" to "http://". And firefox keeps adding the s back in when I type the address in the address bar and using links. How do I stop firefox from adding the "s" back in? I tried deleting cookies, clearing the cache, and deleted firefox. Then I reinstalled firefox and it didn't fix it.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Intel web components updater - Installs and updates the Intel web components
  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • Creative Cloud Desktop Plugin.v_3_0_0_0
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • Citrix Online App Detector Plugin
  • Google Update
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 23.0 r0
  • VLC media player Web Plugin 2.0.0-rc

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

Eminye Imininingwane

jl 0 izisombululo 9 izimpendulo
Kuphostiwe

This happens to me off and on too - no idea why (FF adding s to the http). Eventually it stops for me for a relatively long time, then comes back when I've almost forgotten about it. It looked almost to me like some 'learning' program thought I mis-typed. It happens to me with exactly one web address (not the same one).

This happens to me off and on too - no idea why (FF adding s to the http). Eventually it stops for me for a relatively long time, then comes back when I've almost forgotten about it. It looked almost to me like some 'learning' program thought I mis-typed. It happens to me with exactly one web address (not the same one).
FredMcD
  • Top 10 Contributor
4245 izisombululo 59390 izimpendulo
Kuphostiwe

Impendulo Ewusizo

The website is secured, so the link changes adding the S to show this. Is there a reason this bothers you?

The website is secured, so the link changes adding the S to show this. Is there a reason this bothers you?

Umnikazi wombuzo

FredMcD said

The website is secured, so the link changes adding the S to show this. Is there a reason this bothers you?
I removed the certificate, and firefox keeps adding the s to the address.  And says this page is not secure and I'm unable to go to the site. The site works fine on explorer,chrome and opera. I just can't see the page on firefox?
''FredMcD [[#answer-943673|said]]'' <blockquote> The website is secured, so the link changes adding the S to show this. Is there a reason this bothers you? </blockquote> I removed the certificate, and firefox keeps adding the s to the address. And says this page is not secure and I'm unable to go to the site. The site works fine on explorer,chrome and opera. I just can't see the page on firefox?
jscher2000
  • Top 10 Contributor
8685 izisombululo 71008 izimpendulo
Kuphostiwe

Hi gilberteaz, I assume you are not using HTTPS Everywhere or a similar extension, this is just normal Firefox.

So one possible explanation is:

Strict Transport Security

Are you getting an error page? If so, does it include this phrase:

"This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely."

If so, unfortunately, that will affect all prior visitors to the site: their Firefox has stored that setting. It can be cleared, but the methods are not very convenient:

(1) Remove all information about the site from Firefox, or (2) Edit or remove Firefox's settings file which stores HSTS information

Forget About This Site

Firefox offers a way to remove ALL DATA for a site, including the saved HSTS flag AND cached pages, history entries, cookies, bookmarks, and site-specific permissions. For a casual visitor, this method might be fine, but it's probably not a good idea for you.

If you want to try it:

  • Open the Library dialog to your history, either
    • Windows: Ctrl+Shift+h
    • History menu > "Show All History"
  • right-click a history entry for the site and choose "Forget About This Site"

That might take several moments if you have a large cache and a traditional spinning hard drive. There is no "Undo" for this so be sure you want to do it!

Your HTTP address should no longer get redirected to HTTPS (if it is, it could be on the server).

Edit or Remove Settings File

Firefox keeps HSTS flags and related data in a settings file named "SiteSecurityServiceState.txt" in your currently active profile folder. This is a plain text file you could edit, or if you remove it, Firefox will rebuild it as you revisit those sites. While there is some site data in here that perhaps you might not want to lose, I don't think it's crucial.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button (on Mac: Show in Finder). This should launch a new window listing the various files and folders in your profile folder.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename SiteSecurityServiceState.txt to something like SiteSecurityServiceState.old (or if your Windows still has the default setting to hide the .txt extension, it might be simpler to rename it to SiteSecurityServiceState-old).

Start Firefox back up again, and when you get the certificate error page, you now should see the Add Exception button.

Hi gilberteaz, I assume you are not using HTTPS Everywhere or a similar extension, this is just normal Firefox. So one possible explanation is: '''Strict Transport Security''' Are you getting an error page? If so, does it include this phrase: "This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely." If so, unfortunately, that will affect all prior visitors to the site: their Firefox has stored that setting. It can be cleared, but the methods are not very convenient: (1) Remove all information about the site from Firefox, or (2) Edit or remove Firefox's settings file which stores HSTS information '''''Forget About This Site''''' Firefox offers a way to remove ALL DATA for a site, including the saved HSTS flag AND cached pages, history entries, cookies, bookmarks, and site-specific permissions. For a casual visitor, this method might be fine, but it's probably not a good idea for you. If you want to try it: * Open the Library dialog to your history, either ** ''Windows:'' Ctrl+Shift+h ** History menu > "Show All History" * right-click a history entry for the site and choose "Forget About This Site" That might take several moments if you have a large cache and a traditional spinning hard drive. There is no "Undo" for this so be sure you want to do it! Your HTTP address should no longer get redirected to HTTPS (if it is, it could be on the server). '''''Edit or Remove Settings File''''' Firefox keeps HSTS flags and related data in a settings file named "SiteSecurityServiceState.txt" in your currently active profile folder. This is a plain text file you could edit, or if you remove it, Firefox will rebuild it as you revisit those sites. While there is some site data in here that perhaps you might not want to lose, I don't think it's crucial. Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, click the "Show Folder" button (on Mac: Show in Finder). This should launch a new window listing the various files and folders in your profile folder. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then rename '''SiteSecurityServiceState.txt''' to something like SiteSecurityServiceState.old (or if your Windows still has the default setting to hide the .txt extension, it might be simpler to rename it to SiteSecurityServiceState-old). Start Firefox back up again, and when you get the certificate error page, you now should see the Add Exception button.
cor-el
  • Top 10 Contributor
  • Moderator
17467 izisombululo 157838 izimpendulo
Kuphostiwe

Impendulo Ewusizo

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Note that using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain like bookmarked pages that you do not want to lose then make sure to backup this data or make a note.

Can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Note that using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain like bookmarked pages that you do not want to lose then make sure to backup this data or make a note. Can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again.

Umnikazi wombuzo

Thank you for the help. The "S" in gone!

Thank you for the help. The "S" in gone!
FredMcD
  • Top 10 Contributor
4245 izisombululo 59390 izimpendulo
Kuphostiwe

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.