Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Extensions vanished after upgrade to 42.0

  • 6 uphendule
  • 1 inale nkinga
  • 29 views
  • Igcine ukuphendulwa ngu jscher2000

more options

When I go to about:addons it says there aren't any.

Isisombululo esikhethiwe

Hi SlashChuck:

How do I uninstall plugins? The Add-Ons Manager doesn't seem to enable that.

True, plugins usually are outside your personal settings and need to be removed from locations referenced in the Windows registry. Typically the provider has an installer or uninstaller that can clean things up, or you can use the about:plugins page to discover their physical locations on disk and remove them by hand.

After inspecting the default profile shown by the Help->Troubleshooting Information, I think the add-ons are still here but for some reason they don't show up in about:addons

Could you try cor-el's suggestion in this post with regarding to ruling out a problem with a possibly corrupt extensions registry file: https://support.mozilla.org/questions/1091378#answer-800060

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options

Does this occur in all categories, or only Extensions? When you shared your data to the forum, it didn't list any extensions.

Also, are you on beta 9? I can't tell from your data which version you're on.

One possible reason for all your extensions to vanish is if you used the Refresh feature during your update. That could occur when Firefox reports that it is starting slowly and you can speed it up by restoring some default settings. If you click that button, your settings folder is moved to the desktop inside an Old Firefox Data folder, and a new settings folder is created with part of your data.

Can you find an Old Firefox Data folder? If so, check inside to see if the semi-randomly-named settings (profile) folder there has freshly updated files. That would be the tell-tale sign.


If you refreshed and you don't want to reinstall all those extensions, you could revert the refresh. There's no one-click way to "roll back" a refresh, but here is a procedure to revert to your pre-Refresh data. It takes 5 minutes, but that may be faster than recovering individual files and loading those into your new profile.

Check inside the "Old Firefox Data" folder that Refresh adds to your desktop for a folder with a semi-randomized name. If there's only one, that probably has your old settings and add-ons. If there's more than one, you'll want to work with the one that was updated most recently.

Once you have identified the profile folder you want to restore, here is my suggested "old profile resurrection procedure":

Overview

These are the steps described in more detail below:

  1. Create a new Firefox profile
  2. Remove everything from that new profile folder
  3. Copy in everything from the old profile folder

Create a new Firefox profile (Windows)

Exit Firefox completely, and then start up in the Profile Manager by pasting the following into the Start menu search box, or the Start > Run dialog, and pressing Enter:

firefox.exe -P

Note: Any time you want to switch profiles, exit Firefox and return to this dialog.

Click the Create Profile button, assign a name like OldSettings, and skip the option to change the folder location. Then select that new profile in the dialog and start Firefox.

Open the New Profile folder in Windows Explorer

Firefox in the new profile should look like a factory fresh installation. Open the Troubleshooting Information page using either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table, click the "Show Folder" button. Firefox will launch your brand new profile folder in Windows Explorer.

Leaving that folder open, switch back to Firefox, and Exit using either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

When Firefox closes, the profile folder should be front and center, or you can activate it using the Task bar.

Copy Old Data in Place of New

In that new profile folder you just popped open -- NOT the one on your desktop -- select all the contents (you can use Ctrl+a) and delete (you can press the Delete key on the keyboard).

Leaving that window open, open or switch over to your Old Firefox Data folder. Drill down into your old profile folder. At this level you should see a folder named bookmarkbackups among other things.

Select everything (Ctrl+a) and Copy (either right-click > Copy or Ctrl+c).

Switch to the empty new profile folder in other window and Paste (either right-click > Paste or Ctrl+v). This may take a minute since some of the files are large.

Start Firefox

Firefox should start up in that "new" profile with the resurrected old profile data. Success?

more options

There is already a release candidate Firefox 42.0 RC2, so Firefox 42 reports as the next Firefox 42.0 release.

If you didn't create a new profile via a Refresh/Reset then you can check this:

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox menu button/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this hasn't helped then also delete the addons.json file.

more options

Separate Issue; Your System Details shows;

Installed Plug-ins

Adobe PDF Plug-In For Firefox and Netscape 11.0.13 Adobe PDF Plug-In For Firefox and Netscape "9.5.5"

Adobe Shockwave for Director Netscape plug-in, version 11.6.3.633 Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638 Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

Shockwave Director: Shockwave Standalone Installer / Uninstaller{web link} Shockwave Director Version 12.2.1.171 http://get.adobe.com/shockwave/

Adobe PDF Plug-In For Firefox and Netscape: Adobe Reader Version 2015.009.20069 Note: McAfee Security is offered in the download.

more options

Note that your System Detail list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file will only be present if you or other software has created this file and normally won't be present.

You can check its content with a plain text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself. You can use this button to go to the current Firefox profile folder:

more options

How do I uninstall plugins? The Add-Ons Manager doesn't seem to enable that.

I can't find any user.js dated this year.

After inspecting the default profile shown by the Help->Troubleshooting Information, I think the add-ons are still here but for some reason they don't show up in 'about:addons'

Okulungisiwe ngu Chuck

more options

Isisombululo Esikhethiwe

Hi SlashChuck:

How do I uninstall plugins? The Add-Ons Manager doesn't seem to enable that.

True, plugins usually are outside your personal settings and need to be removed from locations referenced in the Windows registry. Typically the provider has an installer or uninstaller that can clean things up, or you can use the about:plugins page to discover their physical locations on disk and remove them by hand.

After inspecting the default profile shown by the Help->Troubleshooting Information, I think the add-ons are still here but for some reason they don't show up in about:addons

Could you try cor-el's suggestion in this post with regarding to ruling out a problem with a possibly corrupt extensions registry file: https://support.mozilla.org/questions/1091378#answer-800060