Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Disable the allow / deny in full screen permanently, not URL by URL

  • 5 uphendule
  • 17 zinale nkinga
  • 11690 views
  • Igcine ukuphendulwa ngu cor-el

more options

Some months ago Firefox started prompting when i went into full screen mode : Allow or deny - it's irritating. I wantt o allow always without the prompt.

I know about Tools>page info>permissions but that is only url by url.

I found something that worked in here before, but it seems to have reset when firefox restarted. And i can't find the method this time around!

Thanks

Isisombululo esikhethiwe

cor-el said

You can manage the full screen permission via "Tools > Page Info > Permissions" or via the about:permissions page. You can look at this pref on the about:config page.
  • full-screen-api.approval-required

This is the method - it doesn't really explain it - but what you should do is open a new window type about:config in the URL space up to and then find the full-screen-api.approval-required and click on the true so it turns false.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 4

All Replies (5)

more options

you found it once, you will find it again :)

more options

You can manage the full screen permission via "Tools > Page Info > Permissions" or via the about:permissions page.

You can look at this pref on the about:config page.

  • full-screen-api.approval-required
more options

beastmanrules said

you found it once, you will find it again :)

It took me 3 evenings to find it first time and then it only worked until firefox was restarted.

It shouldn't be that hard.

more options

Isisombululo Esikhethiwe

cor-el said

You can manage the full screen permission via "Tools > Page Info > Permissions" or via the about:permissions page. You can look at this pref on the about:config page.
  • full-screen-api.approval-required

This is the method - it doesn't really explain it - but what you should do is open a new window type about:config in the URL space up to and then find the full-screen-api.approval-required and click on the true so it turns false.

more options