Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why won't PDFs won't preview in Firefox 36.0? (OS10.9.5)

  • 13 uphendule
  • 36 zinale nkinga
  • 11589 views
  • Igcine ukuphendulwa ngu jocha15

more options

Since updating to Firefox 36.0 (OS 10.9.5), PDFs no longer preview in Firefox: I'm prompted to download and save them -- even though in Firefox Preferences, the default selection reads: Preview in Firefox. Help, please.

Isisombululo esikhethiwe

If you double-click that line then you get a dialog that shows the current value for editing. If you can erase the current value and leave the value empty and click OK to confirm the change.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (13)

more options

https://support.mozilla.org/en-US/kb/pdf-files-are-blank-or-cause-error-message-mac PDF files are blank or cause an error message on Mac An Adobe Reader update can cause PDF files to be unreadable in Firefox. We'll explain how to fix this and cover options for viewing PDF files.

https://support.mozilla.org/en-US/kb/view-pdf-files-firefox-without-downloading-them View PDF files in Firefox without downloading them Learn how to get PDF files to open in the Firefox window and fix common problems like blank pages and files downloading instead of opening.

more options

It's completely obvious from my original question that I know how Firefox is SUPPOSED to allow viewing PDF files without downloading them. It's worked that way for the past several versions. As I stated in my question, as of the upgrade to 36.0, it isn't doing it, even though -- as I also stated -- I have the Preferences set to Preview in Firefox. I would appreciate a real answer this time, not just a link to a document that says what I clearly already know.

more options

You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu if you want to display PDF documents in Firefox with another application (i.e. not the built-in PDF Viewer).

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

Sorry, it's difficult to understand Cor-el's suggestion. Again: I WANT to use Firefox's PDF viewer as I've done in the past, until 36.0 screwed things up. I don't want to use another application, because it's inconvenient and because they save every PDF to my hard drive. Can you please explain in plain English? Thanks.

more options

Type about:config in the location (address) bar and press the Enter key to open the about:config page like you open a website by typing the URL in the location bar.

  • if you see a warning message then you can confirm that you want to access the about:config page.
  • use the Search bar at the top of the about:config page to locate preferences more easily
  • preferences that have been modified and do not have the default value show as bold (user set)
  • preferences that are user set (bold) can be reset to the default value via the right-click context menu
  • preferences can be modified via Modify (String or Integer) or Toggle (Boolean) in the right-click context menu and by double-clicking the line with the pref

See also:

more options

Sorry, but this explanation explains nothing. Accessing the about:config page is easy. But all the passive voice bullets about what can be modified, reset, etc. don't give a clue of what should be done to make the PDF Viewer work. Isn't there a way to communicate that to those of use who don't speak technical jargon? The last bullet point is particularly impenetrable. Sorry to seem dense, but I'm actually a science writer, and a pretty well-known one. My job is to take highly technical information and jargon and put it into language that the rest of us can understand. To do that, I have to ask a lot of questions until I understand. So far here, I don't. Thanks -- AW

more options

What is the current value of the plugin.disable_full_page_plugin_for_types pref?

You can start typing the name in the search bar at the top of the about:config page until you see this pref. You can right-click this pref and use Copy in the right-click context menu.

more options

plugin.disable_full_page_plugin_for_types;application/pdf

more options

plugin.disable_full_page_plugin_for_types;application/pdf Status: user set Type: string Value: application/pdf

more options

Double-click that line to modify the plugin.disable_full_page_plugin_for_types pref and set the value to an empty String value.

more options

Please explain: " set the value to an empty String value." What exactly do I do?

more options

Isisombululo Esikhethiwe

If you double-click that line then you get a dialog that shows the current value for editing. If you can erase the current value and leave the value empty and click OK to confirm the change.

more options

I had the same problem and was able to resolve it by going to "Tools," then "Add-Ons," then clicking on the "Extensions" tab and disabling the Adobe Acrobat add-on. I had to restart Firefox and it was back to previewing pdfs in the browser as it had done before.