X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

our wordpress site no longer works in firefox

Kuphostiwe

Since last week our wordpress site no longer appears properly in firefox.

CSS elements are no longer loaded such as the patterned background.

Images which where hidden within a slider are all visible and images which are sitting on another sister server are not shown. Our flowplayer no longer works and in the backend on the wordpress dashboard certain functionality no longer appears.

I'd say that Firefox is no longer allowing any javascript elements to wok but I'm no expert.

Firefox is easily my browser of choice but our site appears perfectly normally in all other browsers.

R

Since last week our wordpress site no longer appears properly in firefox. CSS elements are no longer loaded such as the patterned background. Images which where hidden within a slider are all visible and images which are sitting on another sister server are not shown. Our flowplayer no longer works and in the backend on the wordpress dashboard certain functionality no longer appears. I'd say that Firefox is no longer allowing any javascript elements to wok but I'm no expert. Firefox is easily my browser of choice but our site appears perfectly normally in all other browsers. R

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 13.0 r0
  • Unity Web Player version 4.3.5f1. (c) 2013 Unity Technologies ApS. All rights reserved.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).

Isisebenziso

  • Firefox 30.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:30.0) Gecko/20100101 Firefox/30.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/30.0/Darwin/en-US/

Izandiso

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription:
  • adapterDeviceID: 0x fea
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce GT 755M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Okuthandwayo Okulungisiwe

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140605174243
  • browser.startup.homepage_override.buildID: 20140605174243
  • browser.startup.homepage_override.mstone: 30.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 30.0
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1404826885
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1404825501

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
cor-el
  • Top 10 Contributor
  • Moderator
17578 izisombululo 158995 izimpendulo
Kuphostiwe

Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Firefox > Preferences > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Note that these settings affect background images.

See also:

Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings. Make sure that you allow pages to choose their own colors. *Firefox > Preferences > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above" Note that these settings affect background images. See also: *http://kb.mozillazine.org/Website_colors_are_wrong

Umnikazi wombuzo

No sorry, that made no difference, but thanks for your swift reply.

R

No sorry, that made no difference, but thanks for your swift reply. R
cor-el
  • Top 10 Contributor
  • Moderator
17578 izisombululo 158995 izimpendulo
Kuphostiwe

Can you post a link so we can check if there are issues with Firefox?

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)
Can you post a link so we can check if there are issues with Firefox? Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem *Use a compressed image type like PNG or JPG to save the screenshot *Make sure that you do not exceed the maximum size of 1 MB ---- Clear the cache and cookies only from websites that cause problems. "Clear the Cache": *Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac)

Umnikazi wombuzo

It's not just my machine that displays the same issue.

I'll send 2 screenshot. One from chrome and the other from Firefox

R

It's not just my machine that displays the same issue. I'll send 2 screenshot. One from chrome and the other from Firefox R
cor-el
  • Top 10 Contributor
  • Moderator
17578 izisombululo 158995 izimpendulo
Kuphostiwe

Seems to be working fine here. I can see the Flash player and the video if I enable the Flash plugin.

Did you try to clear the cache?


You can create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem

<!-- http://trainordaviesdesign.com/ --> Seems to be working fine here. I can see the Flash player and the video if I enable the Flash plugin. Did you try to clear the cache? ---- You can create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Okulungisiwe ngu cor-el

Umnikazi wombuzo

Hi cor-el,

I had previously tried starting in firefox safe mode, I cleared the cache and I went back to Firefox 29. I made a new profile as you suggested and restarted Firefox using this profile and there was no change.

I'm really surprised you couldn't see the issue. So was the slider also working on the homepage? Which version of Firefox are you using?

Thanks again for your help.

R

Hi cor-el, I had previously tried starting in firefox safe mode, I cleared the cache and I went back to Firefox 29. I made a new profile as you suggested and restarted Firefox using this profile and there was no change. I'm really surprised you couldn't see the issue. So was the slider also working on the homepage? Which version of Firefox are you using? Thanks again for your help. R
cmosqueda 1 izisombululo 19 izimpendulo
Kuphostiwe

I am seeing your issue. We had an issue with a script being called twice, which in most browsers the same script being called twice in a page would just run the Script. For some reason Firefox did not allow the script to run because it was in there twice. PLUS there was an issue with the Script being INSIDE the body tag.

You could try, if you know how to edit your Wordpress templates, to try to move your Javascript to inside the <head> instead of inside the <body> tag. I know this is not ideal because of page load issues, but this may fix your issue in Firefox, assuming you want it to work in Firefox.

There seems to be a bug, from my experience so far, that Firefox does not like "inline" Javascript and is breaking the Javascript when other browsers render it fine.

I see that a call to eva() (in your cforms.js) is being used and it is being blocked by CSP (Content Security Policy). Which looks like Firefox added something in the Browser that blocks eval() from being used. Typically eval() is considered unsafe, BUT typically still runs on other browsers, seems like Firefox just breaks the code if it finds it.


You may try to use a different forms plugin too instead of cforms.js because of the eval() method being used.

I am seeing your issue. We had an issue with a script being called twice, which in most browsers the same script being called twice in a page would just run the Script. For some reason Firefox did not allow the script to run because it was in there twice. PLUS there was an issue with the Script being INSIDE the body tag. You could try, if you know how to edit your Wordpress templates, to try to move your Javascript to inside the <head> instead of inside the <body> tag. I know this is not ideal because of page load issues, but this may fix your issue in Firefox, assuming you want it to work in Firefox. There seems to be a bug, from my experience so far, that Firefox does not like "inline" Javascript and is breaking the Javascript when other browsers render it fine. I see that a call to eva() (in your cforms.js) is being used and it is being blocked by CSP (Content Security Policy). Which looks like Firefox added something in the Browser that blocks eval() from being used. Typically eval() is considered unsafe, BUT typically still runs on other browsers, seems like Firefox just breaks the code if it finds it. You may try to use a different forms plugin too instead of cforms.js because of the eval() method being used.

Okulungisiwe ngu cmosqueda

Umnikazi wombuzo

Hi cmosqueda,

Thanks very much for that. At least I know I'm not going mad. Yes I've very keen to get it to work in Firefox.

I'm just surprised that this happened so suddenly at the end of last week when everything worked perfectly before.

So apart from the cforms issue, would you then say that the theme is no longer compatible with Firefox, in which case I can attempt to get some help from the theme builder?

R

Hi cmosqueda, Thanks very much for that. At least I know I'm not going mad. Yes I've very keen to get it to work in Firefox. I'm just surprised that this happened so suddenly at the end of last week when everything worked perfectly before. So apart from the cforms issue, would you then say that the theme is no longer compatible with Firefox, in which case I can attempt to get some help from the theme builder? R
cor-el
  • Top 10 Contributor
  • Moderator
17578 izisombululo 158995 izimpendulo
Kuphostiwe

There is a a tag in the head section that causes Firefox to close the head and open the body.

<a href="https://plus.google.com/117319391483993774484" rel="publisher"></a>

You can see that in the source code the body tag is marked in red code and the </head> just before it as well.

  • Firefox/Tools > Web Developer > Page Source (Ctrl+U)
  • right-click on a web page and select View Page Source in the context menu

http://trainordaviesdesign.com/

There is a a tag in the head section that causes Firefox to close the head and open the body. <pre><nowiki><a href="https://plus.google.com/117319391483993774484" rel="publisher"></a></nowiki></pre> You can see that in the source code the body tag is marked in red code and the </head> just before it as well. *Firefox/Tools > Web Developer > Page Source (Ctrl+U) *right-click on a web page and select View Page Source in the context menu ---- http://trainordaviesdesign.com/
cmosqueda 1 izisombululo 19 izimpendulo
Kuphostiwe

@cor-el. I did see the red </head> tag but could not pinpoint where that was coming from. Good catch. Looks like something injected by the theme probably. Just in the wrong place.

@Roniart, if there is a place in your theme admin to disable the Google Plus icon, try that and see if that fixes your issue.

You could try the cforms first and the disabling the Google Plus share option and see if that works. If you change your theme, first test the themes out of Firefox if you want to use it. There are multiple sites you can go to choose and test Wordpress themes (http://themeforest.net) or others. Just make sure they work on Firefox before you choose.

@cor-el. I did see the red </head> tag but could not pinpoint where that was coming from. Good catch. Looks like something injected by the theme probably. Just in the wrong place. @Roniart, if there is a place in your theme admin to disable the Google Plus icon, try that and see if that fixes your issue. You could try the cforms first and the disabling the Google Plus share option and see if that works. If you change your theme, first test the themes out of Firefox if you want to use it. There are multiple sites you can go to choose and test Wordpress themes (http://themeforest.net) or others. Just make sure they work on Firefox before you choose.

Umnikazi wombuzo

Thanks guys,

I have removed the plus.google.com script from the header and disabled the cForms plugin.

We have built some other sites for clients/friends using the same theme, whose sites look perfect in Firefox & I have switches themes briefly and saw no change in the problems. Therefore I think the theme might not me the issue.

I am also not seeing some of the functions which should be there in the wordpress and any images that are sitting on other servers are no longer linking, so I am now wondering if this could either a wordpress corruption issue or a server, but would this not mean the issue would be there on other browsers?

R

Thanks guys, I have removed the plus.google.com script from the header and disabled the cForms plugin. We have built some other sites for clients/friends using the same theme, whose sites look perfect in Firefox & I have switches themes briefly and saw no change in the problems. Therefore I think the theme might not me the issue. I am also '''not''' seeing some of the functions which should be there in the wordpress and any images that are sitting on other servers are no longer linking, so I am now wondering if this could either a wordpress corruption issue or a server, but would this not mean the issue would be there on other browsers? R
cmosqueda 1 izisombululo 19 izimpendulo
Kuphostiwe

@Roniart.

There might be some other issues with your theme and Firefox too. I am going through your portfolio (nice work by the way), and on Firefox when I click on a project, the images on the project page don't seem to load for me.

@Roniart. There might be some other issues with your theme and Firefox too. I am going through your portfolio (nice work by the way), and on Firefox when I click on a project, the images on the project page don't seem to load for me.
cmosqueda 1 izisombululo 19 izimpendulo
Kuphostiwe

I am not sure if is Wordpress corruption because on Chrome the images and such look fine. This has to be a Firefox issue.

I am seeing one more Javascript error. uberMenuSettings is not defined.

The other errors went away though.

It really seems that if there are any Javascript issues, Firefox seems to not load everything. It is stopping you Javascript from loading someplace. The scroll ticker and the sliders are just not working.

Like my other assumption may be, is that the Javascript that is inside the </body> tag may be causing an issue. If you can move all your Javascript into the <head> and test it in Firefox, then this may be your issue.

I am not sure if is Wordpress corruption because on Chrome the images and such look fine. This has to be a Firefox issue. I am seeing one more Javascript error. uberMenuSettings is not defined. The other errors went away though. It really seems that if there are any Javascript issues, Firefox seems to not load everything. It is stopping you Javascript from loading someplace. The scroll ticker and the sliders are just not working. Like my other assumption may be, is that the Javascript that is inside the </body> tag may be causing an issue. If you can move all your Javascript into the <head> and test it in Firefox, then this may be your issue.

Okulungisiwe ngu cmosqueda

Umnikazi wombuzo

The images which load are on the same server, the ones that don't load are on a different server (medioto.com) so somehow outward links are blocked.

R

The images which load are on the same server, the ones that don't load are on a different server (medioto.com) so somehow outward links are blocked. R
FredMcD
  • Top 10 Contributor
4269 izisombululo 59882 izimpendulo
Kuphostiwe

With the last Firefox upgrade, some plugins are no longer enabled until you enable it.

With the last Firefox upgrade, some plugins are no longer enabled until you enable it.