X
點擊此處開啟此網站的行動版。

技術支援討論區

此討論串已經關閉並封存。 如果您有需要幫助,請新增一個新問題

How do I change my default search engine in the URL bar back to Google after my ISP replaced my default search engine with their own?

已張貼

Before I changed internet service providers, I could type my search queries into the url bar and receive search results from Google. After I switched ISPs, my queries typed into the url bar are put into my new ISP's horrible search engine. How do I change it back?

I've already tried going to about:config and changing the value of the keyword.URL preference to "http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=" but that didn't fix my problem.


New information since creation of the post:

My ISP is Optimum. I have opted out of DNS Assistance and still have seen no change.

When my search term is two words or more, I am directed to Google search results. If my search term is only one word, however, I am still directed to Optimum's search results.

Before I changed internet service providers, I could type my search queries into the url bar and receive search results from Google. After I switched ISPs, my queries typed into the url bar are put into my new ISP's horrible search engine. How do I change it back? I've already tried going to about:config and changing the value of the keyword.URL preference to "http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=" but that didn't fix my problem. New information since creation of the post: My ISP is Optimum. I have opted out of DNS Assistance and still have seen no change. When my search term is two words or more, I am directed to Google search results. If my search term is only one word, however, I am still directed to Optimum's search results.

由 samshine 於 修改

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.6 r602
  • Version 3.16.0.12200
  • Google Talk Plugin Video Accelerator version:0.1.44.24
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Coupons Inc., Coupon Printing FireFox Plugin
  • 5.1.10411.0
  • GameTree Download Manager Plug-in
  • Octoshape Streaming Services web integration browser plug-in
  • Musicnotes Viewer plugin 1.18.8 http://www.musicnotes.com
  • iPhoto6

應用程式

  • Firefox 19.0.2
  • 使用者代理:Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:19.0) Gecko/20100101 Firefox/19.0
  • 技術支援網址:http://support.mozilla.org/1/firefox/19.0.2/Darwin/en-US/

擴充套件

  • Reddit Enhancement Suite 4.1.2 (jid1-xUfzOsOFlzSOXg@jetpack)
  • Search by Image for Google 1.2.0 ({ab4b5718-3998-4a2c-91ae-18a7c2db513e})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription:
  • adapterDeviceID: 0x 46
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce GT 330M OpenGL Engine
  • windowLayerManagerType: OpenGL

修改過的偏好設定

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: https://www.google.com/|https://www.facebook.com/|http://www.reddit.com/
  • browser.startup.homepage_override.buildID: 20130307023931
  • browser.startup.homepage_override.mstone: 19.0.2
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0.2
  • gfx.blacklist.webgl.msaa: 4
  • keyword.URL: http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1364823753
  • places.history.expiration.transient_current_max_pages: 104019
  • places.history.expiration.transient_optimal_database_size: 166429982
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

其他

  • User JS: 否
  • 輔助功能: 否
ideato 893 個解決方法 6250 個答案

有幫助的回覆

Hello samshine, try to reset the browser.search.defaultenginename in about:config and check it again.


thank you

Hello samshine, try to reset the '''browser.search.defaultenginename''' in about:config and check it again. thank you

提出問題者

That didn't fix it either, unfortunately.

That didn't fix it either, unfortunately.
finitarry 251 個解決方法 3421 個答案

Just how did your ISP change your search engine in the address bar? Did you have to install some kind of software in order to connect to it?

Just how did your ISP change your search engine in the address bar? Did you have to install some kind of software in order to connect to it?

提出問題者

There was no software to install when I changed ISPs. They "installed" my service on the scheduled day by doing something remotely that allowed our address to have access to their service. Then the next time I opened my browser and typed in a search query, I was taken to their search engine.

There was no software to install when I changed ISPs. They "installed" my service on the scheduled day by doing something remotely that allowed our address to have access to their service. Then the next time I opened my browser and typed in a search query, I was taken to their search engine.

提出問題者

If it's any help, the ISP I'm referring to is Optimum.

If it's any help, the ISP I'm referring to is Optimum.
jscher2000
  • Top 10 Contributor
8773 個解決方法 71729 個答案

有幫助的回覆

It's confusing because when you posted, your address bar search URL was set to Google:

keyword.URL: http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=

But... lately the URL should go to the secure site, so try resetting it as described in this article: Search the web from the address bar -- "Changing the Internet Keyword service" section.

Any luck?

It's confusing because when you posted, your address bar search URL was set to Google: keyword.URL: http://www.google.com/search?ie=UTF-8&oe=UTF-8&q= But... lately the URL should go to the secure site, so try resetting it as described in this article: [[Search the web from the Address Bar]] -- "Changing the Internet Keyword service" section. Any luck?
jscher2000
  • Top 10 Contributor
8773 個解決方法 71729 個答案

I just re-read your post more carefully and see that you had updated keyword.URL yourself.

Could you check your connection setting and see whether a change there makes any difference? You might need to restart Firefox between changes to have it take effect. In that case, you can use the History menu to restore your previous session and come back to this thread.

Firefox > Preferences > Advanced > Network > "Settings" button

Try "No Proxy" or compare with Safari (as mentioned in this article: https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-bro...).

Any difference?

I just re-read your post more carefully and see that you had updated keyword.URL yourself. Could you check your connection setting and see whether a change there makes any difference? You might need to restart Firefox between changes to have it take effect. In that case, you can use the History menu to restore your previous session and come back to this thread. Firefox > Preferences > Advanced > Network > "Settings" button Try "No Proxy" or compare with Safari (as mentioned in this article: [https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can#w_firefox-connection-settings]). Any difference?

提出問題者

I changed the setting to "No Proxy" and then restared firefox, but I'm still seeing no difference.

Some more information that I'm not sure is relevant or helpful: I have no problem accessing Google in general. It's only when I type search queries into the URL bar that I get sent to Optimum's (formerly Bresnan's) search engine. For instance when I type in "firefox" I get taken here: http://search.bresnan.net/index.php?origURL=http%3A//firefox/&r=

I changed the setting to "No Proxy" and then restared firefox, but I'm still seeing no difference. Some more information that I'm not sure is relevant or helpful: I have no problem accessing Google in general. It's only when I type search queries into the URL bar that I get sent to Optimum's (formerly Bresnan's) search engine. For instance when I type in "firefox" I get taken here: http://search.bresnan.net/index.php?origURL=http%3A//firefox/&r=

提出問題者

Also, it seems to only be an issue with Firefox. I tried this out with both Google Chrome and Safari and my search queries are taken to Google when entered into the URL bar.

Also, it seems to only be an issue with Firefox. I tried this out with both Google Chrome and Safari and my search queries are taken to Google when entered into the URL bar.
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 個解決方法 40244 個答案

I think Optimum uses a 'DNS Assistance' service. See if this helps you.

http://www.optimum.net/dnsassist/optout

I think Optimum uses a 'DNS Assistance' service. See if this helps you. http://www.optimum.net/dnsassist/optout
cor-el
  • Top 10 Contributor
  • Moderator
17539 個解決方法 158588 個答案

What is your ISP?

You may have an ISP that automatically redirects you to a search page if a DNS look up fails.
That takes the control from Firefox to do the normal keyword search like a Google I'm Lucky search.
In such cases you need to contact your ISP and ask for a DNS server to opt-out of that feature.
You can also check if there is a link on the search results page to go to your ISP and opt-out.

What is your ISP? You may have an ISP that automatically redirects you to a search page if a DNS look up fails.<br /> That takes the control from Firefox to do the normal keyword search like a Google I'm Lucky search.<br /> In such cases you need to contact your ISP and ask for a DNS server to opt-out of that feature.<br /> You can also check if there is a link on the search results page to go to your ISP and opt-out.

提出問題者

the-edmeister: I went to that link and opted out, quit Firefox as it instructed me to do, and then restarted it and I'm still seeing no change.

the-edmeister: I went to that link and opted out, quit Firefox as it instructed me to do, and then restarted it and I'm still seeing no change.

提出問題者

Another thing I just noticed: If my search term is two words or more it will direct me to the google search results. If my search term is only one word, however, I am still directed to the Optimum/Bresnan search results.

Another thing I just noticed: If my search term is two words or more it will direct me to the google search results. If my search term is only one word, however, I am still directed to the Optimum/Bresnan search results.
jscher2000
  • Top 10 Contributor
8773 個解決方法 71729 個答案

Hi samshine, to have single words also searched, try disabling Firefox's domain guessing feature, also known as "fixup" (Firefox fixes up the domain with www before and com after).

https://support.mozilla.org/en-US/kb/search-web-address-bar#w_turning-off-domain-guessing

Hi samshine, to have single words also searched, try disabling Firefox's domain guessing feature, also known as "fixup" (Firefox fixes up the domain with www before and com after). https://support.mozilla.org/en-US/kb/search-web-address-bar#w_turning-off-domain-guessing

提出問題者

I followed the instructions there, and then quit and restarted Firefox and it's still giving me Optimum's search engine with single-word search queries.

I followed the instructions there, and then quit and restarted Firefox and it's still giving me Optimum's search engine with single-word search queries.
jscher2000
  • Top 10 Contributor
8773 個解決方法 71729 個答案

That's strange.

If you check about:config, did the settings get flipped back?

  • browser.fixup.alternate.enabled should be false
  • keyword.enabled should be true
  • keyword.URL should be blank
That's strange. If you check about:config, did the settings get flipped back? * browser.fixup.alternate.enabled should be false * keyword.enabled should be true * keyword.URL should be blank

提出問題者

All of those settings still look good.

All of those settings still look good.
jscher2000
  • Top 10 Contributor
8773 個解決方法 71729 個答案

Edit: The following explanation would not apply to new one-word searches.


Could be a cached result. I'm not sure of the best way to clear that without having to clear your entire Firefox cache. If necessary, you would do that here:

Firefox > Preferences > Advanced > Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes to churn away.

Hopefully someone else will have a more targeted suggestion.

''Edit: The following explanation would not apply to new one-word searches.'' ---- Could be a cached result. I'm not sure of the best way to clear that without having to clear your entire Firefox cache. If necessary, you would do that here: Firefox > Preferences > Advanced > Network mini-tab > Cached Web Content : "Clear Now" If you have a large hard drive, this might take a few minutes to churn away. Hopefully someone else will have a more targeted suggestion.

由 jscher2000 於 修改

提出問題者

It only took a few seconds because I clear my cache often. Still no fix, though. :(

Thanks for helping me out. Really, this problem really isn't that big of an issue but it's been bugging me for so long and at this point we've gotten so far into trying to figure it out, that I feel like we have to find a solution.

It only took a few seconds because I clear my cache often. Still no fix, though. :( Thanks for helping me out. Really, this problem really isn't that big of an issue but it's been bugging me for so long and at this point we've gotten so far into trying to figure it out, that I feel like we ''have'' to find a solution.
cor-el
  • Top 10 Contributor
  • Moderator
17539 個解決方法 158588 個答案

Try to create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Try to create a new profile as a test to check if your current profile is causing the problems. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox