X
點擊此處開啟此網站的行動版。

技術支援討論區

I have a laptop with Windows 8-64 Bit, but the download version of Firefox is 32 Bit, how to correct this?

已張貼

I find that my browser hangs a bit when playing games, don´t know if it might be attributed in having Firefox with 32 Bit instead of one with 64 Bit. Please advise. Thanks in advance

I find that my browser hangs a bit when playing games, don´t know if it might be attributed in having Firefox with 32 Bit instead of one with 64 Bit. Please advise. Thanks in advance

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • McAfee MSC FF plugin DLL
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

更多資訊

iamjayakumars 492 個解決方法 5972 個答案

有幫助的回覆

Firefox works fine with 32-bit. There is no official 64 bit version of Firefox for Windows released yet.

check out this. https://developer.mozilla.org/en/Supported_build_configurations

are you facing that problem only in particular website or all other website.

Firefox works fine with 32-bit. There is no official 64 bit version of Firefox for Windows released yet. check out this. https://developer.mozilla.org/en/Supported_build_configurations are you facing that problem only in particular website or all other website.
jscher2000
  • Top 10 Contributor
8792 個解決方法 71899 個答案

The 64-bit version of Windows 7 happily runs 32-bit programs such as Firefox, so I don't think that's the source of the problem.

If the games use 3D, the problem could be an incompatibility between Firefox and your graphics adapter. Could you try disabling Firefox's hardware graphics acceleration?

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button or classic Tools menu > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the issue resolved or at least improved?


If the games are hosted in the Flash plugin, of course there are many possible troubleshooting suggestions for Flash issues...

The 64-bit version of Windows 7 happily runs 32-bit programs such as Firefox, so I don't think that's the source of the problem. If the games use 3D, the problem could be an incompatibility between Firefox and your graphics adapter. Could you try disabling Firefox's hardware graphics acceleration? You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). orange Firefox button ''or'' classic Tools menu > Options > Advanced On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available" If you restart Firefox, is the issue resolved or at least improved? ---- If the games are hosted in the Flash plugin, of course there are many possible troubleshooting suggestions for Flash issues...

提出問題者

to Lamjayakumars, No, It happens when I play at the Zynga web site and also with Facebook. By the way I have WINDOWS 8, NOT 7! Thanks for your attention and intentions.

to Lamjayakumars, No, It happens when I play at the Zynga web site and also with Facebook. By the way I have WINDOWS 8, NOT 7! Thanks for your attention and intentions.

由 hkmmm 於 修改

有幫助的回覆

to jscher2000, I had tried as you suggested and regretfully this did not help. By the way, I have WINDOWS 8, NOT 7! Thanks anyway for your good intentions in trying to help.

to jscher2000, I had tried as you suggested and regretfully this did not help. By the way, I have WINDOWS 8, NOT 7! Thanks anyway for your good intentions in trying to help.

由 hkmmm 於 修改

jscher2000
  • Top 10 Contributor
8792 個解決方法 71899 個答案

Hi hkmmm, I did read that you had Windows 8, but my point simply was that 64-bit versions of Windows historically support both 64-bit and 32-bit software.

I suggest trying the standard Flash guidance for Windows 7/Vista, on the theory that the plugin behaves similarly on Windows 8.

(1) Disable protected mode (Win Vista & Win 7 & maybe Win 8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) [done] In Firefox, un-check the box here and restart:

orange Firefox button or classic Tools menu > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

Hi hkmmm, I did read that you had Windows 8, but my point simply was that 64-bit versions of Windows historically support both 64-bit and 32-bit software. I suggest trying the standard Flash guidance for Windows 7/Vista, on the theory that the plugin behaves similarly on Windows 8. (1) Disable protected mode (Win Vista & Win 7 & maybe Win 8) See this support article from Adobe under the heading "Last Resort": [http://forums.adobe.com/message/4468493#TemporaryWorkaround Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?] (2) Disable hardware graphics acceleration in Firefox and in Flash (A) [''done''] In Firefox, un-check the box here and restart: orange Firefox button ''or'' classic Tools menu > Options > Advanced > General > "Use hardware acceleration when available" (B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues