搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

My problem is a hijack of the proxy settings and I cannot remove it even by editing pref.js file. It just keeps restoring the use manual proxy settings.

  • 41 回覆
  • 42 有這個問題
  • 7731 次檢視
  • 最近回覆由 betabeta1

more options

I had the cycbot trojan and have removed it. However my browser will not connect to the Internet unless I manually select no proxy in the connection settings. then on restart of firefox the settings change back to a manual proxy.

被選擇的解決方法

I think what you can do here is to go to about:config and then in the filter at the top, enter each of those entries one at a time, then right click them and choose Reset. This should restore their default values.

So network.proxy.http_port should revert to '0' when you do that instead of its current value of 64586.

從原來的回覆中察看解決方案 👍 3

所有回覆 (1)

more options

I looked for files modified at the time I thought a similar Malware acted on my PC.


Found 3 lines added to the:



C:/users/xxxxxmyprofile/appdata/roaming/mozilla/firefox/profiles/xxxxx.default/extensionsfoxmarks@kei.com/default/preferences/prefs.js


I removed them, and I saved the prefs.js file again. They were like: user_pref("network.proxy.http", "127.0.0.1"); user_pref("network.proxy.http_port", 58505); user_pref("network.proxy.type", 1); More or less.


My suggestions: Check all *.js files in firefox/ subfolders, plugins included (in my case, as you can see, it was in foxmarks subfolder).


Took me a while, finally solved.

  1. 1
  2. 2
  3. 3