X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox will not play videos. A green screen shows instead. Same sites work in IE. Problem just started this week. How can I fix this?

已張貼

The sound works -- it's just that video is replaced by a solid green screen.

The sound works -- it's just that video is replaced by a solid green screen.

額外的系統細節

這發生了

每當開啟 Firefox 的時候

問題發生於...

This past week. Not sure exactly when.

已安裝的外掛程式

  • getplusplusadobe16297
  • Office Plugin for Netscape Navigator
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Shockwave Flash 10.1 r102
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • 4.0.51204.0
  • NPWLPG

應用程式

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

更多資訊

I know Windows 7 recently wanted 15 updates installed (which I obediently did). I don't know if this is related to the problem or merely a coincidence.

cor-el
  • Top 10 Contributor
  • Moderator
17759 個解決方法 160617 個答案

有幫助的回覆

A green screen usually means that there is a DirectShow problem with creating the overlay window with the player.

If it is only with Flash then try to disable hardware acceleration in the Flash player.

See Flash videos won't play full screen

Flash "Display settings" window:

A green screen usually means that there is a DirectShow problem with creating the overlay window with the player. If it is only with Flash then try to disable hardware acceleration in the Flash player. See [[Cannot view full screen Flash videos]] Flash "Display settings" window: *http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html
kinxton 0 個解決方法 1 個答案

Seems that problem is back with Firefox 11.0.

"If it is only with Flash then try to disable hardware acceleration in the Flash player." That doesn't make it work here. Flash has been updated to the latest version, but still the same issue. Still that green overlay.

Anyone found a solution yet? This occurs on Facebook with videos made with an iPhone and in some cases it happens randomly.

Seems that problem is back with Firefox 11.0. "If it is only with Flash then try to disable hardware acceleration in the Flash player." That doesn't make it work here. Flash has been updated to the latest version, but still the same issue. Still that green overlay. Anyone found a solution yet? This occurs on Facebook with videos made with an iPhone and in some cases it happens randomly.

由 kinxton 於 修改

curiosityaware 0 個解決方法 1 個答案

有幫助的回覆

I found the problem, and I don't think it is with Firefox or Adobe. I have Radeon Graphics running on a Intel Core i7 computer and I was able to solve this problem by opening the Catalyst Control Center and clicking on one setting and applying.

Open your Catalyst Control Center (it may be an icon on your desktop, in the start menu, or accessed via right clicking the desktop and selecting "Graphics Properties") and click on the "power" icon. From there you select "Switchable Graphics", and there should be an area for "recent applications". If you do not see any recent applications, I would re-download the flash player, access a website that uses it, and then retry the above instructions. There should be a "button" to the right of the Flash Player Application and select it until it says "power saving" and select apply. I also tried using "high performance" as a setting and the green screen remained. I am using Catalyst Control Center version 2011.1205.2215.39827, and cannot say if the above instructions will work with any other version.

I found the problem, and I don't think it is with Firefox or Adobe. I have Radeon Graphics running on a Intel Core i7 computer and I was able to solve this problem by opening the Catalyst Control Center and clicking on one setting and applying. Open your Catalyst Control Center (it may be an icon on your desktop, in the start menu, or accessed via right clicking the desktop and selecting "Graphics Properties") and click on the "power" icon. From there you select "Switchable Graphics", and there should be an area for "recent applications". If you do not see any recent applications, I would re-download the flash player, access a website that uses it, and then retry the above instructions. There should be a "button" to the right of the Flash Player Application and select it until it says "power saving" and select apply. I also tried using "high performance" as a setting and the green screen remained. I am using Catalyst Control Center version 2011.1205.2215.39827, and cannot say if the above instructions will work with any other version.

由 curiosityaware 於 修改

braedonnal 0 個解決方法 1 個答案

I am having a similar issue (green screen when playing videos on youtube or on cnn it's black and audio is choppy) and don't know how to fix it. I have Windows 7 intel core i7 processor, AMD Radeon HD 6670 Graphics card. I opened up the Catalyst Control center and there is no "Power" icon or "Switchable Graphics". I have the current version of Adobe Flash Player. I am very frustrated because nothing online is helping me.

Nevermind! I went to adobe webpage. Follow these steps to disable the hardware acceleration!

http://forums.adobe.com/thread/891337

I am having a similar issue (green screen when playing videos on youtube or on cnn it's black and audio is choppy) and don't know how to fix it. I have Windows 7 intel core i7 processor, AMD Radeon HD 6670 Graphics card. I opened up the Catalyst Control center and there is no "Power" icon or "Switchable Graphics". I have the current version of Adobe Flash Player. I am very frustrated because nothing online is helping me. Nevermind! I went to adobe webpage. Follow these steps to disable the hardware acceleration! http://forums.adobe.com/thread/891337

由 braedonnal 於 修改