Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How can I make Firefox show the search query I type instead of the URL?

  • 9 回覆
  • 0 有這個問題
  • 1 次檢視
  • 最近回覆由 cor-el

more options

If I search "lemmy", I want to see that in the URL instead of the full search URL: https://www.google.com/search?q=lemmy. It makes it easier to copy the search query. If the query has spaces than they're written with +s in the URL. I remember months ago this ended up being the default even for pre-existing Firefox profiles, but then it was changed back.

If I search "lemmy", I want to see that in the URL instead of the full search URL: https://www.google.com/search?q=lemmy. It makes it easier to copy the search query. If the query has spaces than they're written with +s in the URL. I remember months ago this ended up being the default even for pre-existing Firefox profiles, but then it was changed back.

所有回覆 (9)

more options

Set browser.urlbar.showSearchTerms.featureGate to true in about:config.

有幫助嗎?

more options

Thanks.

Is it possible to have this apply to any custom search engine I defined with in about:preferences with browser.urlbar.update2.engineAliasRefresh set to true?

有幫助嗎?

more options

It applies to your chosen default search engine, regardless of how it is added.

有幫助嗎?

more options

@zeroknight I mean can I make it work even on non default search engines, like when I pick one from the URL bar?

有幫助嗎?

more options

It works for me when I select this search engine as the default search engine in "Settings -> Search" and Firefox shows the search engine label when I type the alias (keyword) and a space. Also make sure that keyword.enabled is true on about:config.

I assume that you have set a tick on "Show search terms instead of URL on default search engine results page" that appears in "Settings -> Search" if you set the above mentioned featureGate pref to true?

有幫助嗎?

more options

I have another search engine added in about:preferences after setting browser.urlbar.update2.engineAliasRefresh to true: Perplexity, URL: https://www.perplexity.ai/?q=%s, Alias: pp. When I try searching with it in the URL bar, it still shows the full URL. I have keyword.enabled set to true.

有幫助嗎?

more options

Have you set this search engine as the default search engine as that is necessary to make this work ?

This even seems to work if you have a tab opened to the search results page and then switch the default search engine to/from Perplexity.

由 cor-el 於 修改

有幫助嗎?

more options

Can I have it work on non-default search engines too? Any search engine defined in settings?

有幫助嗎?

more options

No, this choice only works for the current search engine like the name of this setting tells (i.e. it detects only one, default, search engine) as you can see by opening several search result pages and changing the default search engine, only the current default result page will show the terms.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題