搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Local domain brings up search results

  • 16 回覆
  • 0 有這個問題
  • 22 次檢視
  • 最近回覆由 menext

more options

When entering a local domain in the URL bar Firefox sends the request to a search engine instead of the DNS server. How can I stop this behaviour and switch back to how it was before?

When entering a local domain in the URL bar Firefox sends the request to a search engine instead of the DNS server. How can I stop this behaviour and switch back to how it was before?

被選擇的解決方法

jscher2000 - Support Volunteer said

Have users been complaining about this? Maybe you can use some of this (customize for your environment):
Firefox recently changed how it handles domain lookups in the address bar: for domain names ending with .com, .org, and other official top level domains, it still defaults to visiting the site, but for domain names ending with unofficial TLDs (for example, accounting.custom), Firefox will send the text to your default search engine. This affects our internal site(s). You can work around this change using one of these methods: (1) Add a slash after your text: Firefox will interpret accounting.custom/ as an address instead of a search query.

Adding the / at the end seems to work.

從原來的回覆中察看解決方案 👍 0

所有回覆 (16)

more options

Hi Menext,

You can try this solution: https://support.mozilla.org/gu-IN/questions/1359116

有幫助嗎?

more options

Can you describe the pattern of the local domain?

Generally speaking, if it's a single word like marketing then Firefox will prefer to send it to search rather than look it up. Actually, Firefox will look it up after sending it to search and then show a bar asking "Did you mean to go to marketing?" Clicking Yes there will add an exception so Firefox doesn't search it again in the future.

On the other hand, if it's a dotted domain that ends with one of the standard ICANN extensions, then Firefox will do the address lookup.

If it ends with some OTHER text that isn't recognized as a domain, then back to search. It is possible to create an exception in this case. I'm not sure of the simplest way, but as an example:

Let's say the domain is "accounting.eastregion" and you want to always do name resolution for domains ending with .eastregion:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.fixup.domainsuffixwhitelist.eastregion and pause while the list is filtered

Firefox should display a bar with Boolean Number String and a plus button.

(3) Keep the selection on Boolean and click the plus button to create a new preference for eastregion. If the value isn't automatically set to true, double-click the preference to switch the value from false to true

Success?

有幫助嗎?

more options

I've been using Firefox since it was called Netscape. Mainly because it was more private and I felt the developers cared more about the user experience than marketing the users. It's beginning to feel that it is no longer the case.

about:networking resolves the local domain correctly, yet Firefox prefers to send the request to search. Making changes in about:config is like playing in the Windows registry not practical and most likely break in some future update or upgrade.

Removing search from the address bar still brings up search. Why? This was tested on 3 different systems.

Firefox ignores system settings. Chrome doesn't but has other privacy issues. It feels that Firefox was so motivated to send user usage statistics to a central location when it implemented DoH that it didn't care what it broke.

The only way I can make it work is by putting http:// or https:// before the URL. Even that sometimes doesn't work because Firefox doesn't check until it's restarted. All other system programs (ssh, dig, filezilla, chrome,...) have no issues finding the local domains but Firefox just never checks the DNS. It's the whole point of a DNS resolver.

有幫助嗎?

more options

menext said

about:networking resolves the local domain correctly, yet Firefox prefers to send the request to search.

Is the problem that it is a single word string, or is it a dotted string with an ICANN TLD extension, or is it some other dotted string? I may be able to help with this but what exactly is the scenario.

Making changes in about:config is like playing in the Windows registry not practical and most likely break in some future update or upgrade.

Sometimes if you don't want the default behavior, it's the only option, but to find out, please explain more about the pattern of your text string.

Removing search from the address bar still brings up search. Why? This was tested on 3 different systems.

I didn't recommend doing that. Either way, how did you remove search from the address bar, exactly? Do you still get search engine results, or an error page?

Firefox ignores system settings.

Which system settings are being ignored? If you use DNS-over-HTTPS, by default, Firefox now checks for a hosts file. However, it doesn't use the system DNS. You can turn off DNS-over-HTTPS if you think that will help. See: Firefox DNS-over-HTTPS.

The only way I can make it work is by putting http:// or https:// before the URL. Even that sometimes doesn't work because Firefox doesn't check until it's restarted.

Of course using a protocol resolves any ambiguity. But I don't understand why it would sometimes not work. The top line of the address bar drop-down should tell you after every character you type what Firefox intends to do if you submit that input. It should behave consistently.

有幫助嗎?

more options
  • Is the problem that it is a single word string, or is it a dotted string with an ICANN TLD extension, or is it some other dotted string?

It's a dotted string or a single word that is not an ICANN TLD.

  • I didn't recommend doing that. Either way, how did you remove search from the address bar, exactly? Do you still get search engine results, or an error page?

It's in Firefox settings. I still get search results.

  • Which system settings are being ignored? If you use DNS-over-HTTPS, by default, Firefox now checks for a hosts file. However, it doesn't use the system DNS. You can turn off DNS-over-HTTPS if you think that will help.

DNS-over-HTTPS is turned OFF on the system and on the DNS server. The system settings that are being ignored are DNS. Like I said when using about: networking in Firefox and doing a DNS lookup I get the correct IP. When using the address bar I get search results.

  • Of course using a protocol resolves any ambiguity. But I don't understand why it would sometimes not work. The top line of the address bar drop-down should tell you after every character you type what Firefox intends to do if you submit that input. It should behave consistently.

If I wanted the default action to be a search I would use the search field. If someone enters something in an address bar that is a single word or text separated by periods it should check DNS first. Having the address bar send data to a search engine creates ambiguity.

Yes it should behave consistently but it doesn't. If the text is a previous link visited it offers the option. If the link is not in history it fails and goes to a search. If the entry resulted in a search it ignores the DNS and goes directly to search.

This behaviour changed recently, I believe, after Firefox implemented DNS-over-HTTPS. It reacts the same on Windows, Mac and Linux. If you clear history or add a new entry in your DNS Firefox ignores the system DNS and goes straight to search.

The whole point of managing network settings from one server is that all stations behave the same and react the same. If every piece of software decides to do as it pleases we are back to the DOS/Win 3.11 days.

有幫助嗎?

more options

menext said

* Is the problem that it is a single word string, or is it a dotted string with an ICANN TLD extension, or is it some other dotted string? It's a dotted string or a single word that is not an ICANN TLD.

Okay, we're headed back to about:config here. If you want Firefox to ALWAYS do a DNS lookup first BEFORE searching in these cases --

  • single-word queries, for example: linguini
  • dotted-word queries where the suffix is non-ICANN, for example: linguini.pesto

-- then:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.fixup.dns_first_for_single_words and pause while the list is filtered (exists since Firefox 36)

(3) Double-click the preference to switch the value from false {search first} to true {DNS first}

* I didn't recommend doing that. Either way, how did you remove search from the address bar, exactly? Do you still get search engine results, or an error page? It's in Firefox settings. I still get search results.

The Settings page doesn't have an option to disable searching from the address bar. The wording may give the wrong impression that adding the optional Search bar separates those functions, but it does not, it just gives you a second way to search.

有幫助嗎?

more options

Now how do I automate this for 40 ~ 50 stations with different operating systems? Some that are not on location and connect with a VPN.

It might exist since Firefox 36 but it didn't respond like this until recently.

有幫助嗎?

more options

有幫助嗎?

more options

Are those systems used by other people? If they are used to searching for single words from the address bar, this is going to slow down their searches while Firefox waits for a DNS response.

有幫助嗎?

more options

jscher2000 - Support Volunteer said

Are those systems used by other people? If they are used to searching for single words from the address bar, this is going to slow down their searches while Firefox waits for a DNS response.

This is misleading or FUD. If your internal DNS server has a human noticeable delay then you seriously have to upgrade your 1960's hardware. A Raspberry Pi is fast enough for people not to notice even when running Pi-Hole. I can't imaging what your DNS server is for you to give that answer.

有幫助嗎?

more options

cor-el said

You can use a Preferences policy to deploy a browser.* pref.

This is interesting but it doesn't mention how to easily deploy on an existing infrastructure. I'll look it over again to see if I missed anything that will help with the deployment.

There is this notion going around that we need to dumb down software configuration/options. It's goes to the point where developers tell users "if you don't like it use something else." Monopolies like Microsoft who locked their users into their ecosystem can get away with it. The rest complain when their user base disappears. about:config is a terrible solution for a user environment configuration. There is even a warning when you open it and yet we send people there to make the browser behave. Firefox has a Search field and a Address Bar which used to work as labled. I would think that it would have been easy for the user to choose how the Address Bar behaves in the settings. Now the option is 2 search fields or mess up your settings.

Nobody is listening at Firefox and with each iteration there is less differentiating it from Chrome.

有幫助嗎?

more options

I think I see the problem now. Before Firefox 104, Firefox did this:

(1) Send linguini or linguini.pesto to your default search engine

(2) Do a follow-up DNS lookup in the background and, if there is a match, show an infobar above the page asking whether you meant to go to an internal server.

This bar had a button to load the internal page *and* it created a permanent exception in about:config (similar to the built-in browser.fixup.domainwhitelist.localhost preference):

This preference controls the background DNS lookup behavior:

browser.urlbar.dnsResolveSingleWordsAfterSearch

Valid values:

  • 0 => Never check DNS (default in Firefox 104+)
  • 1 => Check DNS selectively based heuristics (default in Firefox 78-103)
  • 2 => Always check DNS (never the default)

Over the years, many users expressed their annoyance that Firefox's post-search DNS lookup triggered the display of phony matches because of exploitive ISP DNS services or malware, and found it difficult to modify the value of a preference in about:config, so the backup search was turned off in Firefox 104.

This change removed the one-click option to add the exception, which is probably why you were motivated to create this thread rather than simply clicking that button and moving on with your day. (I hope this is not changed in the Extended Support Release, since that is targeted toward the enterprise users who tend to have internal servers.)

You could consider rolling back this change through Policy.

有幫助嗎?

more options

I missed the you are on Mac, so you can look at these pages for more info on how to deploy on Mac.

You can add policies at any time to make changes to an existing installation as you make these changes globally (plist or policies.json) for all profiles and not in the profile folder.

If you need further help with deploying on Mac then I can move the thread to "Firefox for Enterprise" support.

有幫助嗎?

more options

Reply to jscher2000: I have never seen that prompt and I've been using this browser since the first version of Netscape. This whole issue started sometime after 2019. During covid. Before that I was using it regularly to test solutions and deploy internal resources.

Reply to cor-el: The environments are mixed. Windows, Mac, Linux, FreeBSD as well as other IoT that follow standards.

I saw the link that referenced Windows, Mac and Linux but this would be doable on new installations. Some systems that connect remotely are employee systems. Before COVID it would have been easier since the remote users were few. The only feasible simple option so far is an email that explains how the user can modify their about:config. I hate everything about it.

有幫助嗎?

more options

Have users been complaining about this? Maybe you can use some of this (customize for your environment):

Firefox recently changed how it handles domain lookups in the address bar: for domain names ending with .com, .org, and other official top level domains, it still defaults to visiting the site, but for domain names ending with unofficial TLDs (for example, accounting.custom), Firefox will send the text to your default search engine. This affects our internal site(s). You can work around this change using one of these methods: (1) Add a slash after your text: Firefox will interpret accounting.custom/ as an address instead of a search query. (2) Use a bookmark to the site rather than the address bar. (3) Add a global exception for all domains ending with .custom so you can use the address bar without adding a slash. Here are the steps for that: (A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (B) In the search box in the page, type or paste browser.fixup.domainsuffixwhitelist.custom and pause while the list is filtered Firefox should display a bar with Boolean Number String and a plus button. (C) Keep the selection on Boolean and click the plus button to create a new preference for .custom domains. If the value isn't automatically set to true, double-click the preference to switch the value from false to true

有幫助嗎?

more options

選擇的解決方法

jscher2000 - Support Volunteer said

Have users been complaining about this? Maybe you can use some of this (customize for your environment):
Firefox recently changed how it handles domain lookups in the address bar: for domain names ending with .com, .org, and other official top level domains, it still defaults to visiting the site, but for domain names ending with unofficial TLDs (for example, accounting.custom), Firefox will send the text to your default search engine. This affects our internal site(s). You can work around this change using one of these methods: (1) Add a slash after your text: Firefox will interpret accounting.custom/ as an address instead of a search query.

Adding the / at the end seems to work.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題