搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Can't download anything, dialog box never appears

  • 5 回覆
  • 1 有這個問題
  • 13 次檢視
  • 最近回覆由 FredMcD

more options

Starting last night Firefox will not let me download anything. If I click on a download link, my Mac toolbar goes gray like normal, but no download dialog box ever appears. I have confirmed the dialog box isn't hiding behind any open windows on my desktop, and I have tried rebooting my system with no change.

Please help me fix this.

Starting last night Firefox will not let me download anything. If I click on a download link, my Mac toolbar goes gray like normal, but no download dialog box ever appears. I have confirmed the dialog box isn't hiding behind any open windows on my desktop, and I have tried rebooting my system with no change. Please help me fix this.

被選擇的解決方法

This turned out to not be a Firefox problem. My computer suddenly decided it is going to retain a second desktop for my other display, even when its turned of, which it has never done before. For some reason Firefox was choosing to put the dialog box on this other desktop that I didn't know existed.

Sorry for bothering you all and thanks for the advice.

從原來的回覆中察看解決方案 👍 0

所有回覆 (5)

more options

By default, Firefox 98+ will automatically save files to your default Downloads folder. You can use the Downloads button on the toolbar, or the main list opened by Command+J, to see whether any new files have been added there or there are failure notices.

If you selected "Always ask you where to save files" on the Settings/Preferences page, then before finalizing the download, Firefox should display a Finder window to choose where to save the file (and allowing you to rename it). Is that what is missing?

有幫助嗎?

more options

https://www.mozilla.org/en-US/firefox/98.0/releasenotes/ Firefox has a new optimized download flow . . . .

https://support.mozilla.org/en-US/kb/manage-downloads-preferences-using-downloads-menu Changes to how file downloads are handled in Firefox version 98

  • Firefox no longer asks what to do for each file by default
  • Downloads panel automatically opens
  • Downloaded files are saved to disk
  • Set a default app to open a file type
  • "Always Open Similar Files" option from the Downloads panel
  • Frequently asked questions


You can set this pref to false on the about:config page to prevent opening the download panel on each download.

  • browser.download.alwaysOpenPanel = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

有幫助嗎?

more options

Firefox 98 changed Always Ask to Save in Settings > General > Applications. Check your settings there and change them to what you want.

由 Terry 於 修改

有幫助嗎?

more options

選擇的解決方法

This turned out to not be a Firefox problem. My computer suddenly decided it is going to retain a second desktop for my other display, even when its turned of, which it has never done before. For some reason Firefox was choosing to put the dialog box on this other desktop that I didn't know existed.

Sorry for bothering you all and thanks for the advice.

有幫助嗎?

more options

That was very good work. Well Done.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題