搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox 98.0.1 "always open similar files" not shown

more options

The option "always open similar files" is not shown in the downloaded file context menu. This occurs on 2 machines running Windows 7 64 bit. A third machine also running Windows 7 64 bit shows it correctly. All three machines have Firefox 98.0.1 installed.

Please advise how to resolve this.

The option "always open similar files" is not shown in the downloaded file context menu. This occurs on 2 machines running Windows 7 64 bit. A third machine also running Windows 7 64 bit shows it correctly. All three machines have Firefox 98.0.1 installed. Please advise how to resolve this.

被選擇的解決方法

I think the only way "application/-x-download" could get added as a content type is if the server indicated that content type when serving the file to Firefox. Since it's non-standard, it's probably specific to one server, similar to how some sites use application/download for PDFs.

I'm going to suggest trying my add-on for this. The user interface is a bit out of date now, but it's still functional. You can install from here:

https://addons.mozilla.org/firefox/addon/content-type-fixer/

Step #1 is to turn on the listener by clicking its Zzzz toolbar button.

Next, try the problem download. I created a test file if someone is following along and doesn't have a .log file: https://www.jeffersonscher.com/res/test.log

After that, click the hammer button and click "Add/Edit Content Types (View Log)". That opens a new tab showing top level file loads during the last few minutes, and the download should be on top. In the "Action Taken" column for that row, Firefox should indicate what content type the site provided. There also should be an Add button.

The Add button allows creating an override for whatever content type the server provided. You can just use the fictitious content type, or if you prefer that the .log file open in a tab, you can manually enter text/plain as the new content type. (My web server uses text/x-log -- not sure whether that is its default or I set that up at some point?)

After saving the override, you probably will need to do the download again to get "Always Open Similar Files" on the context menu.

從原來的回覆中察看解決方案 👍 2

所有回覆 (12)

more options

有幫助嗎?

more options

What kind of file is it (for example, PDF, Excel, image, Zip)? If the server identified the file as the same type of content, and used the same file extension, and Firefox can match either of those up with a default application on the system, then I would expect the three menus to be the same. ??

有幫助嗎?

more options

I have read all that, thank you. My problem is that the Downloads panel context menu options for the file are: Show in folder, Copy download link, Delete, Remove from History, Clear Downloads. The option "Always Open Similar Files" is not there. So how do I get it to appear?

The file ends with .log and was downloaded from a Vigor router.

有幫助嗎?

more options

In answer to jscher2000: the file ends with .log and is set to open with Notepad. All .log files open correctly with Notepad. Curiously some other files - e.g. ending with .xlsx - do show "Always Open Similar Files" in the context menu.

有幫助嗎?

more options

I was wrong about the third machine. The "Always Open Similar Files" option is NOT present for files ending .log - when checking previously I had not understood that the menu option would behave differently for different file types. So all machines behave the same way in that they fail to show the "Always Open Similar Files" for .log files.

If anybody else can replicate this I will post a more specific request.

有幫助嗎?

more options

A .log file usually is plain text. Servers could tell browsers that the content type is "text/plain" but then usually the browsers will display it in a tab. To bypass that, they probably are indicating something else, and if it's the generic binary file content type, then it's normal not to have "Always Open Similar Files".

How was it working in Firefox 97? Probably you got the Download dialog because Firefox didn't know what to do automatically and you could open it there?

Okay, I guess we need a workaround to get back to that.

有幫助嗎?

more options

I tried downloading a .txt file. The clean install of Firefox 98.0.1 shows "always open similar files" in the context menu and when invoked Menu | General | Applications shows Content Type = "Text Document" and I can set Action = "Always ask". However if I download a .log file the "always open similar files" option is not available for it in the context menu. Luckily the "always ask" function works, so I can go to the saved file and edit it.

On one machine the Menu | General | Applications shows two Content Types: Text Document (application/-x-download) and Text Document (text/plain). Selecting "Always ask" for the former allows the choice of "open (with editor)" or "save" - which is what always happened with versions prior to 98.0

So the question arises: how do I get the two Content Types: Text Document (application/-x-download) and Text Document (text/plain)? Can you suggest a website here I can download files of the correct form to achieve this?

有幫助嗎?

more options

選擇的解決方法

I think the only way "application/-x-download" could get added as a content type is if the server indicated that content type when serving the file to Firefox. Since it's non-standard, it's probably specific to one server, similar to how some sites use application/download for PDFs.

I'm going to suggest trying my add-on for this. The user interface is a bit out of date now, but it's still functional. You can install from here:

https://addons.mozilla.org/firefox/addon/content-type-fixer/

Step #1 is to turn on the listener by clicking its Zzzz toolbar button.

Next, try the problem download. I created a test file if someone is following along and doesn't have a .log file: https://www.jeffersonscher.com/res/test.log

After that, click the hammer button and click "Add/Edit Content Types (View Log)". That opens a new tab showing top level file loads during the last few minutes, and the download should be on top. In the "Action Taken" column for that row, Firefox should indicate what content type the site provided. There also should be an Add button.

The Add button allows creating an override for whatever content type the server provided. You can just use the fictitious content type, or if you prefer that the .log file open in a tab, you can manually enter text/plain as the new content type. (My web server uses text/x-log -- not sure whether that is its default or I set that up at some point?)

After saving the override, you probably will need to do the download again to get "Always Open Similar Files" on the context menu.

有幫助嗎?

more options

Firefox 98.0.0 clean install on test machine. Settings | General | Applications | Content Type: Text Document = Use Notepad - this achieved as explained previously

Install your https://addons.mozilla.org/firefox/addon/content-type-fixer/ click Zzzz toolbar button.

Open router page with .log file download it - am prompted for download location

Click hammer: see: C-T: No Action - no association for extension; current CT is "application/octet-stream" Add: Content type for .log = (application/x-download) Red message "Log entry obsolete. Please try the download again to test your change."

Download .log file again Context menu now shows: "Always Open Similar Files"

Change: Settings | General | Applications | Content Type: Text Document (application/x-download) = "Always ask"

Firefox does now function as per versions prior to 98.0.

Thank you.

Have you any influence on Mozilla to get a new version to achieve this without your add-on, please?

有幫助嗎?

more options

The ultimate issue with this particular file was that the "What to do with an unknown content type" was changed from "Ask the user" to "Save the file." I did see a proposal to make that a selectable option, but that needs to go through user interface approval, so I don't know whether we would see that in Firefox 99 or whether we will see it at all. There does seem to be a lot of concern about this change, so maybe?

有幫助嗎?

more options

I am trying to set up Firefox on my Windows 10 PC workstation so that when I open a Java streaming data platform, I can open it seamlessly like I have in the past before Mozilla made a bunch of changes to Firefox.

I downloaded the content_type_fixer-1.7.4.1-fx.xpi extension, loaded it.

I managed to enable .jnlp content application/x-jnlp but beyond nothing else is working.

If I go to the Settings/General and scroll down, JNLP is not present.

If I do Ctrl-J, go into the download library and right-click on the download.jnlp file, I do not see the "Always open similar files".


This set up is still working on my laptop which was set up sometime ago well before 98.0.1.

BTW, I have been adding the browser.download.skipConfirmLaunchExecutable command in about:config.

Suggestions? Doing this properly is extremely difficult if not impossible in the paternalistic Chrome web browsers such as Chrome, Edge and Vivaldi. Still have not figured out how to do that.

I agree that Scotiabank is using outdated technology but would still appreciate any help.

有幫助嗎?

more options

ewpoole said

I downloaded the content_type_fixer-1.7.4.1-fx.xpi extension, loaded it. I managed to enable .jnlp content application/x-jnlp but beyond nothing else is working.

Hmm, I wonder whether this is because .jnlp is on Firefox's "executable files" list. Perhaps we can fool the system with a different file extension, but I'll need to set up a test.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題