On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Shockwave no longer works

  • 14 回覆
  • 1 有這個問題
  • 38 次檢視
  • 最近回覆由 cor-el

more options

Since I upgraded to version 94.0.1 I can no longer access games at shockwave.com, such as https://www.shockwave.com/gamelanding/the-daily-snoop-a-hidden-object-game.jsp. All I get is the initial splash screen.

It does work on MS Edge and since I no longer have Adobe Flash installed on my computer that shouldn't be an issue.

I have also submited this question to Shockwave. Do you have any suggestions?

Thanks.

Since I upgraded to version 94.0.1 I can no longer access games at shockwave.com, such as https://www.shockwave.com/gamelanding/the-daily-snoop-a-hidden-object-game.jsp. All I get is the initial splash screen. It does work on MS Edge and since I no longer have Adobe Flash installed on my computer that shouldn't be an issue. I have also submited this question to Shockwave. Do you have any suggestions? Thanks.

被選擇的解決方法

I'm sure that Flash isn't used despite still having Flash installed because Flash support has been from Firefox quite some time ago.

Do you get the player window indicating that at least that isn't blocked and not the window that is in the first screenshot in this reply ?

從原來的回覆中察看解決方案 👍 0

所有回覆 (14)

more options

uBlock Origin?

more options

Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

Thanks, but your suggestion did not really solve the problem. I automatically clear all history whenever I close Firefox.

I tried using Firefox in safe mode and I could see the game. However, I lost all my add-ons, including ad blocker. I would rather have to use another browser than not have the add-ons.

Moreover, I was able to use Firefox for Shockwave before the latest Firfox upgrade.

more options

crl4242 said

I tried using Firefox in safe mode and I could see the game

https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes), any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. If the problem goes away, that tells us one thing. If it does not, that tells us something else.

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

There is no joy in Mudville.

I turned off each of the add-ons -- ad blocker, tracker blocker, HTTPS Everywhere, Facebook Container -- but the program still doesn't work. I use McAfee Total Protection and Malwarebytes and am hesitant to turn them off even for a short test. Plus, they're running when I use MS Edge and ran when I accessed Shockwave through an earlier version of Firefox.

I appreciate your help but there still seems to be a disconnect between Firefox and Shockwave.

I also contacted Shockwave to see whether there was an issue they could resolve on their end. So far the only response was to ask whether I logged in as a user or anonymously. Again, that should not be a factor, given other ways in which I can use their site.

more options

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for relevant-looking messages about blocked content.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

more options

I need to disable Enhanced Tracking Protection and also disable block autoplay (i.e. choose "Allow Audio and Video") to make it work.

more options

Thanks, but this doesn't answer my problem. The shield to the left of the URL in the address line is grey, so enhanced tracking is not on.

more options

You can still try to move the slider to the off position.

Are you using any content blocking extensions like I posted above as those take prevalence and hide them for Firefox Enhanced Tracking Protection ?

more options

Thanks for the suggestion, but I tried turning off the add-ons and I have Enhanced Tracking Protection disabled. None of these actions fixed my problem. Also, all those settings are the same as they were when I could use Firfox to access Shockwave games.

more options

I got only the background at first, but after turning off Ad-block and allowing the Flash it worked for me in Linux because Flash is still installed. Let boot into Win7.

more options

Just installed 94 on Win7 with no Flash and it works for me. Not sure why in Win7 all my screenshots are not in color....

more options

選擇的解決方法

I'm sure that Flash isn't used despite still having Flash installed because Flash support has been from Firefox quite some time ago.

Do you get the player window indicating that at least that isn't blocked and not the window that is in the first screenshot in this reply ?