搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Default Search Engine keeps resetting.

  • 2 回覆
  • 2 有這個問題
  • 11 次檢視
  • 最近回覆由 jscher2000

more options

I have set my default search engine as duckduckgo, however everytime I restart the browser it has reset to google. Is there any way to make the change stick?

所有回覆 (2)

more options

That was happening with a previous profile here but eventually it stopped. I kept removing Google and making DDG the default search engine.

有幫助嗎?

more options

It's possible there is a problem with the settings file that stores the information about your default search engine. If you haven't added any search engines, then you wouldn't lose anything by removing that file and letting Firefox set it up again from scratch. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > Help > More Troubleshooting Information
  • (menu bar) Help > More Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, find the Profile Folder row. On that row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows File Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then:

Right-click search.json.mozlz4 then Rename to something like search.jsonOLD.mozlz4

Start Firefox back up again and it should build a new file. Return to the Settings page and make DuckDuckGo your default search engine again. Fingers crossed that it sticks this time!

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題