搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Search Engine Default problems

  • 3 回覆
  • 1 有這個問題
  • 3 次檢視
  • 最近回覆由 FredMcD

more options

I just started using Firefox recently. I can't get my search engine to stick. Every time i change it it changes back to Google. Every time I delete Google it shows back up . It's like a bad infection. How can I change my search engine and not have it revert back to default? I have performed all of the recommended procedures with no success. And I have no add-ons installed.

所有回覆 (3)

more options

Hmm, that's odd.

Is your Firefox retaining other data, such as bookmarks, history, other changed settings, and theme or toolbar layout changes?

Are you choosing a different default search engine from the built-in list (for example, Bing or DuckDuckGo), or are you using an add-on for the new default search engine?

有幫助嗎?

more options

This feels a little like it could be malware/adware, where they're setting the default to an engine that has been blocked, and Firefox is then resetting to default (as that's all it can do).

Might be worth using something like MalwareBytes to check for malware/adware. I'd be interested to know the names of anything it did find.

有幫助嗎?

more options

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; (<Control> [Mac=<Command>] <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove “ Google “ Anything.

Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine, securedsearch

Now do the same in the computer’s Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the Applications folder. Linux: Check your user manual.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題