X
點擊此處開啟此網站的行動版。

技術支援討論區

Can't update firefox to the latest version

已張貼

I keep getting a message "System Unsupported", that Firefox is out of date and that I need to upgrade my system to a version of windows (7, 8 or 10) that microsoft still suports. We upgraded our computer from WIndows 7 to 10 a while ago.

I keep getting a message "System Unsupported", that Firefox is out of date and that I need to upgrade my system to a version of windows (7, 8 or 10) that microsoft still suports. We upgraded our computer from WIndows 7 to 10 a while ago.

額外的系統細節

已安裝的外掛程式

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 19.8.20071
  • AmazonMP3DownloaderPlugin 1.0.15
  • Citrix Online App Detector Plugin
  • Garmin Communicator Plug-In 4.1.0.0
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.181.2 for Mozilla browsers
  • Picasa plugin
  • Shockwave Flash 32.0 r0
  • 5.1.50907.0
  • NPWLPG
  • iTunes Detector Plug-in

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

更多資訊

James
  • Top 25 Contributor
  • Moderator
1603 個解決方法 11348 個答案

In your More System Details by your post your UserAgent shows you using Firefox 52 on Windows Vista (NT 6.0).

Mozilla/5.0 (Windows NT 6.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

https://support.microsoft.com/help/15078/windows-make-older-programs-compatible

You may be for some reason running Firefox in Windows Vista compatibility mode. Firefox 53 and later requires Windows 7 or later to run.


edit: After fixing this compatibility setting, download current Firefox 63.0.3 Release from www.mozilla.org/firefox/all/ because if you were to do a internal update in Firefox you would get 60.3.0 ESR instead as you are on ESR channel due to using 52.9.0esr.

In your More System Details by your post your UserAgent shows you using Firefox 52 on Windows Vista (NT 6.0). Mozilla/5.0 (Windows '''NT 6.0'''; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 https://support.microsoft.com/help/15078/windows-make-older-programs-compatible You may be for some reason '''running Firefox in Windows Vista compatibility mode'''. Firefox 53 and later requires Windows 7 or later to run. edit: After fixing this compatibility setting, download current Firefox 63.0.3 Release from www.mozilla.org/firefox/all/ because if you were to do a internal update in Firefox you would get 60.3.0 ESR instead as you are on ESR channel due to using 52.9.0esr.

由 James 於 修改

cor-el
  • Top 10 Contributor
  • Moderator
17681 個解決方法 159964 個答案

Like posted above, check that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

Like posted above, check that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.