搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox Zoom keeps changing to 100% every time tab is clicked

  • 2 回覆
  • 4 有這個問題
  • 39 次檢視
  • 最近回覆由 hifromnz

more options

This is driving me nuts.

I had to zoom every page out to 67% to fit most pages in my window (half of a 27" monitor - I need to look at other things at the same time, did someone overlook this?)

When I opened another tab, sometimes (I think) it copied the zoom level.

Each time I changed the zoom level in one window, It usually seemed to change the zoom level in other windows too (which was annoying, some I had already zoomed to 50, some to 80).

So I looked for a way to set the default zoom to 67%. Oh, there's none. Why not, wasnt Firefox just rewritten? (Without options avialable in other browsers???)

I tried clicking "zoom text only". Then I tried setting the font to 10 point. Then I tried unchecking override page settings box. They didn't work so I changed them all back.

Now EVERY tab changes to 100%, every time I switch to another tab then back to it. I have done NOTHING. I can actually see it at the 67% zoom I set for a fraction of a second after switching back to the tab, THEN it changes the zoom to 100% before my eyes.

It changes every time I reload the tab - or go to another address (like edit this question). I am contstantly having to press control- several times before I can see what I am doing.

Please don't tell me to refresh firefox! I have spent enough time setting it up and trying to make stupid things like this work. This is just unbelievable. This is supposed to be a user friendly, stable programme.

Can anyone help with what has caused this and how to fix it please? I don't want another addon to conflict with the addons I have and slow down ff, I would be grateful just to return to the browser remembering the zoom level I manually set in my active tabs.

 :-o

(I tried installing Zoom Page. It disabled the Ctrl-/+, doesnt work on Mozilla pages, and the zoom keeps reverting to 100% - not fixed.

附加的畫面擷圖

由 hifromnz 於 修改

所有回覆 (2)

more options

Maybe check these prefs on the about:config page:

  • browser.zoom.siteSpecific
  • browser.zoom.updateBackgroundTabs

The "Resist Fingerprinting" feature can also affect zoom.

more options

Hi, thanks for your input, I havent checked your suggestions because the issue seems to have self-resolved after I restarted FF. Unfortunately I can't say whether Zoom Page add-on fixed it or just restarting, as it was installed before I exited FF.

But after Zoom Page was uninstalled tabs are no longer changing so my sanity is regained. :-)

If anyone else finds this problem suggest you restart FF and report here if that fixes it?

Cheers, V