搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

MOZILLA_PKIX_ERROR_MITM_DETECTED in Firefox Nightly?

  • 3 回覆
  • 10 有這個問題
  • 21479 次檢視
  • 最近回覆由 dleaper

more options

Hello, I have been using Firefox for at least three years or so and I actually decided to try the Firefox Nightly browser. However, just yesterday I started to have issues with the browser, for some strange reason or another, I will get the 'Your connection is not secure' page no matter what website I go to. The error code is the following:

www.deviantart.com uses an invalid security certificate.

The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported.

Error code: MOZILLA_PKIX_ERROR_MITM_DETECTED

At first, I thought it was because I needed to update my antivirus (I use AVG), so when I did update it and restarted my computer, the browser worked for a little while, but then it started acting up again not long after with the same error. Again, this does this for any website I try to go to, not just DeviantART.

This is the code text from Nightly that I would presume codes for the certificate:

https://www.deviantart.com/ Your connection is being intercepted by a TLS proxy. Uninstall it if possible or configure your device to trust its root certificate. HTTP Strict Transport Security: false HTTP Public Key Pinning: false

Certificate chain:


BEGIN CERTIFICATE-----

MIIELjCCAxagAwIBAgIQBpUGIIUVmEuO/Hj1wej55zANBgkqhkiG9w0BAQsFADB7 MTgwNgYDVQQLDC9nZW5lcmF0ZWQgYnkgQVZHIEFudGl2aXJ1cyBmb3IgU1NML1RM UyBzY2FubmluZzEcMBoGA1UECgwTQVZHIFdlYi9NYWlsIFNoaWVsZDEhMB8GA1UE AwwYQVZHIFdlYi9NYWlsIFNoaWVsZCBSb290MB4XDTE4MDEzMTAwMDAwMFoXDTIw MDIyNjEyMDAwMFowezELMAkGA1UEBhMCVVMxEzARBgNVBAgTCkNhbGlmb3JuaWEx FDASBgNVBAcTC0xvcyBBbmdlbGVzMRkwFwYDVQQKExBEZXZpYW50QXJ0LCBJbmMu MQswCQYDVQQLEwJJVDEZMBcGA1UEAwwQKi5kZXZpYW50YXJ0LmNvbTCCASIwDQYJ KoZIhvcNAQEBBQADggEPADCCAQoCggEBAOr4ugCjLqA7pnoBn2wXymE6QJ5RiE3t 9JI/UuUyHbVb/RIWg0D+Y28wuXEXvVxIduNj56jlV1WEDkCkGxq0MTdv/kglbVHb qZeMlBc877B07Q2p6/yHnSIwiJ5tqQGe7u9CDk7SHKI9yGzxOxE381oCf7BiaeFy B6NepwRu/E+G2xocS2QtIyn6yqplMo+vYVW8GKyrpwJSkkVATmSDQAbiOyak0Nj6 hAQ8orc25vHuqcvCnUULtJYNWa61p5k+beIUAkwJwHs8FacRNsMw182imTnOgcip Gy7HxSHz3nHSJeJevVI3TCQK35wFsf2cpXlNrIwET3PXrCDEUVElScMCAwEAAaOB rTCBqjAfBgNVHSMEGDAWgBRz0ie2sAWXm2IEdOmY7UUkPHBPwjAdBgNVHQ4EFgQU J6W9qk/yJ1wB8iIWhTQNTeHZTiMwKwYDVR0RBCQwIoIQKi5kZXZpYW50YXJ0LmNv bYIOZGV2aWFudGFydC5jb20wDgYDVR0PAQH/BAQDAgWgMB0GA1UdJQQWMBQGCCsG AQUFBwMBBggrBgEFBQcDAjAMBgNVHRMBAf8EAjAAMA0GCSqGSIb3DQEBCwUAA4IB AQAOvDQ4pWcvTW3k+Fx3+ehyydoHs/HKTgry26dDyvIGfajG+6Ia9WszzxPu8+eJ BkAqQK/vNMVFLp09w2zPYSbMRI2UdCythzBW7sKspM/dtrB7ryzkeq3eCBvqYWdy qvN84/NYVrb7vFSHzT0xohi5d9V8WPoC5Wy9ngLWFkw+s+cl87ZZ7FURTny7tYWa aGAzIYgNxReK3niSHBQlHkFr7Y6ZYfpiPNJbBI64rEbjl4Cw39jFykqbee81GJ3J KWQaH08OVJVM28liKyLXqGEUdxXlgPH7nMzsrP4OyKce1jD7zVtpH4Hnn2IUbztd xQU8LAGaZ+DcOP4hxK+Tvg9+


END CERTIFICATE-----
BEGIN CERTIFICATE-----

MIID9TCCAt2gAwIBAgIQfwgL7Fj7d0Su9TxVArD+2DANBgkqhkiG9w0BAQsFADB7 MTgwNgYDVQQLDC9nZW5lcmF0ZWQgYnkgQVZHIEFudGl2aXJ1cyBmb3IgU1NML1RM UyBzY2FubmluZzEcMBoGA1UECgwTQVZHIFdlYi9NYWlsIFNoaWVsZDEhMB8GA1UE AwwYQVZHIFdlYi9NYWlsIFNoaWVsZCBSb290MB4XDTEwMDEwMTEyMDAwMFoXDTQw MDEwMTEyMDAwMFowezE4MDYGA1UECwwvZ2VuZXJhdGVkIGJ5IEFWRyBBbnRpdmly dXMgZm9yIFNTTC9UTFMgc2Nhbm5pbmcxHDAaBgNVBAoME0FWRyBXZWIvTWFpbCBT aGllbGQxITAfBgNVBAMMGEFWRyBXZWIvTWFpbCBTaGllbGQgUm9vdDCCASIwDQYJ KoZIhvcNAQEBBQADggEPADCCAQoCggEBAMFpW4Yl2GM2knRutQUM6CiQyme0OVyl Dz0mpDuA3Hvnu5cT9j+U+IuuZkUFWvS7dWam3HDqaiHbIZ2exy7a25ItB4iwENEK Gf2SQKfMrePIpWDfWj2ofH5DB1iIJIDvyeOEWpXvoP8Dnv3Fx/+V++4MS9OBcpTW rFv6ACiA2VsgAS3XqSiUbLI5clA+xdCQbab2W8F0pal96qA51XzdXp7yLciOQCGs h7F250WsF9SKMLqI/pMHWKGXy9EMF0t4usl7383j4UATklMf6zUiBAESXRTrOaQX y1vds8n7o3V5KKPUVloRCXjZ/hRa3JiFNqWGEvoFnuPAh9uMXjhNoPECAwEAAaN1 MHMwDwYDVR0TBAgwBgEB/wIBADALBgNVHQ8EBAMCAgQwEwYDVR0lBAwwCgYIKwYB BQUHAwEwHQYDVR0OBBYEFHPSJ7awBZebYgR06ZjtRSQ8cE/CMB8GA1UdIwQYMBaA FHPSJ7awBZebYgR06ZjtRSQ8cE/CMA0GCSqGSIb3DQEBCwUAA4IBAQCK2tlUN92Z M6I5sTcTQGCqE1n8ItVkd/Xt/Zj3wI/XkOSloT727HyTjwoH6R9McMiQfHXAKTEP h7TBybbqnbRbSxrJTcaRIbEeQCtgwIB/gw9zpUHBAA/8ZXtbDh9AWWWRHd8uN+Ws Vt0atgSxzZeXHX3ooNxnrQy/UUCy5NLKvtu8mMu/ueEHGrKra2RymJNFdpNsip4m srym3LzQ5NNK4ei4OrqvL3pp7Yl220AmaIxkEYnnLpxCa7uP1doIXGs7gAdwOTjw whpIT7cEBT03J0NgS1xEL/NCY084tr7vj8aEXXMStGVaSxlFXSy8gSHJrOWLnXNB rMhjectNvUfh


END CERTIFICATE-----

被選擇的解決方法

hi, thanks for providing some error details. unfortunately it appears like your avg software is meddling with secure connections. i'd recommend to turn off the https scanning functionality within their settings, like it's described for avast at How to troubleshoot security error codes on secure websites (they're the same company now).

從原來的回覆中察看解決方案 👍 0

所有回覆 (3)

more options

選擇的解決方法

hi, thanks for providing some error details. unfortunately it appears like your avg software is meddling with secure connections. i'd recommend to turn off the https scanning functionality within their settings, like it's described for avast at How to troubleshoot security error codes on secure websites (they're the same company now).

more options

philipp said

hi, thanks for providing some error details. unfortunately it appears like your avg software is meddling with secure connections. i'd recommend to turn off the https scanning functionality within their settings, like it's described for avast at How to troubleshoot security error codes on secure websites (they're the same company now).

Alright, I did as you have suggested in turning off the HTTPS scanning functionality within the settings and that has fixed the issue. Thank you so much for the assistance. :)

more options

Another Solution that worked for me was to re-apply the solution for a a different error message: SEC_ERROR_UNKNOWN_ISSUER

I just change the setting from True, to False, and then to True again, without a restart of Firefox for the Preference security.enterprise_roots.enabled under about:config.

I should note that i have Firefox latest Beta 64 bit, on Windows 10, and on a corporate network - so I can't just disabled Anti-virus and such.

This is the link to getting SEC_ERROR_UNKNOWN_ISSUER error Original Post.