X
點擊此處開啟此網站的行動版。

技術支援討論區

此討論串已經關閉並封存。 如果您有需要幫助,請新增一個新問題

How do I get rid of the "Recently Bookmarked" section in my bookmarks toolbar?

已張貼

Just updated and all of a sudden I have this obnoxious section in my bookmarks toolbar telling me what I recently bookmarked and an unnecessary folder titled "Other Bookmarks" which I can't delete. How do I get rid of them, and who in their right mind thinks that adding more clutter that can't easily be removed is a good idea?

Just updated and all of a sudden I have this obnoxious section in my bookmarks toolbar telling me what I recently bookmarked and an unnecessary folder titled "Other Bookmarks" which I can't delete. How do I get rid of them, and who in their right mind thinks that adding more clutter that can't easily be removed is a good idea?

被選擇的解決方法

The Other Bookmarks item shows the Unsorted folder.

Maybe thiscode work better:

#menu_unsortedBookmarks,
#BMB_unsortedBookmarks {display:none!important}

#BMB_recentBookmarks,
#BMB_recentBookmarks+.bookmark-item,
#BMB_recentBookmarks+.bookmark-item+.bookmark-item,
#BMB_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item,
#BMB_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item,
#BMB_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item{display:none!important}

#menu_recentBookmarks,
#menu_recentBookmarks+.bookmark-item,
#menu_recentBookmarks+.bookmark-item+.bookmark-item,
#menu_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item,
#menu_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item,
#menu_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item{display:none!important}
從原來的回覆中察看解決方案 4

額外的系統細節

已安裝的外掛程式

  • Battlelog Game Launcher (2.7.1)
  • Battlelog Game Launcher (2.6.2)
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 21.0 r0
  • iTunes Detector Plug-in

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

更多資訊

cor-el
  • Top 10 Contributor
  • Moderator
17569 個解決方法 158913 個答案

Did you ever import any bookmarks via the Bookmarks Manager (Library) or are you using Sync to sync bookmarks from other devices?

You can check for problems with the places.sqlite database (bookmarks and history) in the Firefox profile folder.

See also:


Some information about so called smart bookmarks folders:

  • "Most Visited" and "Recently Bookmarked" and "Recent Tags" are examples of so called Smart Bookmarks folders and are not real existing folders.
  • Smart folders show a list created by a query of the places.sqlite database that stores bookmarks and history in Firefox.
  • Smart folder lists show a maximum of 10 entries by default.
  • Bookmarks and history items that show up in a smart folder list are stored elsewhere in another folder and any changes made are applied to the real bookmark or history item.
  • If you remove an entry then the list is shifted up and a new entry that wasn't shown previously is added to show 10 entries.
  • If you add a new bookmark or visit a website then a new item is added at the top and the entry at the bottom disappears from that list.
  • Items that disappear from the list are not gone, but merely do not show up anymore in that list.
  • Actions like copy & paste or delete that you perform on bookmarks in such a list are done on the original bookmark.
  • If you do not want a specific list then remove that query (right-click: Delete), but do not delete the content that is displayed in such a list.
Did you ever import any bookmarks via the Bookmarks Manager (Library) or are you using Sync to sync bookmarks from other devices? You can check for problems with the <b>places.sqlite</b> database (bookmarks and history) in the Firefox profile folder. *https://addons.mozilla.org/firefox/addon/places-maintenance/ See also: *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file ---- Some information about so called smart bookmarks folders: * "Most Visited" and "Recently Bookmarked" and "Recent Tags" are examples of so called [[Smart Bookmarks folders|Smart Bookmarks folders]] and are not real existing folders. * Smart folders show a list created by a query of the places.sqlite database that stores bookmarks and history in Firefox. * Smart folder lists show a maximum of 10 entries by default. * Bookmarks and history items that show up in a smart folder list are stored elsewhere in another folder and any changes made are applied to the real bookmark or history item. * If you remove an entry then the list is shifted up and a new entry that wasn't shown previously is added to show 10 entries. * If you add a new bookmark or visit a website then a new item is added at the top and the entry at the bottom disappears from that list. * Items that disappear from the list are not gone, but merely do not show up anymore in that list. * Actions like copy & paste or delete that you perform on bookmarks in such a list are done on the original bookmark. * If you do not want a specific list then remove that query (right-click: Delete), but do not delete the content that is displayed in such a list.

提出問題者

These things only showed up today when I updated to 48. They can't be deleted and they are obnoxious to say the least. I want to know how to remove them because I don't care for either.

These things only showed up today when I updated to 48. They can't be deleted and they are obnoxious to say the least. I want to know how to remove them because I don't care for either.
jscher2000
  • Top 10 Contributor
8786 個解決方法 71864 個答案

Hi Immortal009, I'm still running Firefox 46, so your display looks a little unfamiliar. Is that the Bookmarks menu from the classic menu bar, or something else?

Some sections of the Bookmarks menu are hardcoded and can't be moved around in the Library dialog (Ctrl+Shift+b). In that case, you could use a custom style rule to hide them, but someone probably would need hands-on access to craft the rule.

Hi Immortal009, I'm still running Firefox 46, so your display looks a little unfamiliar. Is that the Bookmarks menu from the classic menu bar, or something else? Some sections of the Bookmarks menu are hardcoded and can't be moved around in the Library dialog (Ctrl+Shift+b). In that case, you could use a custom style rule to hide them, but someone probably would need hands-on access to craft the rule.

提出問題者

I was using 47 before this and these new bookmark "features" were not there in any previous version. I am using the drop down bookmarks tab from the menu bar. "Recently Bookmarked" does not show up in the Library dialog, but the "Other Bookmarks" folder does, though right clicking on it gives me no options (can't even rename it).

I was using 47 before this and these new bookmark "features" were not there in any previous version. I am using the drop down bookmarks tab from the menu bar. "Recently Bookmarked" does not show up in the Library dialog, but the "Other Bookmarks" folder does, though right clicking on it gives me no options (can't even rename it).
cor-el
  • Top 10 Contributor
  • Moderator
17569 個解決方法 158913 個答案

Recently bookmarked could be this selector in the "Show your bookmarks" drop-down list (#BMB_recentBookmarks) and in the Bookmarks Menu (#menu_recentBookmarks).

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#BMB_recentBookmarks { display:none!important; }
#menu_recentBookmarks { display:none!important; }

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

Recently bookmarked could be this selector in the "Show your bookmarks" drop-down list (#BMB_recentBookmarks) and in the Bookmarks Menu (#menu_recentBookmarks). Add code to the <b>userChrome.css</b> file below the default @namespace line. *http://kb.mozillazine.org/userChrome.css ---- <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #BMB_recentBookmarks { display:none!important; } #menu_recentBookmarks { display:none!important; } </nowiki></pre> ---- The customization files userChrome.css (user interface) and userContent.css (websites) are located in the <b>chrome</b> folder in the Firefox profile folder. *http://kb.mozillazine.org/Editing_configuration
cor-el
  • Top 10 Contributor
  • Moderator
17569 個解決方法 158913 個答案

See also:

  • bug 1219804 - Show last 5 recent bookmarks in the bookmarks menu

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

See also: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1219804 bug 1219804] - Show last 5 recent bookmarks in the bookmarks menu <i>Please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>

提出問題者

Copied the userChrome.css you posted, all it did was remove the "Recently Bookmarked" entry which is progress I guess, however the 5 most recent bookmarks are still there cluttering everything up.

Copied the userChrome.css you posted, all it did was remove the "Recently Bookmarked" entry which is progress I guess, however the 5 most recent bookmarks are still there cluttering everything up.
jscher2000
  • Top 10 Contributor
8786 個解決方法 71864 個答案

I think this is a hard one because there are five new menuitem elements after the heading, but as far as I can tell from looking at the code (a dangerous exercise for a non-coder!) they may not be uniquely identifiable versus other bookmarks. For example, this might affect too many, but you could test it (this does nothing in Firefox 46):

.menuitem-iconic.menuitem-with-favicon.bookmark-item.subviewbutton { background-color: #ffe !important; }

If the pale yellow appears behind other bookmarks, then this selector is not unique enough. If it only affects the recently bookmarked list, you could change the style rule to display:none and hopefully that will take care of them.

I think this is a hard one because there are five new menuitem elements after the heading, but as far as I can tell from looking at the code (a dangerous exercise for a non-coder!) they may not be uniquely identifiable versus other bookmarks. For example, this might affect too many, but you could test it (this does nothing in Firefox 46): <nowiki>.menuitem-iconic.menuitem-with-favicon.bookmark-item.subviewbutton { background-color: #ffe !important; }</nowiki> If the pale yellow appears behind other bookmarks, then this selector is not unique enough. If it only affects the recently bookmarked list, you could change the style rule to display:none and hopefully that will take care of them.
cor-el
  • Top 10 Contributor
  • Moderator
17569 個解決方法 158913 個答案

選擇的解決方法

The Other Bookmarks item shows the Unsorted folder.

Maybe thiscode work better:

#menu_unsortedBookmarks,
#BMB_unsortedBookmarks {display:none!important}

#BMB_recentBookmarks,
#BMB_recentBookmarks+.bookmark-item,
#BMB_recentBookmarks+.bookmark-item+.bookmark-item,
#BMB_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item,
#BMB_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item,
#BMB_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item{display:none!important}

#menu_recentBookmarks,
#menu_recentBookmarks+.bookmark-item,
#menu_recentBookmarks+.bookmark-item+.bookmark-item,
#menu_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item,
#menu_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item,
#menu_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item{display:none!important}
The Other Bookmarks item shows the Unsorted folder. Maybe thiscode work better: <pre><nowiki> #menu_unsortedBookmarks, #BMB_unsortedBookmarks {display:none!important} #BMB_recentBookmarks, #BMB_recentBookmarks+.bookmark-item, #BMB_recentBookmarks+.bookmark-item+.bookmark-item, #BMB_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item, #BMB_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item, #BMB_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item{display:none!important} #menu_recentBookmarks, #menu_recentBookmarks+.bookmark-item, #menu_recentBookmarks+.bookmark-item+.bookmark-item, #menu_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item, #menu_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item, #menu_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item{display:none!important}</nowiki></pre>

提出問題者

That code worked, all the unnecessary clutter is gone, though to be nit-picky there is still a redundant separator. Thanks a lot, I hate little things like this that should be easy to solve with a click.

That code worked, all the unnecessary clutter is gone, though to be nit-picky there is still a redundant separator. Thanks a lot, I hate little things like this that should be easy to solve with a click.
cor-el
  • Top 10 Contributor
  • Moderator
17569 個解決方法 158913 個答案

You're welcome. The bookmark-item elements aren't in a separate container, so the code looks a bit weird. I don't know if there is a shorter way to specify elements between two selectors or a specific number of items that follow a specific selector.

The separator would probably be the last item with menuseparator appended:

#menu_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item+menuseparator {display:none!important;}
#BMB_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item+menuseparator {display:none!important;}
You're welcome. The bookmark-item elements aren't in a separate container, so the code looks a bit weird. I don't know if there is a shorter way to specify elements between two selectors or a specific number of items that follow a specific selector. The separator would probably be the last item with menuseparator appended: #menu_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item+menuseparator {display:none!important;} #BMB_recentBookmarks+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item+.bookmark-item+menuseparator {display:none!important;}
neRok00 0 個解決方法 2 個答案

有幫助的回覆

I found this page on google when looking for a solution to the same problem, which seems to have appeard in v48 for me too. I did just discover you can right click in the bookmark menu and "Hide Recently Bookmarked". I am now on 49.0b1 though, so perhaps this was a change since then?

I found this page on google when looking for a solution to the same problem, which seems to have appeard in v48 for me too. I did just discover you can right click in the bookmark menu and "Hide Recently Bookmarked". I am now on 49.0b1 though, so perhaps this was a change since then?

由 neRok00 於 修改

David S. 3 個解決方法 32 個答案

有幫助的回覆

1. Type "about:config" in address bar. Tell it you'll be careful, etc.

2. Search for "browser.bookmarks.showRecentlyBookmarked" in the config parameters and then double-click on it's "Value" field so it switches from "true" to "false".

3. There is no step 3.

N.B. The above works with FF 49.0, don't know if it's applicable to earlier versions or not.

1. Type "about:config" in address bar. Tell it you'll be careful, etc. 2. Search for "browser.bookmarks.showRecentlyBookmarked" in the config parameters and then double-click on it's "Value" field so it switches from "true" to "false". 3. There is no step 3. N.B. The above works with FF 49.0, don't know if it's applicable to earlier versions or not.
Nelson Yeung 0 個解決方法 6 個答案

I don't get what's with all the code and crazy settings. Just right click on the bookmark pop up and press "Hide Recently Bookmarked". Simple.

I don't get what's with all the code and crazy settings. Just right click on the bookmark pop up and press "Hide Recently Bookmarked". Simple.
David S. 3 個解決方法 32 個答案

Nelson Yeung said

I don't get what's with all the code and crazy settings. Just right click on the bookmark pop up and press "Hide Recently Bookmarked". Simple.

What do you mean by the "bookmark pop up"? Are you referring to the Bookmarks view in the Sidebar? I don't enable the sidebar; I always access bookmarks from the menu (as God intended). If you mean something else then please explain where this mysterious pop up is located, because I don't see it.

''Nelson Yeung [[#answer-919229|said]]'' <blockquote> I don't get what's with all the code and crazy settings. Just right click on the bookmark pop up and press "Hide Recently Bookmarked". Simple. </blockquote> What do you mean by the "bookmark pop up"? Are you referring to the Bookmarks view in the Sidebar? I don't enable the sidebar; I always access bookmarks from the menu (as God intended). If you mean something else then please explain where this mysterious pop up is located, because I don't see it.
jscher2000
  • Top 10 Contributor
8786 個解決方法 71864 個答案

Hi David S., I think Nelson meant the bookmarks menu that you open using the toolbar button. However, in Firefox 49, it should work on either the bookmarks menu on the classic menu bar or the one that opens from the button.

Right-click the gray wording Recently Bookmarked, and the last item on the right-click context menu should be "Hide Recently Bookmarked". Under the covers, this changes the preference you found in about:config from true to false.

Hi David S., I think Nelson meant the bookmarks menu that you open using the toolbar button. However, in Firefox 49, it should work on either the bookmarks menu on the classic menu bar or the one that opens from the button. Right-click the gray wording Recently Bookmarked, and the last item on the right-click context menu should be "Hide Recently Bookmarked". Under the covers, this changes the preference you found in about:config from true to false.

由 jscher2000 於 修改

David S. 3 個解決方法 32 個答案

jscher2000 said

Hi David S., I think Nelson meant the bookmarks menu that you open using the toolbar button. However, in Firefox 49, it should work on either the bookmarks menu on the classic menu bar or the one that opens from the button. Right-click the gray wording Recently Bookmarked, and the last item on the right-click context menu should be "Hide Recently Bookmarked". Under the covers, this changes the preference you found in about:config from true to false.

Right-clicking on the gray wording in the pulldown Bookmarks menu does nothing on a Mac (I'll bet this is the problem - I'm doing this on a Mac not a Windows machine). But now that I poke around I find that if I put the Bookmarks "star" tool into the toolbar (which one again I normally don't because it's just useless clutter when you already have a menu called Bookmarks right there) and right-click on that then I get the pop-up menu with the option to hide the recently bookmarked!

So it all seems to depend on whether you're using the stupid bookmarks tool in the Toolbar or not. Of course on a Windows install where the default is to not display a regular menubar anymore you probably need to... (unprintable commentary involving Microsoft and sheep redacted).

''jscher2000 [[#answer-919236|said]]'' <blockquote> Hi David S., I think Nelson meant the bookmarks menu that you open using the toolbar button. However, in Firefox 49, it should work on either the bookmarks menu on the classic menu bar or the one that opens from the button. Right-click the gray wording Recently Bookmarked, and the last item on the right-click context menu should be "Hide Recently Bookmarked". Under the covers, this changes the preference you found in about:config from true to false. </blockquote> Right-clicking on the gray wording in the pulldown Bookmarks menu does nothing on a Mac (I'll bet this is the problem - I'm doing this on a Mac not a Windows machine). But now that I poke around I find that if I put the Bookmarks "star" tool into the toolbar (which one again I normally don't because it's just useless clutter when you already have a menu called Bookmarks right there) and right-click on that ''then'' I get the pop-up menu with the option to hide the recently bookmarked! So it all seems to depend on whether you're using the stupid bookmarks tool in the Toolbar or not. Of course on a Windows install where the default is to not display a regular menubar anymore you probably need to... (unprintable commentary involving Microsoft and sheep redacted).
jscher2000
  • Top 10 Contributor
8786 個解決方法 71864 個答案

Hi David S., I think on Mac right-click is replaced by Ctrl+click and if someone would give me a Mac I would be happy to test that myself.

Hi David S., I think on Mac '''right-click''' is replaced by '''Ctrl+click''' and if someone would give me a Mac I would be happy to test that myself.
David S. 3 個解決方法 32 個答案

jscher2000 said

Hi David S., I think on Mac right-click is replaced by Ctrl+click and if someone would give me a Mac I would be happy to test that myself.

On a Mac right-clicking and ctrl-clicking do exactly the same thing (ctrl-click is a hangover from the olden days of single-button mice).

Yeah, I've done more testing and that's definitely it - on a Mac you have to open the list of bookmarks using the Bookmarks "star" tool in the toolbar, right click on the gray text in there and that pops up the menu option to hide recently bookmarked. If you right-click on the gray text from the app's normal Bookmarks menu nothing happens. Sigh.

''jscher2000 [[#answer-919250|said]]'' <blockquote> Hi David S., I think on Mac '''right-click''' is replaced by '''Ctrl+click''' and if someone would give me a Mac I would be happy to test that myself. </blockquote> On a Mac right-clicking and ctrl-clicking do exactly the same thing (ctrl-click is a hangover from the olden days of single-button mice). Yeah, I've done more testing and that's definitely it - on a Mac you have to open the list of bookmarks using the Bookmarks "star" tool in the toolbar, right click on the gray text in there and that pops up the menu option to hide recently bookmarked. If you right-click on the gray text from the app's normal Bookmarks menu nothing happens. Sigh.
neRok00 0 個解決方法 2 個答案

Further to what David S. has discovered, using win 7 x64 and firefox 49.0, I have opened the bookmark menu (after pressing the alt key to make it appear) and can confirm that the hide/show recently bookmarked option is present in that right click menu also.

What options are in that right click menu on mac David S.? Mine has options such as new seperator, and open in new tab. Perhaps mac doesn't allow firefox to change the right click menu of such a menu, and you don't have any of these options either?

Further to what David S. has discovered, using win 7 x64 and firefox 49.0, I have opened the bookmark menu (after pressing the alt key to make it appear) and can confirm that the hide/show recently bookmarked option is present in that right click menu also. What options are in that right click menu on mac David S.? Mine has options such as new seperator, and open in new tab. Perhaps mac doesn't allow firefox to change the right click menu of such a menu, and you don't have any of these options either?