X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox v40.0.3 does not launch

已張貼

I am attempting to create a customized installation package for Mozilla Firefox v40.0.3.


>> OS : Windows 7 SP1 x64 <<----

I have performed a Custom installation of the browser (unchecked 'Install Maintenance Service' check-box).

After successful installation, copied the following files to the respective directories:

1. Copied 'local-settings.js' to 'C:\Program Files (x86)\Mozilla Firefox\defaults\pref'


Contents of this file-----------

pref("general.config.obscure_value", 0); pref("general.config.filename", "mozilla.cfg");



2. Copied 'mozilla.cfg' to 'C:\Program Files (x86)\Mozilla Firefox'


Contents of this file-----------

// pref("browser.startup.homepage", http://intranet/); pref("browser.shell.checkDefaultBrowser", false); pref("app.update.auto", false); pref("app.update.enabled", false); pref("app.update.service.enabled", false); pref("browser.cache.disk.smart_size.use_old_max", false); pref("browser.search.update", false); pref("datareporting.healthreport.uploadEnabled", false); pref("signon.rememberSignons", false);


After performing these steps, when I attempt to launch firefox, it fails to launch at all. No errors are displayed. In Task manager, I noticed firefox.exe getting invoked but it exits within seconds.

What is the cause? Please help.

I am attempting to create a customized installation package for Mozilla Firefox v40.0.3. ---->> OS : Windows 7 SP1 x64 <<---- I have performed a Custom installation of the browser (unchecked 'Install Maintenance Service' check-box). After successful installation, copied the following files to the respective directories: 1. Copied 'local-settings.js' to 'C:\Program Files (x86)\Mozilla Firefox\defaults\pref' -----Contents of this file----------- pref("general.config.obscure_value", 0); pref("general.config.filename", "mozilla.cfg"); -------------------------------------------- 2. Copied 'mozilla.cfg' to 'C:\Program Files (x86)\Mozilla Firefox' ---------Contents of this file----------- // pref("browser.startup.homepage", http://intranet/); pref("browser.shell.checkDefaultBrowser", false); pref("app.update.auto", false); pref("app.update.enabled", false); pref("app.update.service.enabled", false); pref("browser.cache.disk.smart_size.use_old_max", false); pref("browser.search.update", false); pref("datareporting.healthreport.uploadEnabled", false); pref("signon.rememberSignons", false); --------------------------------------------------------------- After performing these steps, when I attempt to launch firefox, it fails to launch at all. No errors are displayed. In Task manager, I noticed firefox.exe getting invoked but it exits within seconds. What is the cause? Please help.

被選擇的解決方法

There are no quotes around the browser.startup.homepage value.

//
pref("browser.startup.homepage", "http://intranet/");
pref("browser.shell.checkDefaultBrowser", false);
pref("app.update.auto", false);
pref("app.update.enabled", false);
pref("app.update.service.enabled", false);
pref("browser.cache.disk.smart_size.use_old_max", false);
pref("browser.search.update", false);
pref("datareporting.healthreport.uploadEnabled", false);
pref("signon.rememberSignons", false);
從原來的回覆中察看解決方案 1

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.93 Safari/537.36

更多資訊

FredMcD
  • Top 10 Contributor
4314 個解決方法 60573 個答案

First, remove everything you did to see if Firefox will work properly. You may want to just remove the current Firefox folders and re-install.

If it works, make one change, Then test FF.

First, remove everything you did to see if Firefox will work properly. You may want to just remove the current Firefox folders and re-install. If it works, make one change, Then test FF.

提出問題者

Yes. Firefox functions as expected when I remove the 'local-settings.js' and 'mozilla.cfg' files from there respective locations. I dont know what is wrong with the content of these files. I created these referring to instructions provided at [http://kb.mozillazine.org/Locking_pre.../Locking_preferences] .

Please help. I am at my wits end with this.

Yes. Firefox functions as expected when I remove the ''''local-settings.js'''' and ''''mozilla.cfg'''' files from there respective locations. I dont know what is wrong with the content of these files. I created these referring to instructions provided at [[http://kb.mozillazine.org/Locking_preferences|http://kb.mozillazine.org/Locking_preferences]] . Please help. I am at my wits end with this.
FredMcD
  • Top 10 Contributor
4314 個解決方法 60573 個答案

What ou want to do is above my knowledge. I've called the big guys to help you. Good luck.

What ou want to do is above my knowledge. I've called the big guys to help you. Good luck.
cor-el
  • Top 10 Contributor
  • Moderator
17694 個解決方法 160088 個答案

選擇的解決方法

There are no quotes around the browser.startup.homepage value.

//
pref("browser.startup.homepage", "http://intranet/");
pref("browser.shell.checkDefaultBrowser", false);
pref("app.update.auto", false);
pref("app.update.enabled", false);
pref("app.update.service.enabled", false);
pref("browser.cache.disk.smart_size.use_old_max", false);
pref("browser.search.update", false);
pref("datareporting.healthreport.uploadEnabled", false);
pref("signon.rememberSignons", false);
There are no quotes around the browser.startup.homepage value. <pre><nowiki> // pref("browser.startup.homepage", "http://intranet/"); pref("browser.shell.checkDefaultBrowser", false); pref("app.update.auto", false); pref("app.update.enabled", false); pref("app.update.service.enabled", false); pref("browser.cache.disk.smart_size.use_old_max", false); pref("browser.search.update", false); pref("datareporting.healthreport.uploadEnabled", false); pref("signon.rememberSignons", false);</nowiki></pre>

提出問題者

Thanks a ton. That resolved the issue.

Thanks a ton. That resolved the issue.