X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox crashes

已張貼

Every time I attempt to launch Google Maps, FF crashes immediately.

Mac OS 10.9.5, FF 39.03

Not sure where to put this info (following your directions) > last crash report:

https://crash-stats.mozilla.com/report/index/ac0190ab-e541-4d45-99ff-d5d972150808

Every time I attempt to launch Google Maps, FF crashes immediately. Mac OS 10.9.5, FF 39.03 Not sure where to put this info (following your directions) > last crash report: https://crash-stats.mozilla.com/report/index/ac0190ab-e541-4d45-99ff-d5d972150808

被選擇的解決方法

Well, oddly enough I was going to quote yesterday's instructions on how to disable WebGL, but I can no longer find them here. Did make a screenshot though, so that will be attached here.

1. There is no graphics driver update and I am up to date with this OS version - Mac OS does not allow for or rarely does include such updates.

2. Hardware acceleration is permanently disabled.

3. A fresh install per above instructions did not solve the problem.

4. However!!! Disabling the WebGL did - I can now launch Google Maps without FF crashing.

Which brings up a new question:

Any downside on any site having that disabled?

從原來的回覆中察看解決方案 2

額外的系統細節

已安裝的外掛程式

  • Provides information about the default web browser
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 18.0 r0
  • WebEx64 General Plugin Container Version 205
  • iPhoto6

應用程式

  • Firefox 39.0.3
  • 使用者代理:Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:39.0) Gecko/20100101 Firefox/39.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/39.0.3/Darwin/en-US/

擴充套件

  • 1-Click YouTube Video Downloader 2.4.0.1-signed (YoutubeDownloader@PeterOlayev.com)
  • Adblock Plus 2.6.10 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • WOT 20150708 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7})

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription:
  • adapterDeviceID: 0x11a3
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce GTX 680MX OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
Andrew
  • Moderator
321 個解決方法 4062 個答案

Hello,

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove your Firefox program files and then reinstall Firefox. This process does not remove your Firefox profile data (such as bookmarks and passwords), since that information is stored in a different location.

To do a clean reinstall of Firefox, please follow these steps: Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from mozilla.org (or choose the download for your operating system and language from this page) and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (or open the Firefox menu New Fx Menu and click the close button Close 29 ).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING: Do not use a third party uninstaller as part of this process. Doing so could permanently delete your Firefox profile data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be easily recovered unless they have been backed up to an external device! See Back up and restore information in Firefox profiles.

Please report back to say if this helped you!

Thank you.

Hello<!-- XXX you may wish to edit this greeting, and other parts of the response so that it is personalised to the question asked.-->, Certain Firefox problems can be solved by performing a ''Clean reinstall''. This means you remove your Firefox program files and then reinstall Firefox. This process does not remove your [[Profiles - Where Firefox stores your bookmarks, passwords and other user data| Firefox profile]] data (such as bookmarks and passwords), since that information is stored in a different location. To do a clean reinstall of Firefox, please follow these steps: '''Note:''' You might want to print these steps or view them in another browser. #Download the latest Desktop version of Firefox from [https://www.mozilla.org mozilla.org] (or choose the download for your operating system and language from [https://www.mozilla.org/firefox/all/ this page]) and save the setup file to your computer. #After the download finishes, close all Firefox windows (or open the Firefox menu [[Image:New Fx Menu]] and click the close button [[Image:Close 29]]). #Delete the Firefox installation folder, which is located in one of these locations, by default: #*'''Windows:''' #**C:\Program Files\Mozilla Firefox #**C:\Program Files (x86)\Mozilla Firefox #*'''Mac:''' Delete Firefox from the Applications folder. #*'''Linux:''' If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see [[Installing Firefox on Linux]]. If you downloaded and installed the binary package from the [http://www.mozilla.org/firefox#desktop Firefox download page], simply remove the folder ''firefox'' in your home directory. #Now, go ahead and reinstall Firefox: ##Double-click the downloaded installation file and go through the steps of the installation wizard. ##Once the wizard is finished, choose to directly open Firefox after clicking the Finish button. More information about reinstalling Firefox can be found [[Troubleshoot and diagnose Firefox problems#w_5-reinstall-firefox|here]]. <b>WARNING:</b> Do not use a third party uninstaller as part of this process. Doing so could permanently delete your [[Profiles|Firefox profile]] data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. <u>These cannot be easily recovered unless they have been backed up to an external device!</u> See [[Back up and restore information in Firefox profiles]]. <!-- Starting in Firefox 31, the Firefox uninstaller no longer lets you remove user profile data.Ref: Bug 432017 and https://support.mozilla.org/kb/uninstall-firefox-from-your-computer/discuss/5279 [Fx31] Windows uninstaller will no longer offer the option to remove personal data --> Please report back to say if this helped you! Thank you.
cor-el
  • Top 10 Contributor
  • Moderator
17567 個解決方法 158879 個答案

Try to update to the current Firefox 40.0.2 release. You can find the full version of the current current Firefox release (40.0.2) in all languages and all operating systems here:


You can try to disable hardware acceleration in Firefox.

  • Firefox > Preferences > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Try to update to the current Firefox 40.0.2 release. You can find the full version of the current current Firefox release (40.0.2) in all languages and all operating systems here: *https://www.mozilla.org/en-US/firefox/all/ ---- You can try to disable hardware acceleration in Firefox. *Firefox > Preferences > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

有幫助的回覆

Thanks to both of you. I will not have access to my Mac OS 10.9.5 iMac until tomorrow (using my 10.10.5 MBP without a problem currently) and will try a reinstall of FF.

I do not have hardware acceleration enabled (disabled during the troubleshooting of my last problem). Not sure about WebGL, but will check that tomorrow as well.

As mentioned, I can open Google Maps on 10.10.5 (but not on 10.9.5).

Thanks to both of you. I will not have access to my Mac OS 10.9.5 iMac until tomorrow (using my 10.10.5 MBP without a problem currently) and will try a reinstall of FF. I do not have hardware acceleration enabled (disabled during the troubleshooting of my last problem). Not sure about WebGL, but will check that tomorrow as well. As mentioned, I can open Google Maps on 10.10.5 (but not on 10.9.5).

選擇的解決方法

Well, oddly enough I was going to quote yesterday's instructions on how to disable WebGL, but I can no longer find them here. Did make a screenshot though, so that will be attached here.

1. There is no graphics driver update and I am up to date with this OS version - Mac OS does not allow for or rarely does include such updates.

2. Hardware acceleration is permanently disabled.

3. A fresh install per above instructions did not solve the problem.

4. However!!! Disabling the WebGL did - I can now launch Google Maps without FF crashing.

Which brings up a new question:

Any downside on any site having that disabled?

Well, oddly enough I was going to quote yesterday's instructions on how to disable WebGL, but I can no longer find them here. Did make a screenshot though, so that will be attached here. 1. There is no graphics driver update and I am up to date with this OS version - Mac OS does not allow for or rarely does include such updates. 2. Hardware acceleration is permanently disabled. 3. A fresh install per above instructions did not solve the problem. 4. However!!! Disabling the WebGL did - I can now launch Google Maps without FF crashing. Which brings up a new question: Any downside on any site having that disabled?
philipp
  • Top 25 Contributor
  • Moderator
5320 個解決方法 23500 個答案

you could try google maps lite mode as well: https://support.google.com/maps/answer/3031966

you could try google maps lite mode as well: https://support.google.com/maps/answer/3031966

提出問題者

Thanks for the suggestion - for now, I will leave well enough alone as disabling WebGL did the trick.

Can't mark any answer as solved since the one that did no longer includes the WebGL suggestions, so in order to close this thread, I'll mark my own.

Thanks for the suggestion - for now, I will leave well enough alone as disabling WebGL did the trick. Can't mark any answer as solved since the one that did no longer includes the WebGL suggestions, so in order to close this thread, I'll mark my own.