搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Settings for allowed add-ons downloads site list not saved.

  • 8 回覆
  • 2 有這個問題
  • 2902 次檢視
  • 最近回覆由 FredMcD

more options

Under about:preferences#security, you can choose what sites can download add-ons without you needing to allow it thru the Exceptions button by Warn Me When Sites Try To Install Add-ons

The defaults are; marketplace.firefox.com and addons.mozilla.org

But every time Firefox is restarted, this list is deleted. Even resetting Firefox does not fix this. I deleted the prefs.js file, but no joy. I checked, and found this enter in the file, but it will not display when Firefox is started.

dom.mozApps.signed_apps_installable_from;https://marketplace.firefox.com

I even downgraded from Firefox 34.0.5 to 33.1.1 but the issue is still there.

As far as I can tell, this is the only setting that is having trouble.

由 FredMcD 於 修改

被選擇的解決方法

The whitelist prefs shouldn't have the protocol, but only the name as you can see if you would reset the prefs. The http exception that shows in the one of the screenshots is the result of the presence of the protocol.

Try to rename (or delete) the permissions.sqlite file in the Firefox profile folder. You can also check the file with the SQLite Manager extension.

從原來的回覆中察看解決方案 👍 0

所有回覆 (8)

more options

In case you are using "Clear history when Firefox closes" or otherwise clear history:

  • do not clear the Site Preferences

Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

Note that you can reset these prefs on the about:config page to restore the default software exceptions for installing extensions and the market place xpinstall.whitelist.add (addons.mozilla.org) xpinstall.whitelist.add.180 (marketplace.firefox.com)

If these prefs do not exist or are an empty string when you open the exception window then the corresponding default entry is recreated automatically. Tools > Options > Security : "Warn me when sites try to install add-ons": Exceptions

You can create xpinstall.whitelist.add.* and xpinstall.blacklist.add.* prefs to automatically create exceptions for specific domains. You can specify multiple hosts by separating them with a comma (,). Also works with a user.js file. You need to open the exception window to make Firefox process the pref(s) and set the pref(s) to an empty string.

  • Tools > Options > Security : "Warn me when sites try to install add-ons": Exceptions
  • user_pref("xpinstall.whitelist.add.abc", "abc.com,<another domain>");
  • user_pref("xpinstall.blacklist.add.abc", "abc.com,<another domain>");
more options

Clear history when Firefox closes The setting is on, but only the Fire IE is selected

recreated automatically. "Warn me when sites try to install add-ons": Exceptions I have repeatedly entered the information, but it does not stay saved.

reset these prefs on the about:config page I have followed your instructions;

more options

I restarted Firefox, and this is what I found; Note: Settings Guard was disabled.

I will try the user.js file.suggestion next.

more options

I tried the user.js file.suggestion. Here are the results; 1 Open User.js 2 Added the data, saved file. Reopen to confirm save 3 Open Firefox 4 Entered data in "Warn me when sites" exceptions

由 FredMcD 於 修改

more options

4 Closed, then reopened FF. All these settings: GONE  :-/

more options

選擇的解決方法

The whitelist prefs shouldn't have the protocol, but only the name as you can see if you would reset the prefs. The http exception that shows in the one of the screenshots is the result of the presence of the protocol.

Try to rename (or delete) the permissions.sqlite file in the Firefox profile folder. You can also check the file with the SQLite Manager extension.

more options

Thanks, Cor-el. I looked at the SQLite Manager extension, but was not sure I could understand it. I may look at it later.

I looked at the permissions.sqlite file using a viewer. It looked like a cross of my history and bookmarks. I renamed the file. I then added Mozilla.org to the exception list. I closed and reopened FF several times, and so far the exception is still there. Here is hoping.

Many thanks for your help.

more options

So far, so good. I have now re-upgraded to v34.0.5, and everything is still good. Once again, many thanks.