搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Recently no matter what I do, Firefox will not allow me to use Adobe Reader instead of it's own

  • 8 回覆
  • 12 有這個問題
  • 11 次檢視
  • 最近回覆由 charley000

more options

I used to be able to display pdf documents using Adobe Reader instead of Firefox's built in. I have tried everything that you suggest and that Adobe suggest. I have uninstalled and reinstalled Firefox. I have uninstalled and reinstalled Adobe Reader (11.0.09). I have gone to the options in Mozilla but when I try to change the Portable Document settings, I don't get the option for "Use Adobe Acrobat (in Firefox)". I do get the for Adobe Forms, but not for PDF documents. If I change it to use Adobe Reader, it downloads and then opens reader which is not I want. I want to use the plugin which is installed (I go to Add-ons and it is installed and "always activate").

Help? This only started happening in the last month or so. I am running latest released Firefox (33.0.2), Windows 7 (up to date with all updates, etc.).

被選擇的解決方法

I did a Reset Firefox. Then reactivated the plugins. Now it works with the Adobe Acrobat plugin even though Firefox thinks (at least according the Options->Applications) that it is using the Foxit plugin. It doesn't give me the option to even select the Adobe plugin. But that is what loads when I access a PDF!

As long as it stays working, I won't worry about it.

Before I started posting here, I had already tried uninstalling and reinstalling Firefox, uninstalling and reinstalling Adobe Reader, deleting the pluginreg.dat file, etc., and everything else I could find on the Mozilla site, the Adobe site and the rest of the web.

Thanks everyone for your help.

從原來的回覆中察看解決方案 👍 0

所有回覆 (8)

more options

3 ways I would try:

Look under Preferences in Adobe Reader, and select to make it the default program

Right-click on a pdf file / Open with / Choose default program / More options (if necessary) / scroll down to Look for another App on this PC / navigate to Adobe Reader

Win 8.1 / Control Panel / Default Programs / Associate a file type or protocol with a program / scroll down to pdf - highlight it / in the top right, click "Change Program" / navigate to Adobe Reader

I recommend switching to the Free Foxit Reader, it's smaller, faster, more tools. I just got the paid version of Phantom Business, it lets you rotate and save pages, insert pages, and OCR pdfs (so then I can use Natural Reader). It's excellent.

more options

That doesn't solve the problem. I have all those defaults. But in Firefox, it won't let me select for "Portable Document Format" to "Use Adobe Acrobat (in Firefox)" which it used to let me and which is what the Mozilla Firefox help stuff says to do. I can select Adobe Reader but then it downloads it and opens it in a separate reader window rather than using the plugin. If I select to let Firefox "Preview in Firefox", then the Firefox built-in PDF reader will display it. I have added an add-on "pdfViewerSwitcher" which then lets me display in the Adobe Reader plug-in but only after first displaying it in the Firefox preview. So that verifies that the Adobe Reader plug-in works. But I can't set it to always use the Adobe Reader plug-in.

I have some reasons for wanting to use the Adobe Reader plug-in. I use Nuance Power PDF Pro for editing and doing other things with pdfs.

This all used to work and stopped working at some point in the last couple months. And if you search the web, you will find I am not the only one with this complaint.

I don't know whether it is Adobe's fault or Mozilla's fault but at least one of them is broken. And I think it is Firefox since it won't even let me select it but does let me select it for Adobe Forms.

more options

How about this: Options / Applications tab / PDF - select from one of the options there

Or, you might try a different program, and see how it behaves - I recommend the Free Foxit Reader - verify that it says to open in a browser, when installing.

Why is it necessary for it to open in the browser? I think I chose against this, because I like to have all the controls available when viewing a pdf.

more options

Well I got it to work. I had to go in and manually delete the Nuance plugin (which you have to do in Firefox my renaming the .dll file for the plugin and then when it restarts it deletes the plugin). Now it lets me select it and it works. But each time I exit and restart Firefox, it resets it to "save file". I can't seem to get it to stick. Any ideas?

I get all the controls. And if I don't, then I save the file and edit it. But normally all I want to do it read it and save it. I played with Foxit a while ago but found some incompatibilities. It may be work well now. I might switch to it and see.

more options

I downloaded and installed the Foxit and set its plugin as the default. But just like with Adobe Reader, every time I exit Firefox and restart it, Firefox has reset the defaults to "save file" from use the plugin.

Any ideas?

more options

What do you mean? Do you want to open PDF files in Adobe Reader every time a PDF is accessed in Firefox, instead of the built in PDF reader? Do all PDF files opened on your computer open in Firefox, but you want them to open in Adobe Reader? I have no idea what you're saying but I'll try my best to comprehend it. :P

If you want to use Adobe Reader to view PDFs in Firefox instead of the normal PDF viewer...

  • Press ALT on your keyboard.
  • Click Tools>Options.
  • Go to "Applications".
  • Set the action of everything called "Adobe Acrobat X" (X=anything after it) to open with Adobe Reader. (although Adobe Acrobat or whatever you're using is probably more convenient)

To open all PDF's on your computer with Adobe Reader...

  • Right click a random PDF file on your computer.
  • Click Open With and select a program.
  • Choose Adobe Reader from the list and make sure "Use this program as default" is ticked, and click OK.
more options

Oh, I see what you mean. How Firefox sets the options back to "Save File" is strange. Your Firefox install must be corrupted because this appears to be an isolated incident. What I recommend is uninstalling Firefox from Add/Remove Programs from the Control Panel of Windows (depending on what version of Windows you have), using the reset settings option in the uninstaller when uninstalling (THIS WILL RESET YOUR BOOKMARKS, OPTIONS, ADD-ONS, ETC), then downloading Firefox from Firefox.com and reinstalling it. If your installation was corrupted, I'm sure that will resolve the issue. But don't blame it on me if it doesn't. Are you clicking "OK" on the Options box after setting the option to open with Foxit Reader? (I know this is a stupid question, but I'm just wondering)

由 You 於 修改

more options

選擇的解決方法

I did a Reset Firefox. Then reactivated the plugins. Now it works with the Adobe Acrobat plugin even though Firefox thinks (at least according the Options->Applications) that it is using the Foxit plugin. It doesn't give me the option to even select the Adobe plugin. But that is what loads when I access a PDF!

As long as it stays working, I won't worry about it.

Before I started posting here, I had already tried uninstalling and reinstalling Firefox, uninstalling and reinstalling Adobe Reader, deleting the pluginreg.dat file, etc., and everything else I could find on the Mozilla site, the Adobe site and the rest of the web.

Thanks everyone for your help.