搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Help needed for a pensioner who doasn't understand

  • 2 个回答
  • 0 人有此问题
  • 11 次查看
  • 最后回复者为 Terry

more options

Can someone please help solve this problem. Why am i getting this message below The site concerned is FamilySearch which i have bee using for some years. I am a pensioner who doesn't know much about computers.

Attention: This site does not support the current version of your web browser. To get the best possible experience using our website we recommend that you upgrade to a newer version or install another browser

Can someone please help solve this problem. Why am i getting this message below The site concerned is FamilySearch which i have bee using for some years. I am a pensioner who doesn't know much about computers. Attention: This site does not support the current version of your web browser. To get the best possible experience using our website we recommend that you upgrade to a newer version or install another browser

所有回复 (2)

more options

Hi, I will assume you have been using Firefox as your internet browser. Visit this web: https://www.mozilla.org/en-US/firefox/new/ and click on the blue button called Download Firefox when the download has finished, double click on the file Firefox Installer.exe Install the program (just press Next every time it appears) and next time you open the browser your site will be able to function without problems.

more options

There may be a problem with your installation or with the website. Can you provide a link to the website?