搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Change Firefox background when navigating pages

  • 5 个回答
  • 1 人有此问题
  • 247 次查看
  • 最后回复者为 epomatti

more options

Hi

I have dark mode installed for almost every site that I use.

When I navigate from one page to the other the background of Firefox is set to the white color, and switching from black to white, and immediately back to black is aggressive to the eyes.

How can I change the background color of Firefox before the page has loaded?

Thanks.

被采纳的解决方案

Could I suggest asking about the problem on the Github site? Giving specific page examples for comparison might help.

https://github.com/overdodactyl/ShadowFox/issues

在上下文中阅读这个答案 👍 0

所有回复 (5)

more options

Hi epomatti, the empty frame that the web content goes into normally has a white background. Traditionally, you would create a userChrome.css file to apply a custom background color. It sounds as though Firefox's Dark theme doesn't do that yet, and it still needs to be done the old-fashioned way.

There is a project called ShadowFox that includes this and numerous other style rules to dark theme as much of Firefox as possible: https://overdodactyl.github.io/ShadowFox/

If you don't want to use all of that, just the one change, I could figure out which rule it is, or you could check the following subreddit where the question comes up from time to time: https://www.reddit.com/r/FirefoxCSS/

more options

Hi Jscher

I installed it but there still is a small gap where (I assume) the page CSS is not loaded yet, and the background of the page is white for a short second.

Can that be changed as well?

more options

选择的解决方案

Could I suggest asking about the problem on the Github site? Giving specific page examples for comparison might help.

https://github.com/overdodactyl/ShadowFox/issues

more options

Try to add code to the userContent.css file.


/* about:blank */
@-moz-document url(about:blank){html,body{background-color:#ddd!important}}
more options

cor-el said

Try to add code to the userContent.css file.
/* about:blank */
@-moz-document url(about:blank){html,body{background-color:#ddd!important}}

It didn't work.