搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Firefox 67 regression in proxy settings

  • 3 个回答
  • 1 人有此问题
  • 45 次查看
  • 最后回复者为 n5mx

more options

I have a proxy.pac file I've been using with Firefox for over a year. The proxy.pac is available at https://gist.github.com/magic-lantern/83263e3c1fd251afec8a38d715eefefa I've also attached a screenshot of my Network/Connection Settings configuration.

I frequently use SSH to connect to a remote host, and use the -D option to provide a dynamic proxy to that SSH host. Once I open the dynamic SOCKS5 proxy, I use Firefox to connect to services running on the remote SSH host. For example, http://localhost:8888 which goes through the proxy to the remote host.

As of Firefox 66.0.5 this has always worked great. Just yesterday I updated to 67 and now proxying of localhost/127.0.0.1 no longer works.

Not sure if this is a bug or a feature.

Is there a new way in FF67 to make this work?

I have a proxy.pac file I've been using with Firefox for over a year. The proxy.pac is available at https://gist.github.com/magic-lantern/83263e3c1fd251afec8a38d715eefefa I've also attached a screenshot of my Network/Connection Settings configuration. I frequently use SSH to connect to a remote host, and use the -D option to provide a dynamic proxy to that SSH host. Once I open the dynamic SOCKS5 proxy, I use Firefox to connect to services running on the remote SSH host. For example, http://localhost:8888 which goes through the proxy to the remote host. As of Firefox 66.0.5 this has always worked great. Just yesterday I updated to 67 and now proxying of localhost/127.0.0.1 no longer works. Not sure if this is a bug or a feature. Is there a new way in FF67 to make this work?
已附加屏幕截图

被采纳的解决方案

Try to set this pref to true on the about:config page.

  • network.proxy.allow_hijacking_localhost = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


  • Bug 1535581 - proxy settings for localhost not obeyed unless network.proxy.allow_hijacking_localhost is set

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

定位到答案原位置 👍 1

所有回复 (3)

more options

选择的解决方案

Try to set this pref to true on the about:config page.

  • network.proxy.allow_hijacking_localhost = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


  • Bug 1535581 - proxy settings for localhost not obeyed unless network.proxy.allow_hijacking_localhost is set

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

more options

Thanks for pointing out that bug that referenced the exact problem I was having. Seems like a change like that should have been in the release notes - or just more prominent in the notes as I didn't see that change.

more options