搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

I cannot enable Multiprocess Firefox

  • 14 个回答
  • 1 人有此问题
  • 79 次查看
  • 最后回复者为 grassyBanana

more options

I can't use Responsive Design Mode in the latest Firefox Developer Edition. I get the error "responsive design mode is only available for remote browser tabs, such as those used for web content in multi-process firefox". When I try to enable it in about:config, it show the status as locked and it is set to disabled. I've tried installing Firefox again and restarting in safe mode in case it was a extension. No change.

As you can image, this really impacts my ability to develop websites. I have the latest standard edition of Firefox which doesn't have this issue. I also am not sharing profiles between the two. I really like the CSS tools in Firefox, but I may need to go back to chrome if I can't use responsive mode at all in FF DE.

I can't use Responsive Design Mode in the latest Firefox Developer Edition. I get the error "responsive design mode is only available for remote browser tabs, such as those used for web content in multi-process firefox". When I try to enable it in about:config, it show the status as locked and it is set to disabled. I've tried installing Firefox again and restarting in safe mode in case it was a extension. No change. As you can image, this really impacts my ability to develop websites. I have the latest standard edition of Firefox which doesn't have this issue. I also am not sharing profiles between the two. I really like the CSS tools in Firefox, but I may need to go back to chrome if I can't use responsive mode at all in FF DE.
已附加屏幕截图

由Kevin-EHSD于修改

被采纳的解决方案

jscher2000 said

That's very unusual. Is your Firefox managed by an IT department?

No it is not. My regular Firefox is as it should be (no locked browser.tabs.remote.autostart and browser.tabs.remote.autostart.2, RDM works).

I do have a autoconfig.js and a channel-prefs.js in the /c/Program Files/Firefox Developer Edition/defaults/pref folder. The contents of the autoconfig are below:

// Any comment. You must start the file with a comment! pref("general.config.filename", "mozilla.cfg"); pref("general.config.obscure_value", 0);

There is no autoconfig for The standard Firefox.

After commenting out the two lines from the autoconfig and relaunching Firefox Dev Edition, I now have multi-process enabled and the second config key, browser.tabs.remote.2 is now gone and the original is unlocked. Weird. I certainly didn't add it. IT switched antivirus about a month ago, perhaps it did it, but the non dev edition Firefox wasn't touched.

在上下文中阅读这个答案 👍 1

所有回复 (14)

more options

Hi Kevin-EHSD, it takes some effort to disable multiprocess in Firefox, so it's possible the error message is mistaken. Could you check on the Troubleshooting Information page. Either:

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, there should be a row for "Multiprocess Windows" which normally shows the same number in the numerator and denominator. For example:

7/7 (Enabled by default)

What does yours say?

more options

Too many typos!

由jscher2000 - Support Volunteer于修改

more options

(Disregard previous reply with copy/paste errors.)

I forgot to ask you what preference you were viewing here:

Kevin-EHSD said

When I try to enable it in about:config, it show the status as locked and it is set to disabled.

A preference lock usually is set using an Autoconfig file in Firefox's program folder. There's a .js file in one of these folders that points to the configuration file:

  • C:\Program Files\Mozilla Firefox\defaults\pref\
  • C:\Program Files (x86)\Mozilla Firefox\defaults\pref\
  • Check where Developer Edition launches from, then find the defaults\pref\ path in there

Firefox normally places a file here named channel-prefs.js so any other file could be considered suspect.

Ref. Customizing Firefox Using AutoConfig

more options

Hello,

I attached screenshots of both the error and the specific key I was looking at in about:config. I have also attached a screenshot of the troubleshooting window. I also attached the troubleshooting info in the initial post.

In case you cannot view those I have attached the screenshots again. The value for multi-process windows is: 0/3 (Disabled). The about:config preference I was looking at was browser.tabs.remote.autostart and browser.tabs.remote.autostart.2 which I was pointed to from searching the error message in DevTools.

more options

That's very unusual. Is your Firefox managed by an IT department?

Meanwhile, please do check for an Autoconfig file.

more options

选择的解决方案

jscher2000 said

That's very unusual. Is your Firefox managed by an IT department?

No it is not. My regular Firefox is as it should be (no locked browser.tabs.remote.autostart and browser.tabs.remote.autostart.2, RDM works).

I do have a autoconfig.js and a channel-prefs.js in the /c/Program Files/Firefox Developer Edition/defaults/pref folder. The contents of the autoconfig are below:

// Any comment. You must start the file with a comment! pref("general.config.filename", "mozilla.cfg"); pref("general.config.obscure_value", 0);

There is no autoconfig for The standard Firefox.

After commenting out the two lines from the autoconfig and relaunching Firefox Dev Edition, I now have multi-process enabled and the second config key, browser.tabs.remote.2 is now gone and the original is unlocked. Weird. I certainly didn't add it. IT switched antivirus about a month ago, perhaps it did it, but the non dev edition Firefox wasn't touched.

由Kevin-EHSD于修改

more options

I'm glad you were able to track that down. It may remain a mystery how that file was deposited there.

more options

What is the content of the mozilla.cfg file in the main Firefox program folder that is referenced in the autoconfig.js file ?

more options

cor-el said

What is the content of the mozilla.cfg file in the main Firefox program folder that is referenced in the autoconfig.js file ?

I don't know. I can't locate it on my HD.

more options

If there is an autoconfig.js file then this file would only have worked properly with a mozilla.cfg file and this file is located in the same folder as autoconfig.js, only this file would be in the main Firefox program folder and not in a subfolder. This mozilla.cfg file would contain the actual code to set or lock a pref (lockPref();).

more options

I see it now. Cortana wasn't finding it but a folder search did. It contained the following which looks to be disabling the multi-process as well as accessibility:

lockPref("security.enterprise_roots.enabled", true); lockPref("browser.tabs.remote.autostart",false); lockPref("browser.tabs.remote.autostart.2",false); lockPref("accessibility.force_disabled",0);

Again, this was only found in the Developer Edition and not the non dev edition of Firefox I have installed.

more options

You can remove this mozilla.cfg file and the autoconfig.js file. browser.tabs.remote.autostart is the only pref current Firefox releases use to control multi-process. Only if you need security.enterprise_roots.enabled for importing certificates from the Windows certificate store then you can lave both files and remove the other lines (both files need to start with a comment line: //). You can consider to use pref(); if you want to be able to modify these prefs on the about:config page.

//
pref("security.enterprise_roots.enabled", true); 
pref("accessibility.force_disabled",0);
more options

I had deleted the autoconfig yesterday but it was re-added today after I logged in.

I removed them again. My employer doesn't install or manage Firefox, they only officially support IE11 and also include Chrome in the standard image. I'm not sure why this is only being added to the FF Dev edition and not the standard edition. I am going to ask my boss if he knows.

more options

I have this same problem. None of these solutions worked for me.

I had to create 2 new boolean entries in `about:config`

  • `browser.tabs.remote.force-enable` to false
  • `browser.tabs.remote.autostart.2` to true

That fixed it for me