搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

HAR file generation fails in Firefox 59.0.2

  • 1 个回答
  • 1 人有此问题
  • 5 次查看
  • 最后回复者为 czdiaz

more options

Hello: I am developing a test with selenium 3.11.0 + geckodriver 0.19.1 + firefox 59.0.2 to get the HAR file when loading a page. I got always an error, and no HAR file when using the latest version of Firefox. I could not find any error in the test configuration, and the logs showed always an error in the javascript har-builder.js, which is internal to Firefox. I have not modified the standard configuration of Firefox, or using any add-ons. The idea is to use an standard configuration. I tested in my Mac High Sierra and in a Ubuntu 16.04. Same results I switched the version to Firefox 57.0, and the tests are now always successful in both the Mac and in the Ubuntu, and the HAR file is generated every time. I attach images of the geckodriver logs with every case...Uploading of images fails.. :-(  !!!

I did not find any related issue in the support page.

Regards, Claudio

Hello: I am developing a test with selenium 3.11.0 + geckodriver 0.19.1 + firefox 59.0.2 to get the HAR file when loading a page. I got always an error, and no HAR file when using the latest version of Firefox. I could not find any error in the test configuration, and the logs showed always an error in the javascript har-builder.js, which is internal to Firefox. I have not modified the standard configuration of Firefox, or using any add-ons. The idea is to use an standard configuration. I tested in my Mac High Sierra and in a Ubuntu 16.04. Same results I switched the version to Firefox 57.0, and the tests are now always successful in both the Mac and in the Ubuntu, and the HAR file is generated every time. I attach images of the geckodriver logs with every case...Uploading of images fails.. :-( !!! I did not find any related issue in the support page. Regards, Claudio

所有回复 (1)

more options

I could not upload the images with the error, so I copy the error message from the gecko driver log, as it may help:

console.error:

 Message: TypeError: requestPostData is undefined
 Stack:
   buildPostData@resource://devtools/shared/base-loader.js -> resource://devtools/client/netmonitor/src/har/har-builder.js:268:9

buildRequest@resource://devtools/shared/base-loader.js -> resource://devtools/client/netmonitor/src/har/har-builder.js:186:30 buildEntry@resource://devtools/shared/base-loader.js -> resource://devtools/client/netmonitor/src/har/har-builder.js:128:27 build@resource://devtools/shared/base-loader.js -> resource://devtools/client/netmonitor/src/har/har-builder.js:62:30 buildHarData@resource://devtools/shared/base-loader.js -> resource://devtools/client/netmonitor/src/har/har-exporter.js:175:12 fetchHarData@resource://devtools/shared/base-loader.js -> resource://devtools/client/netmonitor/src/har/har-exporter.js:140:12 executeExport@resource://devtools/shared/base-loader.js -> resource://devtools/client/netmonitor/src/har/har-automation.js:188:12 autoExport@resource://devtools/shared/base-loader.js -> resource://devtools/client/netmonitor/src/har/har-automation.js:135:12 pageLoadDone/<@resource://devtools/shared/base-loader.js -> resource://devtools/client/netmonitor/src/har/har-automation.js:116:16