搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Fonts on many websites show up as a question mark in a box.

more options

running Firefox 57.0.1 on an macOS Sierra 10.12.6. Many websites I can't see the fonts, it shows up as question marks within a box. I have the box checked for allowing websites to choose own fonts. Everything works in Safari, only Firefox has this issue. Fonts in system folder have not been deleted or moved. If I can't get this worked out I guess I'll just continue to use Safari.

running Firefox 57.0.1 on an macOS Sierra 10.12.6. Many websites I can't see the fonts, it shows up as question marks within a box. I have the box checked for allowing websites to choose own fonts. Everything works in Safari, only Firefox has this issue. Fonts in system folder have not been deleted or moved. If I can't get this worked out I guess I'll just continue to use Safari.

被采纳的解决方案

When did this problem start for you?

On Mac, Firefox 56 ratcheted up the security sandbox, limiting which files pages can use on your system. This apparently prevents Firefox from using font files in a "suitcase" or "Adobe Type 1" format. The developers are aware of this and some fixes were made in Firefox 57, but they might have missed some font types or unexpected font file locations.

To see whether this is the problem, and as a temporary workaround, you can reduce the sandbox security level back to what it was in Firefox 52-55 as follows:

(1) In a new tab, type or paste about:config in the address bar and press Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste sand and pause while the list is filtered

(3) Double-click the security.sandbox.content.level preference and change the value from 3 to 1 and click OK

That change won't take effect until the next time you quit and restart Firefox.

Does that let Firefox show website fonts normally?

定位到答案原位置 👍 4

所有回复 (4)

more options

选择的解决方案

When did this problem start for you?

On Mac, Firefox 56 ratcheted up the security sandbox, limiting which files pages can use on your system. This apparently prevents Firefox from using font files in a "suitcase" or "Adobe Type 1" format. The developers are aware of this and some fixes were made in Firefox 57, but they might have missed some font types or unexpected font file locations.

To see whether this is the problem, and as a temporary workaround, you can reduce the sandbox security level back to what it was in Firefox 52-55 as follows:

(1) In a new tab, type or paste about:config in the address bar and press Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste sand and pause while the list is filtered

(3) Double-click the security.sandbox.content.level preference and change the value from 3 to 1 and click OK

That change won't take effect until the next time you quit and restart Firefox.

Does that let Firefox show website fonts normally?

more options

This worked! Thank you so much. Will this be fixed with the next update?

more options

Hi nazkey, I'm not sure. Apparently fonts are drawn from various unexpected locations and those need to be accounted for. Hopefully someone else can update us on what will be added next or where to find your font locations to provide information to solve it.

more options

In another thread, user SurfinSpots pointed out that Mozilla has provided steps to capture more information on why the fonts are not loading. However, I admit I don't totally understand the instructions because I have very little Mac experience.

https://wiki.mozilla.org/Security/Sandbox#Debugging_Features