搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Wrong sans serif font displaying on pages

  • 5 个回答
  • 6 人有此问题
  • 75 次查看
  • 最后回复者为 QC

more options

I have Times New Roman set as my default serif font and Arial set as my default sans serif font, but today the default sans serif switched to another random font on my system for no apparent reason. I switched it back, but it's still displaying that way. When I uncheck the "Allow pages to choose their own fonts" box it displays as another random font on my system.

所有回复 (5)

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

It is possible that there is a problem with some of the font on your computer.

You can do a font test to see if you can identify font(s) that aren't working properly.

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"

Make sure to restore the default setting and allow pages to choose their own fonts when you are done with testing to avoid issues with downloaded icon fonts.

more options

FredMcD said

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

No, it isn't there now. So does that mean the problem is one of my add-ons?

more options

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.


You can right-click and select "Inspect Element" to open the Inspector (Firefox menu button or Tools > Web Developer) with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.

more options

Disabling hardware acceleration fixed it--thanks!