Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Èròjà atẹ̀lélànà yii ni a ti fi pamọ́ fọ́jọ́ pípẹ́. Jọ̀wọ́ béèrè ìbéèrè titun bí o bá nílò ìrànwọ́.

How do I fix Firefox on Linux so it doesn't show unreadable black text on a black background on error pages?

  • 1 èsì
  • 1 ní ìṣòro yìí
  • 173 views
  • Èsì tí ó kẹ́hìn lọ́wọ́ Nindalf

more options

I've tried changing my GTK theme, and starting with a chosen GTK theme that doesn't have black background. I've tried setting colors in Preferences. I've tried disabling my all-ons. I've tried doing each of these things, shutting down Firefox, and restarting it. I'm on Ubuntu 16.04.

Where is it getting the background color setting and how do I change it? I know that it uses a hard-coded black text color on error pages, that can't be changed, while using a background color setting from somewhere that might also be set to black, and that this bug has gone unfixed for years, but I don't know where it's getting the background color.

I've tried changing my GTK theme, and starting with a chosen GTK theme that doesn't have black background. I've tried setting colors in Preferences. I've tried disabling my all-ons. I've tried doing each of these things, shutting down Firefox, and restarting it. I'm on Ubuntu 16.04. Where is it getting the background color setting and how do I change it? I know that it uses a hard-coded black text color on error pages, that can't be changed, while using a background color setting from somewhere that might also be set to black, and that this bug has gone unfixed for years, but I don't know where it's getting the background color.

Ọ̀nà àbáyọ tí a yàn

I figured out a fix:

File: ~/.mozilla/firefox/[random stuff].default/chrome/userContent.css

Contents: @-moz-document url-prefix("about:") { body{background-color: #B7B7B7 !important;} }

Ka ìdáhùn ni ìṣètò kíkà 👍 0

All Replies (1)

more options

Ọ̀nà àbáyọ Tí a Yàn

I figured out a fix:

File: ~/.mozilla/firefox/[random stuff].default/chrome/userContent.css

Contents: @-moz-document url-prefix("about:") { body{background-color: #B7B7B7 !important;} }