Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

tried to upgrade Firefox, followed all the steps, but on homepage still says I need to upgrade to the latest version.

  • 3 iimpendulo
  • 15 inale ngxaki
  • 1 view
  • Impendulo yokugqibela ngu alpajem

more options

On the start page it said that I needed to update Firefox to the latest version. So I clicked on update and followed all the steps. I clicked to save to desktop, but there is no icon there and when I go to the start page, it keeps saying that I need to update Firefox to the latest version. Also when I try to play my games at Pogo.com, it says I have a pop-up blocker on and the games will not load. How do I get rid of this? Can't find a pop-up blocker in my tool bars. Is it a part of the Mozilla Firefox?

On the start page it said that I needed to update Firefox to the latest version. So I clicked on update and followed all the steps. I clicked to save to desktop, but there is no icon there and when I go to the start page, it keeps saying that I need to update Firefox to the latest version. Also when I try to play my games at Pogo.com, it says I have a pop-up blocker on and the games will not load. How do I get rid of this? Can't find a pop-up blocker in my tool bars. Is it a part of the Mozilla Firefox?

Isisombulu esikhethiweyo

You are updated see your user agent :

Mozilla/5.0 (Windows NT 5.0; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

all you have to do is to set another page as the home page, see why is that in cor-el reply here .

for pop-up blocker : go to TOOLS > OPTIONS > CONTENT PANEL and UNCHECK Block Pop-up Windows [ ] then click OK to save it, exit firefox and restart-it. (By default, Firefox blocks annoying pop-up windows on websites. Unchecking this option will disable pop-up blocking). OR do an exception in exceptions area.

for more info : Options window - Content panel


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

Funda le mpendulo kwimeko leyo 👍 1

All Replies (3)

more options
more options

Isisombululo esiKhethiweyo

You are updated see your user agent :

Mozilla/5.0 (Windows NT 5.0; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

all you have to do is to set another page as the home page, see why is that in cor-el reply here .

for pop-up blocker : go to TOOLS > OPTIONS > CONTENT PANEL and UNCHECK Block Pop-up Windows [ ] then click OK to save it, exit firefox and restart-it. (By default, Firefox blocks annoying pop-up windows on websites. Unchecking this option will disable pop-up blocking). OR do an exception in exceptions area.

for more info : Options window - Content panel


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

Ilungisiwe ngu ideato

more options

Hearty thanks to two people for the solution to my problems.

Oxylatium: I used Method 2 from your answer and it worked. The update was downloaded and finally said that it had finished downloading and am not now getting the message about needing to update.

ideato: I followed your steps for the pop-up blocker and solved my problem.

Again thanks to both of these people. alpajem from Oz