Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Ця тема перенесена в архів. Якщо вам потрібна допомога, запитайте.

Chase.com not loading correctly in Firefox version 24. It works correctly in IE.

  • 5 відповідей
  • 25 мають цю проблему
  • 25 переглядів
  • Остання відповідь від chiaroscuro

more options

Chase.com only displays in text after Firefox updated to version 24. Tested on two different computers with FFv24 and same result. Chase.com loads correctly using Internet Explorer.

Chase.com only displays in text after Firefox updated to version 24. Tested on two different computers with FFv24 and same result. Chase.com loads correctly using Internet Explorer.

Обране рішення

I fixed the loading issue by setting network.http.sendRefererHeader back to 2 (the default) from 0. Note that 1 doesn't work either. Only 2 will cause the site to load properly.

Given that 0 worked in 23 on chase.com, I think this is likely a bug in 24.

I'm seeing NS_ERROR_NET_RESET for CSS, JS and image requests when loading the page with sendRefererHeader set to 0. When it's set to 2, everything goes through clean. The requests that had previously failed had Referer = "https://www.chase.com". It looks like Chase is refusing to serve the additional resources without referer being set.

My guess is that 23 sent the site itself as referer even when sendRefererHeader was 0, but 24 doesn't. Perhaps another configuration option is needed that allows same site referer (no harm in that), but doesn't send any other referer info?

Читати цю відповідь у контексті 👍 4

Усі відповіді (5)

more options

hello kydave, i don't have any issues accessing the site with firefox 24 - please see if going through the common troubleshooting procedure covered in Websites look wrong or appear differently than they should can fix the problem...

more options

Вибране рішення

I fixed the loading issue by setting network.http.sendRefererHeader back to 2 (the default) from 0. Note that 1 doesn't work either. Only 2 will cause the site to load properly.

Given that 0 worked in 23 on chase.com, I think this is likely a bug in 24.

I'm seeing NS_ERROR_NET_RESET for CSS, JS and image requests when loading the page with sendRefererHeader set to 0. When it's set to 2, everything goes through clean. The requests that had previously failed had Referer = "https://www.chase.com". It looks like Chase is refusing to serve the additional resources without referer being set.

My guess is that 23 sent the site itself as referer even when sendRefererHeader was 0, but 24 doesn't. Perhaps another configuration option is needed that allows same site referer (no harm in that), but doesn't send any other referer info?

more options

There is a separate pref for secure web pages (network.http.sendSecureXSiteReferrer, defaults to true), so if you need to adjust the pref for a regular http connection then the page may include content retrieved via a secure connection.

more options

Changing network.http.sendSecureXSiteReferrer didn't affect the problem. The only setting that will make chase.com work with FF24 is sendRefererHeader = 2 (it works whether sendSecureXSiteReferrer is true or false). And toggling sendSecureXSiteReferrer when sendRefererHeader is 0 or 1 had no effect: it still didn't work.

more options

admoman said - "The only setting that will make chase.com work with FF24 is sendRefererHeader = 2"

Same here. Only for me the site mostly worked, except for certain functions. I could access my accounts normally, but when I went to look at 'Recent Activity' on my ccards, there was no list. I called Chase and complained, and they told me to use Chrome. I then fired off a (secure) email to Chase from inside my account, and when they answered, I could not read it with FF24. Clicking on 'inbox' from within the account did nothing. I had to go in with Chrome to read the message, which said "Choose 'all activity' from the drop-down box." There IS NO drop-down box in FF24.

I googled the problem, wound up here, and made the change suggested by admoman, and it fixed the problem. I had recently changed 'sendRefererHeader = 0' after reading an article on security.

Thanks admoman!

Змінено chiaroscuro