Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Ця тема перенесена в архів. Якщо вам потрібна допомога, запитайте.

New Yahoo Search Changes

  • 11 відповідей
  • 4 мають цю проблему
  • 18 переглядів
  • Остання відповідь від JackNaylorPE

more options

I have always used Yahoo search; while Firefox had Google as the default, I would change it to Yahoo. I would sometimes try google but one of the things that annoyed me with Google was if you clicked on a link, that link would, by default, open on the same page forcing you to "go back" to see the list again. With Yahoo OTOH clicking on a link would always open in a new tab allowing me to more easily go back and forth between selected links.

Yes I know I can right click and open in a new tab but is there any way to get the old default behavior back where a normal left click on the Yahoo search results open in a new tab ? I have a condition which affects my right hand and using the right click button can sometimes be gets cumbersome at times.

I have always used Yahoo search; while Firefox had Google as the default, I would change it to Yahoo. I would sometimes try google but one of the things that annoyed me with Google was if you clicked on a link, that link would, by default, open on the same page forcing you to "go back" to see the list again. With Yahoo OTOH clicking on a link would always open in a new tab allowing me to more easily go back and forth between selected links. Yes I know I can right click and open in a new tab but is there any way to get the old default behavior back where a normal left click on the Yahoo search results open in a new tab ? I have a condition which affects my right hand and using the right click button can sometimes be gets cumbersome at times.

Усі відповіді (11)

more options
more options

Note that you can also middle-click a link with the mouse wheel to open a link in a new tab.

For the Google website you can set preferences on the Google results page via the gear icon in the top right corner, click that button to open the menu list and select Search settings.

Google settings are stored in a PREF cookie on your computer, so you need to create an allow exception to keep cookies for Google to save that setting, otherwise you have to repeat it.

Змінено cor-el

more options

1. Iam....

I read the description on the add-on, the feature list dos not appear to address the referenced change in 34.x Trying it, it chagged nothing.

2. Cor-el

I have been on-line since the late 80's and aside from my hand's physical limitations which make it hard to use the right or middle click, breaking a 25 year old habit is something I'd rather not struggle with.

I don't understand what use the how to change behavior of the google web site would be useful ? As indicated above, I have always used Yahoo search, not google.

However following this advice on the Yahoo page results in no change in behavior since the 34.x upgrade. Whether I select "Open in new tab"or "open in current tab" I get the same results.

Змінено JackNaylorPE

more options

Hi @JackNaylorPE

Hope this helps.

Regards, rat

Змінено deadrat

more options

Thanks rat but as you can see in my last message, I have already done that.... no better said it **was** like that....and I have done it (changed back and forth) a dozen times since.

Way it was when I opened it

Open search results Choose where search results open. **In New Tab**

I had changed it to

Open search results Choose where search results open. **In Current Tab** Saved

And then back again to

Open search results Choose where search results open. **In New Tab** Saved

No matter what the setting, it does the same thing. I have done this several times and have done the Addon suggested in the 1st response.

When I change the "results per page", it changes to the appropriate selection (10 or 20, whatever is selected), however no matter what the setting is in the drop down for "open new tab" / "open current tab", it always uses the current tab, this behavior started with the 34.x upgrade and no changes to the settings have any effect.

more options

JackNaylorPE said

Thanks rat but as you can see in my last message, I have already done that.... no better said it **was** like that....and I have done it (changed back and forth) a dozen times since. Way it was when I opened it Open search results Choose where search results open. **In New Tab** I had changed it to Open search results Choose where search results open. **In Current Tab** Saved And then back again to Open search results Choose where search results open. **In New Tab** Saved No matter what the setting, it does the same thing. I have done this several times and have done the Addon suggested in the 1st response. When I change the "results per page", it changes to the appropriate selection (10 or 20, whatever is selected), however no matter what the setting is in the drop down for "open new tab" / "open current tab", it always uses the current tab, this behavior started with the 34.x upgrade and no changes to the settings have any effect.

Oh, sorry about that. I am using Firefox on fedora, so I couldn't really try that and I do not have windows in any of my machines now. Please try this one thing.

  • Remove the search provider "Yahoo" completely from firefox.
  • Then go to search.yahoo.com and re-add the search provider.

Please try this and see if it works.

more options

No luck ..... tho I am not sure how one is supposed to "add a search provider" at search.yahoo.com .... there is no option of this page to do this.

I am presented with the Yahoo logo and a box to put in a search term and than these links at the bottom

   Yahoo - Help - Privacy - Terms - Advertise - Submit Your Site

Using the site to search results in the same behavior

I also tried restarting in safe mode, behavior persists. However, i find chainging the same setting does open it in new page.

This is what's in about:config

Preference Name ,. Status Type Value browser.contentHandlers.types.0.title default string My Yahoo!

browser.contentHandlers.types.0.uri default string https:/ / add.my.yahoo.com/rss ?u rl =%s

browser.search.defaultenginename.US default string Yahoo

browser.search.order.2 default string Yahoo

browser.search.order.US.l default string Yahoo

browser.search.param.yahoo-fr default string moz35

browser.search.param.yahoo-fr-ja default string mozff

browser.search.selectedEngine user set string Yahoo

browser.startup.homepage user set string https://www.yahoo.com/

extensions.securespeeddial.searchEngine user set string yahoo

gecko.handlerService.schemes.mailto.0.name default string Yahoo! Mail

gecko.handlerService.schemes.mailto0.uriTemplate default string https:/ / compose.mail.yahoo.com/?To=%s

searchreset.backup.browser.startup.homepage user set string https://www.yahoo.com/

Змінено JackNaylorPE

more options

If you have problems using middle-click, you can use Ctrl+left-click instead.

more options

I appreciate your response for another work around but what I am really looking for is a solution to the problem which began with the latest upgrade.

If it comes to using a workaround, I'll simply use Google. The history of Firefox's relationship with Google / Yahoo is interesting in that when they switched from Yahoo to Google, it was a real PITA to get Yahoo back. I really would prefer to use Yahoo, always have as I find the results more relevant. Ironic that if no actual solution can be found, Firefox's reversal to put Yahoo back as the default browser will finally result in me switching to Google.

The settings offers a choice of having one behavior or another. It should work.

Змінено JackNaylorPE

more options

JackNaylorPE ,

Prepare to thank me. LOL.

This should work. I downloaded Win 10 and tried this on Firefox and it worked perfectly.

  • Click on the magnifying glass icon in the Search bar, then click on Change Search Settings, as shown here:
search prefs 34

In the Search settings panel that opens, select Yahoo and click on Remove (see this screenshot).

  • Now Go to search.yahoo.com and try a search. It should work the way you wanted.
  • Just click on Yahoo! on it and add the search engine back.

Yahoo!, it works.



Please let me know if this helps!

more options

It didn't work at first, but eventually got there.

1. Your screenshot shows the method of selecting Yahoo as the default search provider. There is no option to "remove". I select Firefox Help and underneath uncheck Yahoo and all other providers and then set it as default.

2. I then go to search.yahoo.com and try a search. It does work the way I wanted.... for whatever reason it wouldn't yesterday.

3. I go to Go to http://mycroftproject.com/yahoo-search-plugins.html , scrolled down to 16. Major Engines , Yahoo! en-WW (search.yahoo.com) by Denny Kluge. This was what I had to do when Firefox 1st changed the default to Google.

4. I added it and had two Yahoo's in the list, I checked the 2nd one. Add something in the search windows, hit the down arrow and elected Yahoo to search with. It didn't work, same behavior as before.

5. I then changed to selecting Yahoo again as the default.

6. Now here's the weird part .....

a) With Yahoo selected as the default and letting it work as the default, it works as desired.

b) With Yahoo selected as the default, but using the Yahoo selection as an option, it doesn't work.

I have since unchecked the Yahoo box in the list of "alternate search engines to display " while leaving it selected as the default selection. It's worked 3 times so far; hopefully it survives a close and reopen :)

Muchos Grassyass. I dreaded trying to find the mycroft site again as it took me quite a while the last time.

Змінено JackNaylorPE