Не працюють закладки та історія


Ця стаття стосується Firefox версій 3.5 та наступних. Якщо у вас проблеми з закладками у Firefox 3.0.x, перегляньте статтю Закладки та кнопки панелі інструментів не працюють після оновлення.

Ви бачите наступне повідомлення одразу після запуску Firefox? -+Система закладок та історії не функціонує через те що один з файлів Firefox використовується іншою програмою. Дії деяких захисних програм (скажімо, антивірусів) можуть бути причиною+- Це значить, що Firefox не може редагувати файл (не має доступу до нього) places.sqlite, у якому зберігаються ваші закладки та історія. Ця стаття поянює два можливі способи вирішення цієї проблеми.

Якщо ви не бачите вище вказаного повідомлення про помилку, перегляньте наступні статті замість цієї:


Рішення 1: Перезавантажте свій комп'ютер

Зазвичай, причиною даної помилки є те, що якась стороння програма використовує файл places.sqlite, і тим самим, замикає його від інших або файл став пошкодженим в результаті несподіваного закриття комп'ютеру (наприклад, при збої живлення від електромережі). В цьому випадку, просто перезавантажте комп'ютер і запустіть заново Firefox, що повинно вирішити проблему.

Рішення 2: Створіть нову базу даних places

Якщо перезавантаження комп'ютеру не допомогло, вкажіть Firefox створити нову базу даних places. Не хвилюйтесь, зробити це дуже просто.

Крок 1 – Відкрийте теку свого профілю

Firefox 3.6:

      1. Зверху вікна Firefox натисніть менюВ панелі меню натисніть Довідка та оберіть Вирішення проблем.... Відкриється вкладка Вирішення проблем.
      2. В розділі Інформація про програму натисніть кнопку Відкрити відповідну теку. З'явиться вікно, в якому відкрита тека вашого профілю. Перейдіть до кроку 2.

Firefox 3.5:

Windows Vista та 7

        1. Натисніть кнопку Windows Запустити та в полі пошуку унизу надрукуйте %APPDATA%\Mozilla\Firefox\Profiles\ без натискання клавіші Enter. У верхній частині меню Запустити з'явиться список профілів.
        2. Натисніть профіль із словом “default” в своїй назві, щоб відкрити його у провіднику.

          9d6c9fba4aa49676832eb2cab4c24abc-1260349726-745-1.png

Windows 2000 та XP

        1. Натисніть кнопку Windows Пуск та оберіть пункт Виконати....

          9d6c9fba4aa49676832eb2cab4c24abc-1259313405-945-1.png
        2. Вдрукуйте %APPDATA%\Mozilla\Firefox\Profiles\ та натисніть кнопку OK.

          9d6c9fba4aa49676832eb2cab4c24abc-1259313454-505-1.png
        3. Відкриється вікно провідника з теками профілів.
        4. Клацніть двічі по теці, що має в слово “default” в своїй назві.
      1. Відкрийте Finder та перейдіть в домашню теку. Зауважте, що назва домашньої теки зазвичай співпадає зі скороченим ім'ям вашого облікового запису у Mac
      2. З вашої домашньої теки відкрийте /Library/, потім /Application Support/, потім /Firefox/, потім теку /Profiles/. Ваша тека профілю знаходиться в цій теці.
      1. (Ubuntu) У верхньому куті екрану праворуч у меню Місця оберіть Домівка. З'явиться вікно переглядача файлів.
      2. В меню Вигляд оберіть Показувати приховані файли, якщо воно ще не вибрано.
      3. Клацніть двічі по теці позначеній як .mozilla.
      4. Клацніть двічі по теці позначеній як firefox. Ваша тека профілю знаходиться в цій теці.

Крок 2 – Створіть базу даних

    1. Зверху вікна Firefox натисніть кнопку Firefox (меню Файл у Windows XP), потім ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл, потім оберіть ВийтиЗверху вікна Firefox натисніть меню Файл та оберіть ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл та оберіть Вийти. Firefox буде повністю закрито.
    2. В теці профілю Firefox віднайдіть та перейменуйте файли places.sqlite та places.sqlite-journal (останній файл якщо існує).
      • Щоб перейменувати файл, клацніть по ньому правою кнопкою миші та в контекстному меню оберіть пункт Перейменувати клацніть по ньому раз - файл виділиться, клацніть по ньому ще раз - його назву можна буде редагувати. Потім додайте в кінець назви .old.
    1. Відкрийте заново Firefox.
      • Коли Firefox буде запущено, він створить нову базу даних places. Буде втрачено вашу історію переглядів, проте Firefox автоматично імпортує ваші закладки з найостаннішої резервної копії закладок.
      • Якщо ваші закладки не імпортувались після створення нової бази даних places, перегляньте статтю Втрачені закладки.

Допоможіть! Виконання дій цієї статті не вирішило моєї проблеми

Дана проблема має симптоми, схожі з іншими проблемами. Можливо, одна з наступних статей стане вам у пригоді.

Ця стаття допомогла? Зачекайте...

Цю статтю допомогли написати такі гарні люди: Bogdancev. Ви теж можете допомогти - дізнайтесь як.