Закладки не збереглися


Неможливо додати нові закладки чи зробити інші зміни

Якщо ви не можете додавати нові закладки чи якщо ви зробили зміни в панелі інструментів, а вони не збереглися після перезапуску Firefox, перегляньте статтю Панель інструментів продовжує скидатись.

Якщо ви не можете додавати нові закладки чи робити інші зміни в своїх закладках і маєте встановлене розширення щодо роботи з закладками (наприклад, для синхронізації закладок чи знаходження дублюючих закладок), виконайте інструкції статті Вирішення проблем пов`язаних з розширеннями та темами, щоб зрозуміти, чи то розширення є причиною проблеми.

Рекомендується вимкнути усі розширення, які пов'язані з закладками, як пояснюється в вище зазначеній статті, перед тим, як продовжувати виконання наведених нижче способів усунення даної проблеми.


Зміни зникають після перезапуску Firefox

Якщо ви можете додавати, вилучати, впорядковувати та робити інші зміни з вашими закладками, але всі ці зміни зникають після перезапуску Firefox, спробуйте наступне.

Налаштування рlaces

Якщо зміни до закладок не зберігаються після перезапуску Firefox 3, скиньте налаштування browser.places на типові:

  1. Надрукуйте в панелі адрес about:config та натисніть клавішу EnterReturn. ** З'явиться сторінка з повідомленням "Обережніше, цією сторінкою можна порізатись!"'. Щоб продовжити, натисніть кнопку Я буду обережним, обіцяю!.

    f1a49071cc33f163ae0bf63faab918da-1281275779-299-1.png

  2. В полі Фільтр вдрукуйте browser.places
  3. Для кожного налаштування browser.places, що має Стан встановлено користувачем, натисніть правою кнопкою мишіутримуючи клавішу Ctrl натисніть кнопкою миші по ньому та виберіть Скинути.

База даних "рlaces"

Закладки та історія переглядів зберігається в теці профілю Firefox у файлі places.sqlite. Якщо з цим файлом виникли проблеми, зміни внесені в закладки можуть втрачатись після перезапуску Firefox. Ви можете вирішити проблему шляхом спонукання Firefox перебудувати базу даних Places:

  1. Відкрийте теку свого профілю:

    At the top of the Firefox window, click on the Firefox button, go over to the Help menuOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  2. Under the Application Basics section, click on Show FolderShow in FinderOpen Directory. A window with your profile filesfolder will open.
  3. Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

  4. Зверху вікна Firefox натисніть кнопку Firefox (меню Файл у Windows XP), потім ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл, потім оберіть ВийтиЗверху вікна Firefox натисніть меню Файл та оберіть ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл та оберіть Вийти.
  5. У вашій теці профілю вилучіть файл places.sqlite та, якщо існує, файл places.sqlite-journal.
  6. (Необов'язково) Також вилучіть файл localstore.rdf, тим самим ви скинене усі зміни, зроблені на панелі інструментів.

Firefox створить новий файл places.sqlite і автоматично імпортує найостанніший файл резервної копію закладок.

Примітка: Можливо, вам знадобиться зробити те саме з файлом browser.places для скидання налаштувань на типові.

Файл закладок захищений від запису

Якщо зміни, внесені в закладки, зникають після перезапуску Firefox, можливо файл закладок є захищеним від записку. Захищений від запису файл не може бути змінений, що запобігає збереженню ваших редагувань у закладках.

Щоб увімкнути запис файлу закладок:

  1. Відкрийте теку свого профілю:

    At the top of the Firefox window, click on the Firefox button, go over to the Help menuOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  2. Under the Application Basics section, click on Show FolderShow in FinderOpen Directory. A window with your profile filesfolder will open.
  3. Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

  4. Зверху вікна Firefox натисніть кнопку Firefox (меню Файл у Windows XP), потім ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл, потім оберіть ВийтиЗверху вікна Firefox натисніть меню Файл та оберіть ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл та оберіть Вийти.
  5. Клацніть правою кнопкою миші по файлу plac​es.sqli​te та оберіть Властивості.
  6. У віконці властивостей перейдіть на вкладку Загальні. Внизу віконця перевірте, що опція Лише читання не вибрана.

    f1a49071cc33f163ae0bf63faab918da-1281275726-187-1.png

Щоб увімкнути запис файлу закладок:

  1. Відкрийте теку свого профілю:

    At the top of the Firefox window, click on the Firefox button, go over to the Help menuOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  2. Under the Application Basics section, click on Show FolderShow in FinderOpen Directory. A window with your profile filesfolder will open.
  3. Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

  4. Зверху вікна Firefox натисніть кнопку Firefox (меню Файл у Windows XP), потім ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл, потім оберіть ВийтиЗверху вікна Firefox натисніть меню Файл та оберіть ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл та оберіть Вийти.
  5. Виділіть файл​ plac​es.sqli​te.
  6. В панелі меню оберіть File, потім Get Info.
  7. У віконці інформації про файл places.sqlite зніміть галочку з чекбоксу Locked.




Базується на інформації зі статті Закладки не збереглись (база знань Мозілазін)

Ця стаття допомогла? Зачекайте...

Цю статтю допомогли написати такі гарні люди: Bogdancev. Ви теж можете допомогти - дізнайтесь як.