Відкривання файлів PDF за допомогою Firefox

Adobe ще не підтримує модуль для перегляду файлів PDF за допомогою Firefox для комп'ютерів з системою Mac OS X. Для перегляду PDF за допомогою Firefox:

  • Якщо у вас Mac з процесором PowerPC, може бути використаний модуль Schubert|it PDF Browser Plugin.
  • Якщо у вас Mac з процесором Intel, може бути використаний модуль Firefox PDF Plugin.

Відображається тільки перша сторінка (Mac 10.5 та попередні версії)

Якщо документ відкривається за допомогою Firefox, проте відображається тільки перша сторінка, впевніться, що додаток QuickTime не налаштований керувати змістом PDF:

  1. З меню Apple оберіть System Preferences.
  2. З меню View, оберіть QuickTime.
  3. Оберіть вкладку Plug-In та клацніть на MIME settings....
  4. У списку MIME types клацніть далі на трикутник до "Images - Still image files".
  5. Якщо обрано "PDF Image", зніміть мітку.
  6. Клацніть OK

Модуль Adobe Reader може бути використаний для перегляду файлів PDF всередині вікна браузера Firefox. Якщо виникли проблеми з модулем, тоді перегляд стає неможливим. Коли ми спробуєте переглянути PDF, замість цього Firefox може спробувати завантажити його.

За подальшою інформацією про модуль Adobe Reader дивіться Використання модуля Adobe Reader у Firefox.


Перевірте налаштування Firefox

  1. Зверху вікна Firefox натисніть кнопку Firefox (меню Інструменти у Windows XP) та оберіть НалаштуванняВ панелі меню натисніть Firefox та оберіть Налаштування...Зверху вікна Firefox натисніть меню Правка та оберіть НалаштуванняЗверху вікна Firefox натисніть меню Інструменти та оберіть Налаштування...В панелі меню натисніть Firefox та оберіть Налаштування...Зверху вікна Firefox натисніть меню Правка та оберіть Налаштування...
  2. Перейдіть на панель Програми.
  3. Знайдіть Adobe Acrobat Document у цьому списку та клацніть на ньому, щоб його обрати.
  4. Клацніть на стрілку випадаючого меню в колонці Дія для запису Adobe Acrobat Document та оберіть Використовувати Adobe Acrobat (у Firefox).

    a109520fd9b5ff9cf19db0fbcec6f4bc-1258002265-650-1.png

    • Якщо Використовувати Adobe Acrobat (у Firefox) немає у списку, перегляньте Скидання дії нижче, а потім повторіть знову дані інструкції.
  1. Натисніть кнопку OK, щоб закрити вікно НалаштуванняНатисніть кнопку Закрити, щоб вийти з вікна НалаштуванняЗакрийте вікно Налаштування

Спробуйте тепер переглянути PDF за допомогою Firefox. Якщо він відкриється у вікні браузеру, тоді проблему вирішено. Якщо ні, продовжіть виконувати наступні інструкції.

Скидання дії

  1. Відкрийте теку свого профілю:

    At the top of the Firefox window, click on the Firefox button, go over to the Help menuOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  2. Under the Application Basics section, click on Show FolderShow in FinderOpen Directory. A window with your profile filesfolder will open.
  3. Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

  4. Зверху вікна Firefox натисніть кнопку Firefox (меню Файл у Windows XP), потім ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл, потім оберіть ВийтиЗверху вікна Firefox натисніть меню Файл та оберіть ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл та оберіть Вийти.
  5. Вилучіть файл mimetypes.rdf.

Перевірте налаштування Adobe Reader

  1. Відкрийте Adobe Reader.
  2. Спочатку у Adobe Reader клацніть меню Edit, потім Preferences... - відкриється вікно налаштувань.
  3. В секції Categories, клацніть по Internet.
  4. Впевніться, що опція Display PDF in browser відмічена.
  5. Клацніть OK, щоб закрити вікно налаштувань та закрийте Adobe Reader.

Спробуйте тепер переглянути PDF. Якщо він відкриється у вікні браузеру, тоді проблему вирішено. Якщо ні, продовжіть наступні інструкції з усунення неполадок.

Перевстановіть модуль

  1. Закрийте Firefox.
  2. Відкрийте теку встановлення Adobe Reader. Якщо Reader 9 встановлений у типовому місці, то шлях до неї такий: C:\Program Files\Adobe\Reader 9.0\Reader\.
  3. В ній відкрийте теку Browser.
  4. Скопіюйте файл nppdf32.dll до теки модулів Firefox: Клацніть правою клавішею по файлу та оберіть Копіювати з контекстного меню. Перейдіть до теки модулів Firefox (тобто, C:\Program Files\Mozilla Firefox\plugins) та вставте цей файл.
  5. Відкрийте Firefox та вдрукуйте у панелі адрес about:plugins для відображення списку модулів Firefox.
  6. Віднайдіть запис Adobe Acrobat.

Якщо запис там, спробуйте переглянути PDF. Якщо він відкриється у вікні браузеру, тоді проблему вирішено. Якщо ні, продовжіть наступні інструкції з усунення неполадок.

Переініціалізуйте базу даних модулів

Додержуйтесь інструкцій розділу Переініціалізація бази даних модулів статті Вирішення проблем пов`язаних з модулями.

Це змусить Firefox побудувати заново свою базу даних модулів. Спробуйте тепер переглянути PDF. Якщо він відкриється у вікні браузеру, тоді проблему вирішено.

Перевстановіть Adobe Reader

Якщо методи по усуненню проблем, зазначені вище не спрацювали, де-інсталюйте та встановіть Adobe Reader заново:

  • Перегляньте інструкції щодо де-інсталювання (Reader версії 8 та вище). Ви повинні також де-інсталювати будь-яку іншу версію програми Reader, що встановлено у вас .
  • Встановіть останню версію програми Adobe Reader зі сторінки завантаження Adobe. На цій сторінці перейдіть по посиланню "Different language or operating system? (інші мови та операційні системи)" для вибору української версії. На наступній сторінці у верхньому випадаючому списку оберіть вашу операційну систему, а в нижньому - мову. Потім натисніть кнопку "Continue(продовжити) і "Download now (завантажити зараз)". Щоб переконатись, що ваша установка Adobe Reader включає найостанніші оновлення безпеки та стабільності, відкрийте Adobe Reader, в меню Довідка оберіть Перевірити наявність оновлень....

Подальша інформація

Якщо жодні методи по усуненню проблем не допомогли, за додатковими інструкціями перегляньте сторінку по усуненню проблем від Adobe.

Ця стаття допомогла? Зачекайте...

Цю статтю допомогли написати такі гарні люди: Bogdancev. Ви теж можете допомогти - дізнайтесь як.