Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New tab page FF13.0 doesn't show thumbnails of sites, only empty box but site is mentioned.

  • 37 பதிலளிப்புகள்
  • 1188 இந்த பிரச்னைகள் உள்ளது
  • 13736 views
  • Last reply by cor-el

Updated to this version but the new tab page didn't save my most visited sites as is the intention. Dragged my most used websites over there and worked but there is no thumbnail-picture or anything to show, just empty boxes with just below the site described as in my bookmarks.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

The thumbnails on the about:newtab page are generated from the cache, so if the page is not in the cache or otherwise can't be rendered as a PNG image then you will get an empty box.
Do not use Clear Recent History to clear data when you close Firefox.
If there is no history then you get an about:newtab page with empty boxes.

Read this answer in context 👍 31

All Replies (20)

Hey Ostrakizein,

I just tried this on FF 13 and I can reproduce what you are reporting. However, if I then click on each of those links to actually load the page then the thumbnails appear the next time I open the new tabs page. You might want to give that a try.

Hopefully this helps!

Just clicked every link, closed FF and even restarted my computer to see but still nothing appears... It's just a small annoyance but do you have any other ideas to solve this?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

The thumbnails on the about:newtab page are generated from the cache, so if the page is not in the cache or otherwise can't be rendered as a PNG image then you will get an empty box.
Do not use Clear Recent History to clear data when you close Firefox.
If there is no history then you get an about:newtab page with empty boxes.

Here's the exact procedure to fix this problem (I'm translating from the french version so please be understanding):

1-Go in Tools - Options - Privacy tab 2-In the History drop down menu, you need to select "keep all history". If you don't like Firefox to be configured that way, then forget it this will not work. 3-Click on the + to open up a new tab 4-Click on one of the links under an invisible thumbnail and make sure you let the website load completely before doing anything else 5-Click on the + to open up a new tab again. This time you will see the thumbnail relating to the page you let load. 6-Repeat this process for each link that still show an invisible thumbnail

I have this problem. I tried the options above (keep history), let linked pages load completely, and also clearing cache (in case the cache was full - suggested here: https://support.mozilla.org/en-US/kb/thumbnails-on-new-tab-page-are-missing?s=new+tab&r=1&e=es&as=s). None worked so far. I'm using Firefox on Kubuntu.

Here's the correct procedure to fix this problem:

1) Click the orange Firefox tab, then Options, or if you have the Menu bar showing, click Tools, Options

2) In the Options window, click Privacy

3) Under the History section, either choose Remember History, or:

4) With Use custom settings for history selected, and the Clear history when Firefox closes check box checked, click the Settings button to the right of this check box, and in the Settings for Clearing History window, under the History section, you'll have to uncheck Cache. Having Cache checked clears the cache when Firefox closes. The New Tab page preview uses this cache to fill-in the pages with graphics. With Cache unchecked, you can browse to a site and its page will have a graphic on the new tab page.

Hi Chad, - thanks for quick reply. The solution did not immediately solve the problem for me. I found further info here: https://bugzilla.mozilla.org/show_bug.cgi?id=726267 . I was able to solve by going to: about:config and changing: browser.cache.disk.enable to "true".

The thumbnails now show up.

I also toggled the Cache setting you mentioned under custom settings for history. As you mentioned, the cache setting needs to be unchecked.

I'm getting this message..

The address isn't valid The URL is not valid and cannot be loaded.

Web addresses are usually written like
   http://www.example.com/
Make sure that you're using forward slashes (i.e.   /).

How do I get to "browser.cache.disk.enable"? I cant find any access to a configure screen.

I found it - both were "true".

The thumbnails on the about:newtab page are generated from the cache, so if the page is not in the cache or otherwise can't be rendered as a PNG image then you will get an empty box.
Do not use Clear Recent History to clear data when you close Firefox.
If there is no history then you get an about:newtab page with empty boxes.

Make sure that you do not run Firefox in permanent Private Browsing mode.

My New Tab Page does not work at all. I just have the empty squares with nothing in them at all? Why is this

what i dont get is this...i like having my cache cleared and all i want is a thumbnail....is there no way to have both? I mean when i bookmark a page the favicon stays on there even though i clear my cache and history and everything. No way to just take a snapshot or something?

Future Firefox versions will use its own thumbnails folder to store the thumbnails to avoid this choice, but that won't happen in Firefox 13.

  • bug 744388 - [Page Thumbnails] implement a custom storage, don't use the file cache

(please do not comment in bug reports)

cor-el மூலமாக திருத்தப்பட்டது

For some reason mine have started working now,!!!

Thanks chad_work for your help resolving this issue.

romaba மூலமாக திருத்தப்பட்டது

I have also found that this feature will not work with encrypted (SSL) pages.

I have also tried all the cache-related fixes suggested on this page, and am having the same problem. I'm running 14.0-b6 from the firefox-next PPA on Ubuntu (Precise), but have been having htis problem since the early 13.0 betas. Thanks!

Fidodido1966, I follow your procedure and it worked fine. Many thanks for such a clear strategy!!!!

  1. 1
  2. 2