Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't access router setup

  • 20 பதிலளிப்புகள்
  • 62 இந்த பிரச்னைகள் உள்ளது
  • Last reply by dwdallam

Since Firefox updated itself yesterday I have been unable to access my router's setup. My router is a D-link and uses the usual access address of : The following message is received. "Corrupted Content Error The page you are trying to view cannot be shown because an error in the data transmission was detected." Three other browsers on my system do not encounter this problem. Access to on-line addresses is normal.

All Replies (20)

Have you tried clearing your cache that may help

[[How to clear the cache|]]

Thanks, but it was one of the first things I tried - it made no difference.

I am having the same problem and my router is also a D-Link. I Had to access the router via other broswer...

The only solution till now is to force a complete refresh [CNTR]-[F5], this will cause a reload of all the page. Mozilla probably has trouble with the "IF-Modified-Since" header. The problem is not limited to a D-Link router, but to other devices too (network printers) and even webserver software.

I believe the problem is due to a security issue. I have this issue with Firefox and also with Safari on my Mac. Here's what I think is happening: The same IP address, namely is used for routers on three systems I access; at my home, my daughter's home and my summer house. So *I think* when a browser sees multiple MAC addresses for it reacts as if someone were trying to redirect me to a "bad" site. I get a security warning. When this first happened (at my summer house) I switched from Firefox to Safari and I was able to access the router. But then when my daughter asked me to help with the new router at her home neither Firefox nor Safari would talk to it. Somehow I need to able to defeat that to access multiple routers.... or I have to change their IP addresses so they're not the same. I'll try cleaning out the cache, cleaning recent history, and see if that works.

Mozilla released a new version of its browser, version 8, but the problem of access to the router D-Link remains.

Is the technical support will provide a solution to this?

teco மூலமாக திருத்தப்பட்டது

It's good to know someone else is interested. I wonder if anyone is attempting to solve the problem and how many people have been affected. Meanwhile I use one of 3 alternative browsers to access my router. A great nuisance though.

I have a similar problem that began with FF8 (or perhaps FF7).

When I try to access my SMC 7400 router, I get the log-on screen (, but when I enter my log-on information, it goes to, and displays

[html] [head] [meta http-equiv=refresh content='0; url=index.htm'] [end-head] [end-html]

(where "[" and "]" have been substituted for the less-than and greater-than delimiters, and the word "end-" has been substituted for the oblique "end" delimiter, so I can actually post the information with this forum software)

This is the only "source code" it shows for the page.

Everything still works fine with IE8, so presumably FF8 cannot interpret some of the HTML code between the two screens properly.

cdgoldin மூலமாக திருத்தப்பட்டது

redundant comment deleted

cdgoldin மூலமாக திருத்தப்பட்டது

redundant comment deleted

cdgoldin மூலமாக திருத்தப்பட்டது

redundant comment deleted

cdgoldin மூலமாக திருத்தப்பட்டது

The problem remains with FF9. The problem remains with FF10. The problem remains with FF11. I only have problems with FF to connect the router . Nobody solves the problem ??? I think the problem is with FF not with the router (FF6 works fine).

tojomanel மூலமாக திருத்தப்பட்டது

At last! This problem has been solved in the beta Firefox/Aurora version 14.0a2. If any Aurora developer knows how perhaps they could pass the information on to regular Firefox developers. Thank you Aurora.

I began having this problem today. But, after thinking about it, I realized that last night I had changed one of the options. I undid it, and now all is well again logging into my router.

The solution for me was to uncheck "Tell websites I do not want to be tracked" on the Privacy tab, in the Options window.

NCEDAUS மூலமாக திருத்தப்பட்டது

I'm glad this worked for you but when I tried it on my version of Firefox (not Aurora) the problem remained.

Firefox 12 -- still too dumb to access a simple router page.

Closing session control over. . . .

Opening IE. . . . .

Great job Firefox!

I'm being sarcastic because this has been going on for - EVER! And no clearing my browser cache didn't work, and if I ever hear that again I'm gonna commit homicide. Also, turning off "Tell Websites. . ." didn't do anything either. Pretty embarrassing having to go to IE to fix the problem.

dwdallam மூலமாக திருத்தப்பட்டது

As I posted a couple of weeks ago the problem has been solved in Firefox/Aurora version 14.0a2. The trouble is that those working on the development of the program seem to jealously guard their own patch and never listen to others - but then, since the whole enterprise is free and voluntary I suppose we should only carp quietly. I really do recommend that anyone with this problem tries Firefox Aurora. It seems stable. A disadvantage is that it won't allow you to override Add-on compatibility settings which are frequently over cautious but I suppose most people don't want to do this. Here's the link:-

Aurora? I'll have to read up on that. Anything I should know about it that isn't already in the FAQ? I mean my first thought is, "Why another Firefox?"

I think it's just a temporary name for what they describe as a pre-beta version of Firefox. It seems to be identical in almost every way.The link I gave before was mistakenly for betas. Aurora is a sort of alpha. This is the direct link You can have both this and your current Firefox version on your computer at the same time but I only use Aurora now.

OK I remember now. It's a test platform. Thank you.