Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

why am I getting chinese-looking text on my web pages?

  • 15 பதிலளிப்புகள்
  • 42 இந்த பிரச்னைகள் உள்ளது
  • 12097 views
  • Last reply by megarren

Some web pages I open up have chinese-looking text in places. It seems to be where advertisements might be (after looking at the page through Safari) but sometimes it is the whole page.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You're welcome

Could you please click the "Solved it" button to mark the thread as solved?

Read this answer in context 👍 0

All Replies (15)

You can do a check for corrupted fonts and other font issues:

Hi, I have a Mac Mini running Mac OSX version 10.5.8 and have this problem when I'm running Firefox version 4.0.1. Safari doesn't seem to have the problem. Some of my web pages show these chinese-looking characters, not like any of the samples shown in the link in your reply. I am attaching an image of a page from the KMart online shopping site, hopefully this will help you. Thanks

Looks that you are on UTF-16 encoding.
Switch to View > Character Encoding > Western (ISO-8859-1)

You can check the default encoding in:

  • Firefox > Preferences > Content : Fonts & Colors > Advanced

cor-el மூலமாக திருத்தப்பட்டது

Hell0 again. Thank you so much for your reply. You are quite right about my encoding settings. I have gone in and changed both, first in View and then in Firefox Preferences but still have the same problem. Do I need to shut down and start again or anything for the settings to change? (sorry, not really very savvy with all this stuff). Thanks again.

Does that page display correctly if you set the encoding to ISO-8859-1 ?

Reload web page(s) and bypass the cache.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)

Yes! Woohoo that worked! Now, will that stay in place for all the web pages or will I just have to wait and see?

Hopefully it will stay, but in case that it happens again then check the encoding and reload the page and bypass the cache.

Thank you very much. Maybe catch you again if I have another problem later. Megarren

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You're welcome

Could you please click the "Solved it" button to mark the thread as solved?

I'm sorry, I'm getting the chinese-looking text on my Webjet flights page now. I've checked the encoding is all still on Western (ISO-8859-1) and reloaded the page using Cmnd+Shift+R and it didn't make any difference. (This page didn't do this before.) What do you think?

Is View > Character Encoding also showing Western (ISO-8859-1), because that determines what you see?

OK, when I opened up Webjet last night, saw the problem and sent you the message I had checked View and thought it was still on Western (ISO 5889-1). But when I checked it again just now after reading your message it was back on UTF. I have changed it back to ISO 5889-1 and all is well again! Thank you again. Megarren

You're welcome.

Quite strange that Firefox chooses the wrong encoding.

Is the server sending an encoding via the response headers or via meta tag in the file or is Firefox guessing wrong?

Hello, sorry took so long to reply but I don't know enough to answer the last questions. I have, however, just checked a couple of likely suspect web pages but I don't have any problems tonight - even though my View has chosen to be back on UTF-8. Would it make any difference that I have increased my internet allowance, (it had reached capacity and was running slow now)?

PS Internet running nice and fast again now