Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

very slow downloading webpages with Firefox 3.6.8; no problem with IE;

  • 46 பதிலளிப்புகள்
  • 1007 இந்த பிரச்னைகள் உள்ளது
  • 69 views
  • Last reply by megatronky

Firefox is very slow loading web pages. Was OK with the old version. This happened after I downloaded latest upgraded version 3.6.8

This happened

Every time Firefox opened

== after loading new version of Firefox, 3.6.8

All Replies (6)

Try a new profile. If you're like me and you've been using the same profile for years due to passwords that are stored in it, it's easy to copy them to the new profile.

Create the new profile. From the old profile, copy:

signons.sqlite signons2.txt signons3.txt key3.db

And then just use bookmarks->manage bookmarks->backup (and restore in new profile) and you're good to go. Have to update the addons but that's probably the problem anyway, relic addons...

I'm a not a firefox admin or whatever, just some dude that got sick of uber slow firefox but refused to use anything else :)

For most users that pages are loading slow, or losing computer performance, it is more likely your computer can't handle Firefox 4 as it uses allot more resources than the previous versions.

Try downgrading to a previous version of Firefox

very tired of using firefox today, every page load 2-3 minutes where the chrome ,opera and IE can do it in just seconds

Every update of 3.6 just keeps getting worse, nothing seems to be fixed and more bugs are introduced all the time. The developers are either stifled in politics and red-tap or have lost the plot of being the fastest browser around.

The developer forums are full of promises for things to be fixed but I am just not seeing it materialise. 3.6.6 introduced some new bugs that web pages load slower and the browser after being open for a few minutes starts hooking the mouse and there's a delay on everything you click on. 3.6.8 has the very same bug, obviously some sort of memory leak. It's nothing to do with plugins/add ons either because I did a test, disabled all the addons and the problem remains.

What I DID do was downgrade to 3.5.11 and all is working fine again. I will avoid any future versions of 3.6 as clearly the developers ideas of what a decent browser is does not match with what actual users expect and I'm not seeing the developers listening to the many complaints about 3.6 .... clearly this version was rushed to market with serious bugs and I would say everyone should avoid it and downgrade to 3.5.x

As one user here said mozilla has become Bloatware which is sad because they have always had the correct attitude towards browsing but something has clearly gone horribly wrong.

I disabled the add-on "Microsoft .NET Framework Assistant 1.1" and my problems went away.

I use to have the same problem. I found it to be a Addon, specifically the "AVG Safe Search". Once I disabled that everything seems to working great again.

  1. 1
  2. 2
  3. 3