Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox extremely slow to load pages or connect to Web sites after startup - Follow-Up

  • 8 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by mobilesuit

I see my original question is now archived at https://support.mozilla.org/en-US/questions/1380948#question-reply I never closed it because I didn't know if my last process could really fix the issue. It didn't, not always. Over the years, there have been times when the issue would still pop up, but not as often as before (2022 and earlier).

I have a feeling that during an issue, FF is having difficulty setting up shop after starting up. Consequently, it is spending more time before it could become prepared to connect to the Net. I've come up with another "solution," which is deleting (or moving out) xulstore.json in the profile folder after exiting or before starting FF. You can create a batch command or script to execute the process.

So far, FF is connecting immediately after startup.

I see my original question is now archived at https://support.mozilla.org/en-US/questions/1380948#question-reply I never closed it because I didn't know if my last process could really fix the issue. '''It didn't''', not always. Over the years, there have been times when the issue would still pop up, but not as often as before (2022 and earlier). I have a feeling that during an issue, FF is having difficulty setting up shop after starting up. Consequently, it is spending more time before it could become prepared to connect to the Net. I've come up with another "solution," which is deleting (or moving out) ''xulstore.json'' in the profile folder after exiting or before starting FF. You can create a batch command or script to execute the process. So far, FF is connecting immediately after startup.

All Replies (8)

In that previous thread you wrote that your problem might be caused by not giving Firefox to close down properly before shutting down the computer.

Are you using "Clear history when Firefox closes" to clear data like the disk cache and in that case closing Firefox can take more time and Firefox will finish pending tasks on the next start?

Helpful?

Thanks for the response.

"Firefox will finish pending tasks on the next start" That's something new.

I use custom settings for history.

I usually close FF only when shutting the computer at the end of the day. What I've been doing via batch command since 2022 (?) - because of the issue - is to allow 60 secs after exiting FF before shutting down the computer. This because I notice that if I exit FF and start it again immediately, FF would complain that it hasn't totally closed or a window would pop up asking whether to restart or quit FF. So, I give it time to properly close shop. It helps in minimizing occurrence of the issue on the next start up.

Before, I even created a batch command to help FF dump crash reports, if they existed, during exit, but now I just give it more time.

Helpful?

Have to report. As before, it doesn't work all the time.

Helpful?

mobilesuit said

Have to report. As before, it doesn't work all the time.

This because...

I created a batch command to close FF and delete xulstore.json. Apparently, the file is not being deleted every time, even when command is executed in administrator mode; hence, failure to fix the original issue at times.

I am introducing some seconds of delay after exiting FF before deleting xulstore.json. The initial tests show it's working.

We'll see.

Helpful?

How big is your xulstore.json file typically? Do you have a lot of windows in your session?

Helpful?

zeroknight said

How big is your xulstore.json file typically? Do you have a lot of windows in your session?

Only 1KB.

I usually have some tabs open all the time, not windows.

Helpful?

Does it still happen with default settings in a new browser profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile. Make sure you don't sign in to the browser with your Mozilla account while testing to avoid syncing across any settings.

Helpful?

zeroknight said

Does it still happen with default settings in a new browser profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile. Make sure you don't sign in to the browser with your Mozilla account while testing to avoid syncing across any settings.

Using a new profile or resetting FF is, of course, the ultimate solution. It's one of the first suggestions - and the easiest to try - in the old links; but it's a bloody one in my case and I won't explain why here (yes, I have FF browser sync, of course). In the old links, I remember somebody tried it. The issue was gone, for a while.

. . .

Allow me to state the issue again. My FF always ("always" meaning it has existed through the years and versions, but it's not 10 out of 10 starting up) has this issue of having to wait for a few or longer minutes to ***initially*** connect to the Internet. Once it connects, then everything's just fine. It's not happening with the other browsers in the same system, setup, and time.

Imagine you don't know how long you have to wait for the traffic light to turn green because it could be a few minutes or longer. Sometimes the lights have the issue, sometimes they don't. That's the pain, hence I have to find a solution.

So far, using batch command to automatically remove the xulstore.json some seconds after closing FF is working. Meaning, the issue has not popped up.

I notice my xulstore.json contains only parameters for the FF window. You see, there were times in the past when FF was not remembering the last window size. One effective solution I found was to remove the file and let FF create it again upon starting. I noticed that when this happened, the issue never came up. So, I am removing the file as a *remedy* for the issue.

. . .

I thought somebody would notice and inquire about the "batch command" and "command is executed in administrator mode" in my previous message. Perhaps, I didn't add "automatically?" (chuckle!) This is a FF forum after all, so anyway.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.