Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does my firefox always prefer IPv4, while IPv6 is still available?

  • 12 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 349 views
  • Last reply by tempwall

My ISP had provided the IPv6 service, edge/chrome/vivaldi are all IPv6 first and working well. Only firefox insists use IPv4, although it could also pass the IPv6 test on https://test-ipv6.com, and the internal test on https://detectportal.firefox.com/success.txt?ipv6 It leads to some webpage extremely slow, even could not be accessed.

I've tried privacy mode, but the problem is still there. IPv6 in about:config is enabled, all related options are default. Is this a bug, or if there is any way could fix it by some special settings?

Waiting for your help, thanks.

My ISP had provided the IPv6 service, edge/chrome/vivaldi are all IPv6 first and working well. Only firefox insists use IPv4, although it could also pass the IPv6 test on https://test-ipv6.com, and the internal test on https://detectportal.firefox.com/success.txt?ipv6 It leads to some webpage extremely slow, even could not be accessed. I've tried privacy mode, but the problem is still there. IPv6 in about:config is enabled, all related options are default. Is this a bug, or if there is any way could fix it by some special settings? Waiting for your help, thanks.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

It is OK now, after updated to 121.0。 Or maybe my ISP updated sth, I cound not confirm it. Thank you all for your help.

Read this answer in context 👍 0

All Replies (12)

Update: I've tried set a custom 3rd-party dns server in dns over https, ipv6 seems working now. I'm confused, why?

I could use it as a temporarily solution, but there should be a better answer to firefox.

Helpful?

The "ipv6-test" site reports IPv6 is default for me in a new profile (see screenshot).

Try changing DNS over HTTPS (DoH) to "Off" or "Max Protection" and in Connection Settings change "Use system proxy settings" to "No proxy".

Helpful?

zeroknight said

The "ipv6-test" site reports IPv6 is default for me in a new profile (see screenshot). Try changing DNS over HTTPS (DoH) to "Off" or "Max Protection" and in Connection Settings change "Use system proxy settings" to "No proxy".

I do believe it is not a common bug, but it is there to some user. Thanks for your suggestion, but it does not work for me.

In addition: ipv6-test.com also reports that I'm IPv4 in default, and could fall back to IPv6 in 1 second.

tempwall மூலமாக திருத்தப்பட்டது

Helpful?

zeroknight said

The "ipv6-test" site reports IPv6 is default for me in a new profile (see screenshot). Try changing DNS over HTTPS (DoH) to "Off" or "Max Protection" and in Connection Settings change "Use system proxy settings" to "No proxy".

Thanks for your suggestion, but they are not available to me. ipv6-test also said that I'm default in v4, and could fallback to v6 in 1 seconds.

Helpful?

Does it still happen in a new profile without signing into sync? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

Helpful?

zeroknight said

Does it still happen in a new profile without signing into sync? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

Thanks for your follow. As you mentioned, I've just created a new profile and tested in it. Yes, it happens again, ipv4 default, and fallback to ipv6 in 1 second.

In my opinion, it's interesting that DoH setting could be helpful. Maybe it indicated sth, for example, how does firefox switch between ipv4 and ipv6?

Helpful?

Go to about:networking#dnslookuptool in the address bar and resolve a domain to see if it returns any IPv6 addresses.

Helpful?

What is your DHCP handing out, IPv4 or 6 addresses? see screenshot

Helpful?

zeroknight said

Go to about:networking#dnslookuptool in the address bar and resolve a domain to see if it returns any IPv6 addresses.

Wow..it's interesting. There are IPv6 addresses in both DNS, but at the top of the 3rd party, bottom of the ISP. Will it make influence?

Helpful?

jonzn4SUSE said

What is your DHCP handing out, IPv4 or 6 addresses? see screenshot

Thanks for your help. I think it's OK, my IPv6 service works perfectly in edge and chrome. Even firefox, what the test-ipv6 said is, "you've connected to IPv6 network, but your browser do not prefer it." And it shows the correct public IPv6 address of my computer.

Helpful?

I turned on IPv6 only and this site stopped working for me.  ;-)) I see the owner didn't turn it on.

jonzn4SUSE மூலமாக திருத்தப்பட்டது

Helpful?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

It is OK now, after updated to 121.0。 Or maybe my ISP updated sth, I cound not confirm it. Thank you all for your help.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.