Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to set focus on newtab page and not the url bar

  • 4 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 30 views
  • Last reply by n6v26r

When I open a new tab, i would like the page to be in focus and not the urlbar. This is what i used to have in my mozilla.cfg: ``` // Auto focus new tab content try {

 Cu.import("resource://gre/modules/Services.jsm");
 Cu.import("resource:///modules/BrowserWindowTracker.jsm");
 Services.obs.addObserver((event) => {
   window = BrowserWindowTracker.getTopWindow();
   window.gBrowser.selectedBrowser.focus();
 }, "browser-open-newtab-start");

} catch(e) { Cu.reportError(e); } ``` This worked until the last update. What solutions are there?

When I open a new tab, i would like the page to be in focus and not the urlbar. This is what i used to have in my mozilla.cfg: ``` // Auto focus new tab content try { Cu.import("resource://gre/modules/Services.jsm"); Cu.import("resource:///modules/BrowserWindowTracker.jsm"); Services.obs.addObserver((event) => { window = BrowserWindowTracker.getTopWindow(); window.gBrowser.selectedBrowser.focus(); }, "browser-open-newtab-start"); } catch(e) { Cu.reportError(e); } ``` This worked until the last update. What solutions are there?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Services is now a global variable and you can no longer use Cu.import. You need to remove all thes lines.

Cu.import("resource://gre/modules/Services.jsm");

You can this instead in older (e.g. 115 ESR) and newer (117+) Firefox versions.

const Services = globalThis.Services || ChromeUtils.import("resource://gre/modules/Services.jsm").Services;

Read this answer in context 👍 1

All Replies (4)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Services is now a global variable and you can no longer use Cu.import. You need to remove all thes lines.

Cu.import("resource://gre/modules/Services.jsm");

You can this instead in older (e.g. 115 ESR) and newer (117+) Firefox versions.

const Services = globalThis.Services || ChromeUtils.import("resource://gre/modules/Services.jsm").Services;

Helpful?

Hey! I know this isn't related to the original question, but is there a way to also do this for the startpage?

Helpful?

The search bar you see on the Firefox Home page is not a real search bar, but is a fake search bar and even the cursor is fake as you can see if you check this in the inspector (right-click: Inspect), even the For now there is a pref to revert this change.

  • about:config => browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar = false

Helpful?

Hmmm. I don't think that does It. I was talking about the url bar, not the search bar on the page. I think this is specific to me. I forced a different new tab page in mozilla.cfg and applied the patch above for cursor focus. It appears that when the startpage has the same url, the cursor doesn t focus corectly. So, for now, setting one with file:// and one without, magically worked.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.