On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

DevEd update to 103.0b2 just made everything in the browser HUGE.

  • 8 பதிலளிப்புகள்
  • 5 இந்த பிரச்னைகள் உள்ளது
  • 131 views
  • Last reply by Paul

Win 10, Developer Edition 103.0b2

This update caused everything to increase in size. Tabs & toolbars are much bigger now. Toolbar and bookmarks toolbar used to fit in the window with no overflow, now both have a lot of items in overflow.

Sites that used to fit at 100% zoom now have to be reduced to 80% or 67% to fit on-screen.

Just wondering what could cause this behavior? Settings?

Note: Browser window is fully maximized and no other program on my Win10 box has this issue.

Win 10, Developer Edition 103.0b2 This update caused everything to increase in size. Tabs & toolbars are much bigger now. Toolbar and bookmarks toolbar used to fit in the window with no overflow, now both have a lot of items in overflow. Sites that used to fit at 100% zoom now have to be reduced to 80% or 67% to fit on-screen. Just wondering what could cause this behavior? Settings? Note: Browser window is fully maximized and no other program on my Win10 box has this issue.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Could you take a look at the following preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste devp and pause while the list is filtered

Firefox should show one preference: layout.css.devPixelsPerPx

The default value of this preference is -1.0, which instructs Firefox to apply your system-level scaling to Firefox's user interface as well as web content.

You can modify this value to a specific size, but please be careful not to make it too small or too enormous as it can be painful to recover from that.

Example values for standard displays (if you use a Retina display or other double-density display, double these numbers):

  • 1.0 => 100% of the standard 96dpi
  • 1.25 => 125% of the standard 96dpi
  • 1.5 => 150% of the standard 96dpi
  • 0.9 => 90% of the standard 96dpi
  • Note: do not use negative values

(3) To edit this preference value, double-click the preference (or click the pencil button) to display an editing field, and change the value as desired, then press Enter or click the blue check mark button to save the change.

Can you find a comfortable size?

Read this answer in context 👍 2

All Replies (8)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Could you take a look at the following preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste devp and pause while the list is filtered

Firefox should show one preference: layout.css.devPixelsPerPx

The default value of this preference is -1.0, which instructs Firefox to apply your system-level scaling to Firefox's user interface as well as web content.

You can modify this value to a specific size, but please be careful not to make it too small or too enormous as it can be painful to recover from that.

Example values for standard displays (if you use a Retina display or other double-density display, double these numbers):

  • 1.0 => 100% of the standard 96dpi
  • 1.25 => 125% of the standard 96dpi
  • 1.5 => 150% of the standard 96dpi
  • 0.9 => 90% of the standard 96dpi
  • Note: do not use negative values

(3) To edit this preference value, double-click the preference (or click the pencil button) to display an editing field, and change the value as desired, then press Enter or click the blue check mark button to save the change.

Can you find a comfortable size?

Helpful?

I see you cross-posted on r/Firefox: https://www.reddit.com/r/firefox/comments/vnpip6/deved_update_to_1030b2_just_made_everything_in/

Let us know what you discover.

Helpful?

layout.css.devPixelsPerPx was set to -1.0. Changed it to .8 and that got me back to the size it was previously. Thanks for pointing me to that setting.

Helpful?

and what if mine is 175%? i tried 1.5 (almost same as it was) but the writing on my tabs is tiny as hell :S

whyyy firefox whyyyy

Helpful?

This behavior is a bug. Having to specify 1.85 in order to get the look of -1 (2.0 in my case) is not how the pref should work. Also setting the pref to less than the OS DPI makes the various toolbar and context menus smaller. The pref works as it should for menus while other content makes things huge. This also includes toolbar icons and add-on menus. Whatever caused this should be backed out.

Helpful?

moderndefender said

and what if mine is 175%? i tried 1.5 (almost same as it was) but the writing on my tabs is tiny as hell :S

Do you mean the toolbars are tall/thick but the text is still tiny? Or everything is tiny?

streetwolf said

This behavior is a bug.

There is a fix in testing in the beta of Firefox 103 but I don't know whether it will get uplifted to Firefox 102 (if there is a Firefox 102.0.1). There is something else to try, but it also seems imperfect. See next reply.

jscher2000 - Support Volunteer மூலமாக திருத்தப்பட்டது

Helpful?

A new preference was just added to help control this, but I haven't experimented with it myself:

browser.display.os-zoom-behavior

Available values:

  • 0 => Ignore the OS-level scaling (per tester on Reddit, might make UI text smaller than version 102)
  • 1 => Apply OS-level scaling as proportional zoom [default]
  • 2 => Apply OS-level scaling as text-only zoom

A user posted a table on Reddit describing what is affected by these different values:

https://www.reddit.com/r/firefox/comments/vnpip6/deved_update_to_1030b2_just_made_everything_in/ie9zzoe/

Other References:

Helpful?

Hi

While there is not an easy way to revert this our product team did suggest this about:config preference change as the optimal solution at this time.

  1. In the address bar, type about:config and press the Enter key.
  2. The about:config warning page may appear. Click Accept the Risk and Continue to continue to the about:config page.
  3. In the search field, enter browser.display.os-zoom-behavior, select the pencil "edit" icon and change the number to 0.
  4. Select the check mark and restart Firefox.

They did note they would look into alternative options which may be present in a future update.

WARNING from the moderator team: Changing Firefox pref from the about:config page can sometimes break Firefox or cause strange behavior. You should only do this if you know what you're doing.

Please read Firefox advanced customization and configuration options to learn more.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.